LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-18-2013, 06:35 AM   #1
a.abdulna
Member
 
Registered: Feb 2013
Location: Bangalore
Distribution: Rhel
Posts: 86

Rep: Reputation: Disabled
Am not able to do anything!


Hi,

I have a problem with RHEL 6.3, whenever am trying to create a folder am getting this error.

[root@VMCV ~]# mkdir INDIGO
mkdir: cannot create directory `INDIGO': Read-only file system

and while creating user also, its not allowing, see below..

[root@VMCV ~]# useradd indigo
useradd: cannot lock /etc/passwd; try again later.


Please find below details..

[root@VMCV ~]# cat /etc/fstab

#
# /etc/fstab
# Created by anaconda on Wed Jun 5 06:13:46 2013
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
#
/dev/mapper/vg_vmnep-lv_root / ext4 defaults 1 1
UUID=d9833e40-d4cd-45bd-8202-3157585ac296 /boot ext4 defaults 1 2
/dev/mapper/vg_vmnep-lv_swap swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0


[root@VMCV ~]# mount
/dev/mapper/vg_vmnep-lv_root on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_ubject_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev)

mount: warning: /etc/mtab is not writable (e.g. read-only filesystem).
It's possible that information reported by mount(8) is not
up to date. For actual information about system mount points
check the /proc/mounts file.

How can i resolve this issue, anybody knows please help me out..

Regards,
Abdul

Last edited by a.abdulna; 06-18-2013 at 06:37 AM.
 
Old 06-18-2013, 06:47 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Quote:
Originally Posted by a.abdulna View Post
[root@VMCV ~]# mount
/dev/mapper/vg_vmnep-lv_root on / type ext4 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw,rootcontext="system_ubject_r:tmpfs_t:s0")
/dev/sda1 on /boot type ext4 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
gvfs-fuse-daemon on /root/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev)

mount: warning: /etc/mtab is not writable (e.g. read-only filesystem).
It's possible that information reported by mount(8) is not
up to date. For actual information about system mount points
check the /proc/mounts file.
Have you done what is suggested by the mount command?
 
Old 06-18-2013, 06:49 AM   #3
a.abdulna
Member
 
Registered: Feb 2013
Location: Bangalore
Distribution: Rhel
Posts: 86

Original Poster
Rep: Reputation: Disabled
no, what i need to do?
 
Old 06-18-2013, 06:52 AM   #4
mddnix
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch, Ubuntu
Posts: 498

Rep: Reputation: 137Reputation: 137
Try
Code:
# mount -o remount,rw /
 
Old 06-18-2013, 06:54 AM   #5
a.abdulna
Member
 
Registered: Feb 2013
Location: Bangalore
Distribution: Rhel
Posts: 86

Original Poster
Rep: Reputation: Disabled
@mddesai,

[root@VMCV ~]# mount -o remount,rw /
mount: cannot remount block device /dev/mapper/vg_vmnep-lv_root read-write, is write-protected
[root@VMCV ~]#
 
Old 06-18-2013, 06:54 AM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387Reputation: 2387
Quote:
Originally Posted by a.abdulna View Post
no, what i need to do?
As stated: Check the content of /proc/mounts.

mount (and other programs) get their information from this file (among others). The output might not be different from the mount command, but one or more partitions seem to be mounted read only.

You should also check the output of the dmesg command. I'm not sure if this is stored on a partition, I do believe it is not and should produce boot information which might tell you what went wrong.
 
Old 06-18-2013, 07:11 AM   #7
a.abdulna
Member
 
Registered: Feb 2013
Location: Bangalore
Distribution: Rhel
Posts: 86

Original Poster
Rep: Reputation: Disabled
In dmesg am getting file system remounted as read only

[root@VMCV ~]# dmesg|grep read-only
Write protecting the kernel read-only data: 10240k
EXT4-fs (dm-0): Remounting filesystem read-only
[root@VMCV ~]#

and /proc/mounts also it is showing ready only

[root@VMCV ~]# cat /proc/mounts
rootfs / rootfs rw 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
sysfs /sys sysfs rw,seclabel,nosuid,nodev,noexec,relatime 0 0
devtmpfs /dev devtmpfs rw,seclabel,nosuid,relatime,size=3029264k,nr_inodes=757316,mode=755 0 0
devpts /dev/pts devpts rw,seclabel,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /dev/shm tmpfs rw,seclabel,nosuid,nodev,relatime 0 0

/dev/mapper/vg_vmnep-lv_root / ext4 ro,seclabel,relatime,barrier=1,data=ordered 0 0

none /selinux selinuxfs rw,relatime 0 0
devtmpfs /dev devtmpfs rw,seclabel,nosuid,relatime,size=3029264k,nr_inodes=757316,mode=755 0 0
/proc/bus/usb /proc/bus/usb usbfs rw,relatime 0 0
/dev/sda1 /boot ext4 rw,seclabel,relatime,barrier=1,data=ordered 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw,relatime 0 0
sunrpc /var/lib/nfs/rpc_pipefs rpc_pipefs rw,relatime 0 0
/etc/auto.misc /misc autofs rw,relatime,fd=7,pgrp=1532,timeout=300,minproto=5,maxproto=5,indirect 0 0
-hosts /net autofs rw,relatime,fd=13,pgrp=1532,timeout=300,minproto=5,maxproto=5,indirect 0 0
gvfs-fuse-daemon /root/.gvfs fuse.gvfs-fuse-daemon rw,nosuid,nodev,relatime,user_id=0,group_id=0 0 0
[root@VMCV ~]#

how can i make file system as read/write..
 
Old 06-18-2013, 07:20 AM   #8
mddnix
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch, Ubuntu
Posts: 498

Rep: Reputation: 137Reputation: 137
Show results of

Code:
# lvs
# vgs
 
Old 06-18-2013, 07:21 AM   #9
a.abdulna
Member
 
Registered: Feb 2013
Location: Bangalore
Distribution: Rhel
Posts: 86

Original Poster
Rep: Reputation: Disabled
this is the messages am getting ..
[root@VMCV ~]# lvs
File-based locking initialisation failed.
[root@VMCV ~]# vgs
File-based locking initialisation failed.
[root@VMCV ~]#
 
Old 06-18-2013, 07:26 AM   #10
mddnix
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch, Ubuntu
Posts: 498

Rep: Reputation: 137Reputation: 137
Reboot in rescuemode and try fsck
 
1 members found this post helpful.
Old 06-18-2013, 07:29 AM   #11
a.abdulna
Member
 
Registered: Feb 2013
Location: Bangalore
Distribution: Rhel
Posts: 86

Original Poster
Rep: Reputation: Disabled
Dear mddesai thanks for your valuable replay..

i will try fsck and please let me know, what it is happend coz till yesterday it is working fine.
 
Old 06-18-2013, 07:46 AM   #12
mddnix
Member
 
Registered: Mar 2013
Location: Bengaluru, India
Distribution: Redhat, Arch, Ubuntu
Posts: 498

Rep: Reputation: 137Reputation: 137
http://www.cyberciti.biz/tips/linux-...read-only.html
 
Old 06-18-2013, 09:46 AM   #13
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,916

Rep: Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689Reputation: 3689
Quote:
Originally Posted by a.abdulna View Post
Dear mddesai thanks for your valuable replay..
i will try fsck and please let me know, what it is happend coz till yesterday it is working fine.
And again, since you're using RHEL6, have you contacted Red Hat support, since you are PAYING FOR RHEL, right???

Last edited by TB0ne; 06-20-2013 at 09:31 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off




All times are GMT -5. The time now is 06:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration