LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2010, 03:54 PM   #1
jia786
LQ Newbie
 
Registered: Jan 2010
Posts: 29

Rep: Reputation: 15
Always Single user mode


Hi,

I've created Oracle Enterprise 5 Virtual machine. It was running fine but not sure what went wrong and now when ever I reboot the machine, it goes to single user mode. If I enter "init 5" command it boots to multi-user X11 mode without any problem.
I checked inittab file and default line has id 5. So it looks OK. What else can be wrong?

Thanks,
Javed
 
Old 08-10-2010, 04:11 PM   #2
MensaWater
LQ Guru
 
Registered: May 2005
Location: Atlanta Georgia USA
Distribution: Redhat (RHEL), CentOS, Fedora, Debian, FreeBSD, HP-UX, Solaris, SCO
Posts: 6,580
Blog Entries: 14

Rep: Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969Reputation: 969
The line is the following?
Code:
id:5:initdefault:
If so then it sounds like something isn't starting correctly. If you have issues with filesystems mounting or not fsck'ing correctly it will default to single user to do clean up so as to avoid risk to the filesystems. Watch your boot (click on "show details" when the GUI boot screen is being shown so you can see if everything is actually starting).
 
Old 08-10-2010, 04:16 PM   #3
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
Another thing to check would be /etc/grub/grub.conf make sure nobody accidentally placed a 1 or single in the default boot option on the kernel line.
 
Old 08-10-2010, 04:19 PM   #4
jia786
LQ Newbie
 
Registered: Jan 2010
Posts: 29

Original Poster
Rep: Reputation: 15
Thanks for reply.

Yes the line is exactly same. I'll monitor the boot screen to look for any error. A newbie question, I added a disk and the filesystem on it got corrupted but I removed the entry from fstab for auto mount. Will this be a still problem? Should I remove the disk?
 
Old 08-10-2010, 04:29 PM   #5
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
It might lead to a labeling conflict (very common with RHEL/Fedora based Distributions) as they use labels rather then direct partition references in FSTAB. so essentially you can have 2 /, 2/var, 2 /tmp and what not, what can conflict things... Change fstab to physical references to avoid that, also ensure the hard drive is the secondary within BIOS.
 
Old 08-10-2010, 08:00 PM   #6
jia786
LQ Newbie
 
Registered: Jan 2010
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by MensaWater View Post
Watch your boot (click on "show details" when the GUI boot screen is being shown so you can see if everything is actually starting).
last few boot messages are:

Remounting root filesystem in read-write mode: [OK]
Mounting local filesystems: [OK]
Enabling local filesystem quotas: [OK]
Enabling /etc/fstab swaps: [OK]

INIT: Entering runlevel: 1
Entering non-interactive startup
Starting monitoring for VG VolGroup00: 2 logical volume(s) in volume group "VolGroup00" monitored [OK]

Telling INIT to go to single user mode
INIT going single user
INIT sending process the TERM signal
INIT sending process the KILL signal
sh-3.2#


Do ypu see anything wrong in messages?
 
Old 08-11-2010, 03:43 AM   #7
bsat
Member
 
Registered: Feb 2009
Posts: 347

Rep: Reputation: 72
did you check the grub config file as pointed by r3sistance, doesn't look like any thing else is wrong.
 
Old 08-11-2010, 05:29 AM   #8
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
Quote:
Originally Posted by jia786 View Post
last few boot messages are:

INIT: Entering runlevel: 1
Do you see this? It is entering runlevel 1 which is a single user mode. You should check your grub configuration file if you say your inittab file is correct.
/boot/grub/grub.conf should most probably be your file.
See if anyone has passed option to kernel to boot to single user mode.
 
Old 08-11-2010, 09:08 PM   #9
jia786
LQ Newbie
 
Registered: Jan 2010
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by bsat View Post
did you check the grub config file as pointed by r3sistance, doesn't look like any thing else is wrong.
The /boot/grub/grub.conf contents are as follow:

Code:
#boot=/dev/xvda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Enterprise Linux Enterprise Linux Server (2.6.18-92.1.1.0.1.el5xen)
        root (hd0,0)
        kernel /vmlinuz-2.6.18-92.1.1.0.1.el5xen ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.18-92.1.1.0.1.el5xen.img
 
Old 08-11-2010, 09:21 PM   #10
jia786
LQ Newbie
 
Registered: Jan 2010
Posts: 29

Original Poster
Rep: Reputation: 15
I also see following in /var/log/messages file. Does the "1" in this line mean that system is booting in single user mode?

kernel: Kernel command line: ro root=/dev/VolGroup00/LogVol00 rhgb quiet 1
 
Old 08-11-2010, 09:36 PM   #11
GrapefruiTgirl
LQ Guru
 
Registered: Dec 2006
Location: underground
Distribution: Slackware64
Posts: 7,594

Rep: Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551Reputation: 551
That's certainly how it looks in post #10; the "1" means single-user mode, or "init 1" - but where's the "1" in post #9? Are you sure that is the correct grub section - is that the entire grub file, and the only grub file?
 
Old 08-12-2010, 03:57 AM   #12
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
Another thing to check, shutdown the VM and use the following command

"xm create -c <virtualmachinename>"

This should allow you to interact with grub, from here you should be able to view the options/lines that are being loaded.
 
Old 08-12-2010, 09:22 PM   #13
jia786
LQ Newbie
 
Registered: Jan 2010
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by GrapefruiTgirl View Post
Are you sure that is the correct grub section - is that the entire grub file, and the only grub file?
I checked /etc/grub.conf and /boot/grub/menu.lst have same contents.

Quote:
Originally Posted by r3sistance
"xm create -c <virtualmachinename>"
This gave me one option only "Enterprise Linux Enterprise Linux Server (2.6.18-92.1.1.0.1.el5xen)". There was no other option.
 
Old 08-13-2010, 05:21 AM   #14
r3sistance
Senior Member
 
Registered: Mar 2004
Location: UK
Distribution: CentOS 5.4, Mac OS 10.4 (tiger)
Posts: 1,005

Rep: Reputation: 79
Quote:
Originally Posted by jia786 View Post
This gave me one option only "Enterprise Linux Enterprise Linux Server (2.6.18-92.1.1.0.1.el5xen)". There was no other option.
ok... if you can do this again, hit "e" on that option, go to the kernel line and hit e again

it should show you a line like "kernel /boot/vmlinuz-2.<kernel build> ro root=<partition>"

Could you possible put down the exact content of that line here?
 
Old 08-13-2010, 06:11 AM   #15
jia786
LQ Newbie
 
Registered: Jan 2010
Posts: 29

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by r3sistance View Post
ok... if you can do this again, hit "e" on that option, go to the kernel line and hit e again

it should show you a line like "kernel /boot/vmlinuz-2.<kernel build> ro root=<partition>"

Could you possible put down the exact content of that line here?
I can see 3 options now:

> root (hd0,0)

> kernel /vmlinuz-2.6.18-92.1.1.0.1.el5xen ro root=/dev/VolGroup00/LogVol00 rhgb quiet

> initrd /initrd-2.6.18-92.1.1.0.1.el5xen.img

Last edited by jia786; 08-13-2010 at 08:50 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
single user mode under vxfs mode enabled. UltraSoul Solaris / OpenSolaris 1 06-27-2009 10:48 PM
single user mode aashishdhabarde Linux - Kernel 1 01-31-2008 06:11 AM
single user mode... navaladi Mandriva 2 12-26-2004 03:41 AM
single user mode ? wr3ck3d Slackware 5 03-29-2003 10:52 AM
What is single-user mode?? rbanonuevo Linux - Newbie 4 01-28-2002 01:17 PM


All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration