LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-22-2009, 09:29 PM   #1
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Rep: Reputation: 15
Alt X screen Sessions are blank


When I try to exit to an other screen session I just get blank screens. ALT + F1-F6 show up as blank screens.

ALT+F7 brings me back but I can not shell into an other session which is really important at times.

I don't believe it is my xorg.conf but not sure what to check?

Checking other posts I found one in 2005 that asked about getty. I have on other comp and ran a "ps aux |grep getty" and the working one showed /sbin/getty for tty 1-6.

The computer I am having trouble with did not have any instance of getty running. What do I need to do now?

Help pls.

Last edited by Legolas327; 12-22-2009 at 09:40 PM.
 
Old 12-22-2009, 09:46 PM   #2
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
When your in X you have to use CTRL-ALT-F1 though F6
 
Old 12-22-2009, 10:27 PM   #3
gregorian
Member
 
Registered: Apr 2006
Posts: 509

Rep: Reputation: 34
I'm not sure but Alt X are generally ignored if Ctrl Alt X work, but the OP is getting blank screens. I remember reading something about /etc/ttys. Could you look into that?
 
Old 12-22-2009, 10:32 PM   #4
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Quote:
When your in X you have to use CTRL-ALT-F1 though F6
Yes sorry for not typing that correctly, but the problem remains.

Added information: In reading more information I compared my two computers. One working correctly and the other not.

The corectly working computer shows that all tty's are set to start/running when I run:

$ initctl list |grep tty

however the none working comp shows:

$initctl list |grep tty
tty4 stop/waiting

for all 6 tty's

Does anyone know where to find out why the tty's are not starting their process?

I think I should point out that I am running Ubuntu Karmic 9.10 on X64 platform with duel screens. I thought perhaps my xorg.conf may be the culprit but don't think so now.
 
Old 12-23-2009, 06:13 PM   #5
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
I found this possible solution.

Quote:


Switching the console to a framebuffer mode, with, e.g.

vga=791

in grub's menu.lst works around this for me, in that I can see my TTYs again. As soon as xorg starts with the nvidia restricted drivers, a text mode TTY is borked though; so not a fix.
I found this in an ubuntu bug report here https://bugs.launchpad.net/ubuntu/+s...ux/+bug/282068
 
Old 12-23-2009, 11:27 PM   #6
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
After comparing an searching and comparing I finally removed my duel monitor xorg.conf file and used the base one created by automatically and now know that something in my duel monitor xorg.conf file is the issue. When I use a very basic one with out both screens everything works just fine. When I use my duel monitor version it works great but causes the issues I am having. Now having discovered this I am researching what is not liked about the duel monitor xorg.conf file since I have used duel monitors for years with Ubuntu and Fedora. I just have to figure out what I did different this time around.

Ok I used the nvidia-settings to build my xorg.conf file and have the same issues. My Duel monitors work just fine.
However; it wont let me use my other X sessions. I have not had this problem in the past so kind of lost. Here is the xorg.conf file

Code:
:~$ cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@crested)  Sun Feb  1 20:25:37 UTC 2009

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
    Load           "dbe"
    Load           "extmod"
    Load           "type1"
    Load           "freetype"
    Load           "glx"
EndSection

Section "ServerFlags"
    Option         "Xinerama" "0"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "WDE LCM-22w2"
    HorizSync       30.0 - 82.0
    VertRefresh     56.0 - 67.0
    Option         "DPMS"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor1"
    VendorName     "Unknown"
    ModelName      "SHARP HDMI"
    HorizSync       15.0 - 75.0
    VertRefresh     55.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTX"
    BusID          "PCI:2:0:0"
    Screen          0
EndSection

Section "Device"
    Identifier     "Device1"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8800 GTX"
    BusID          "PCI:2:0:0"
    Screen          1
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Device1"
    Monitor        "Monitor1"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Does anyone see a setting that is keeping the X-Sessions from working? Maybe I need to set some resolutions for a text only screen or something?

Last edited by Legolas327; 12-24-2009 at 12:05 AM. Reason: additional information
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl-Alt-F1 = Black,blank screen? timkarwoski Linux - General 16 02-03-2012 06:46 PM
[Suggestion] Ctrl Alt F1 blank screen wongdg Linux - Software 1 10-09-2009 07:40 AM
Suse 9.0 Blank screen instead of login in screen damoncf Linux - Distributions 4 02-24-2007 08:49 PM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 08:13 AM


All times are GMT -5. The time now is 04:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration