LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-16-2011, 09:46 AM   #1
hsiu
LQ Newbie
 
Registered: Dec 2010
Posts: 12

Rep: Reputation: 0
Alsamixer settings getting clobbered on reboot


Hi,

I've found a number of posts about this online, but none of the solutions offered have helped me.

In order to use my laptop's on board microphone, I must go into alsamixer and set "Input Source" to "Front Mic", instead of "Mic" as it is.

When I reset, however, the back to "Mic" it goes.

I have run alsactl store, and if I _manually_ run alsactl restore, the settings are restored.

However, if I add alsactl restore to a startup script, it does not.

I have followed these instructions (bottom post):

http://www.linuxforums.org/forum/sla...tml#post247741

But to no avail. Instead of simply, alsactl restore, I put:

alsactl -d restore >> /home/hsiu/didrcsdrunalsa

Hoping to determine if it was actually running. the file didrcsdrunalsa is created, but there's no debug info in there as alsactl -d usually outputs, so it's difficult to tell. I also put

alsactl -d restore >> /home/hsiu/didrclocalrunalsa.txt

in my /etc/rc.local. Again, the file didrclocalrunalsa.txt is created, but it is 0 bytes, no information.

As I said, if I manually run alsactl [-d] restore at the command line, it works. So, I'm wondering what's happening at startup.

Any advice would be appreciated.
 
Old 01-16-2011, 10:23 AM   #2
ozanbaba
Member
 
Registered: May 2003
Location: Tengiz
Distribution: Slackware64 14.1
Posts: 672

Rep: Reputation: 94
try this;
Code:
/usr/sbin/alsactl -d 2>&1 >> /tmp/alsactllog
(with full path)
 
Old 01-17-2011, 06:05 PM   #3
hsiu
LQ Newbie
 
Registered: Dec 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Thanks for your reply.

I tried using the full path to alsactl and redirected both standard error and out to the log files, but nothing has changed.
 
Old 01-17-2011, 09:57 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,340
Blog Entries: 12

Rep: Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730Reputation: 2730
Do you get any error messages when you run alsactl store?

I just tried it on my Ubuntu laptop with sudo and got a weird output:

Code:
sudo alsactl store
Home directory /home/[username] not ours
Just hazarding a guess, but maybe pulseaudio is interfering with alsa.
 
Old 01-18-2011, 03:26 AM   #5
hsiu
LQ Newbie
 
Registered: Dec 2010
Posts: 12

Original Poster
Rep: Reputation: 0
No, it stores and restores (manually) fine. It also works when I edit it.
 
Old 01-18-2011, 03:32 AM   #6
ozanbaba
Member
 
Registered: May 2003
Location: Tengiz
Distribution: Slackware64 14.1
Posts: 672

Rep: Reputation: 94
Quote:
Originally Posted by frankbell View Post
Do you get any error messages when you run alsactl store?

I just tried it on my Ubuntu laptop with sudo and got a weird output:

Code:
sudo alsactl store
Home directory /home/[username] not ours
Just hazarding a guess, but maybe pulseaudio is interfering with alsa.
I wouldn't call it weird but expected under limited conditions.
 
Old 01-18-2011, 03:35 AM   #7
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hello hsiu,
Quote:
However, if I add alsactl restore to a startup script, it does not.
afaik this cannot work since alsamixer-settings are valid for the user. If you run alsactl at startup, you do it as root, which doesn't change anything with the settings of the user.

I'd try to put the alsactl line into the ~/.xinitrc file which is executed when the X-server starts.

Markus

Last edited by markush; 01-18-2011 at 03:37 AM. Reason: typo
 
Old 02-01-2011, 05:42 AM   #8
hsiu
LQ Newbie
 
Registered: Dec 2010
Posts: 12

Original Poster
Rep: Reputation: 0
Arg, still no luck.

I put the above line in .xinitrc, and this time no file is created at all, not even an empty one, so I don't think .xinitrc is being run at all.
 
Old 02-01-2011, 06:28 AM   #9
ozanbaba
Member
 
Registered: May 2003
Location: Tengiz
Distribution: Slackware64 14.1
Posts: 672

Rep: Reputation: 94
You know, maybe another mixer runs and changes your mixer settings. Maybe pulseaudio indeed get in the way of alsamixer.
 
Old 03-10-2011, 01:22 PM   #10
t.lee.davidson
LQ Newbie
 
Registered: Mar 2011
Posts: 1

Rep: Reputation: 0
I had the same type of problem in that a manual 'alsactl restore' from the command line worked just fine, but yet my sound settings were getting clobbered at boot time. I was able to solve my particular problem.

Before I noticed this problem, I had already disabled PulseAudio to get my Sound Blaster Live! Value working on Mandriva 2010.2 using the KDE4 desktop environment. I used alsamixer to get the settings right and then stored them with 'alsactl store' which saved the settings to '/etc/asound.state'. (If there were more than one sound card in my system, I would also have needed to specify the sound slot number.)

The problem crept in when KDE launched Kmix which was set to "Restore volumes on login" (Kmix [-> mixer] -> Settings -> Configure Kmix...). But instead of disabling that option, I went into Settings -> Configure Channels... and dragged the channels I needed to control from the left-side pane ("Available channels") to the right-side pane ("Visible channels"). I then set them the way I need them to be, and rebooted to test.

Solved.

HTH,
Lee
 
Old 03-10-2011, 01:32 PM   #11
ozanbaba
Member
 
Registered: May 2003
Location: Tengiz
Distribution: Slackware64 14.1
Posts: 672

Rep: Reputation: 94
Heheh kmix did ignores system settings. How I am not surprised hsiu, check other mixer like kmix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsamixer best settings Recursion Linux - Software 1 12-13-2009 12:32 AM
alsamixer settings fakie_flip Linux - Software 1 01-09-2008 08:33 PM
No Sound After Reboot - ALSAMIXER Does not Run. Z3R0o Linux - Hardware 5 01-05-2007 09:37 PM
9.3 alsamixer resetting on reboot ionmich SUSE / openSUSE 4 12-08-2005 08:51 PM
Losing my alsamixer settings after a reboot moger Slackware 4 07-05-2004 11:17 PM


All times are GMT -5. The time now is 10:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration