LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-01-2007, 08:33 AM   #1
Cyhaxor
Member
 
Registered: Nov 2004
Location: UK
Distribution: Fedora 12
Posts: 129

Rep: Reputation: 15
Unhappy alsaconf and sound prob


I run alsaconf as root & alsamixer. I cofigured them and I got sound. I created a user account and I added it to bin & sound groups. I logged in my new account I run the alsamixer I configured it but I am still no having sound in my new account? Is there any farther configuration I have to do?

Thanks in advance,
Cyhaxor
 
Old 10-01-2007, 09:57 AM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,602

Rep: Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532
There is no need to run alsamixer as a user. All you have to do is to run
Code:
alsactl store
after running alsamixer as root, to save your settings.
Then make sure that there is the script /etc/rc.d/rc.alsa and it runs when your box starts.
 
Old 10-01-2007, 10:26 AM   #3
Cyhaxor
Member
 
Registered: Nov 2004
Location: UK
Distribution: Fedora 12
Posts: 129

Original Poster
Rep: Reputation: 15
ok the /etc/rc.d contains the file rc.alsa. But how do I know if it starts when my box comes up? I have sound as root and not as user!
 
Old 10-01-2007, 10:31 AM   #4
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,602

Rep: Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532Reputation: 1532
Quote:
But how do I know if it starts when my box comes up?
If you didn't mess with the various startup scripts, it will come up by default and your alsamixer settings will be restored.
 
Old 10-01-2007, 10:32 AM   #5
Cyhaxor
Member
 
Registered: Nov 2004
Location: UK
Distribution: Fedora 12
Posts: 129

Original Poster
Rep: Reputation: 15
Ok I've just restarted my KDE and I got sound!! Thanks m8!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problems (alsaconf cannot find sound modules.) vmlinuz.gz Linux - Newbie 8 11-12-2008 04:36 AM
no sound even after alsaconf niceday Linux - Hardware 13 08-08-2007 07:11 AM
no sound even after alsaconf ttilt Slackware 17 12-26-2004 07:36 PM
no sound - i have tried alsaconf slackware_03 Linux - Hardware 7 08-25-2004 08:53 AM
Suse9.1/ALSA/Audigy/No Sound/I run alsaconf after reboot(s) to get sound FastFeet Linux - Hardware 23 07-12-2004 06:01 PM


All times are GMT -5. The time now is 03:38 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration