LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-11-2006, 11:41 PM   #1
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Rep: Reputation: 15
ALSA Sound not Working Anymore


Hello. I had my sound system working fine but lost all sound after rebooting. I have an Audigy 2 ZS, running FC5. I think I was fine until I loaded Xine?? can't be sure. Kmix shows my sound card with PCM and all of the channels set properly, but I can't get alsamixer to run (I did before) Let me show what I have so far:

[root@localhost ~]# lsmod |grep '^snd'
snd_intel8x0 32221 0
snd_emu10k1_synth 7745 0
snd_emux_synth 35137 1 snd_emu10k1_synth
snd_seq_virmidi 8001 1 snd_emux_synth
snd_seq_midi_emul 6465 1 snd_emux_synth
snd_emu10k1 117829 2 snd_emu10k1_synth
snd_seq_dummy 4165 0
snd_seq_oss 32705 0
snd_seq_midi_event 7745 2 snd_seq_virmidi,snd_seq_oss
snd_seq 53553 8 snd_emux_synth,snd_seq_virmidi,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_rawmidi 25665 2 snd_seq_virmidi,snd_emu10k1
snd_ac97_codec 92257 2 snd_intel8x0,snd_emu10k1
snd_ac97_bus 2625 1 snd_ac97_codec
snd_seq_device 9037 7 snd_emu10k1_synth,snd_emux_synth,snd_emu10k1,snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi
snd_util_mem 5569 2 snd_emux_synth,snd_emu10k1
snd_pcm_oss 40017 0
snd_mixer_oss 17729 1 snd_pcm_oss
snd_pcm 83781 5 snd_intel8x0,cx88_alsa,snd_emu10k1,snd_ac97_codec,snd_pcm_oss
snd_hwdep 10053 2 snd_emux_synth,snd_emu10k1
snd_timer 24517 3 snd_emu10k1,snd_seq,snd_pcm
snd 55237 19 snd_intel8x0,cx88_alsa,snd_emux_synth,snd_seq_virmidi,snd_emu10k1,snd_seq_oss,snd_seq,snd_rawmidi,sn d_ac97_codec,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_timer
snd_page_alloc 10569 3 snd_intel8x0,snd_emu10k1,snd_pcm

[root@localhost ~]# ls -l /dev/snd/
total 0
crw------- 1 Weston root 116, 15 Sep 11 22:12 controlC0
crw------- 1 Weston root 116, 20 Sep 11 22:12 controlC1
crw------- 1 Weston root 116, 4 Sep 11 22:12 hwC0D0
crw------- 1 Weston root 116, 16 Sep 11 22:12 hwC0D2
crw------- 1 Weston root 116, 6 Sep 11 22:12 midiC0D0
crw------- 1 Weston root 116, 5 Sep 11 22:12 midiC0D1
crw------- 1 Weston root 116, 17 Sep 11 22:12 midiC0D2
crw------- 1 Weston root 116, 18 Sep 11 22:12 midiC0D3
crw------- 1 Weston root 116, 14 Sep 11 22:12 pcmC0D0c
crw------- 1 Weston root 116, 13 Sep 11 22:12 pcmC0D0p
crw------- 1 Weston root 116, 12 Sep 11 22:12 pcmC0D1c
crw------- 1 Weston root 116, 11 Sep 11 22:12 pcmC0D2c
crw------- 1 Weston root 116, 10 Sep 11 22:12 pcmC0D2p
crw------- 1 Weston root 116, 9 Sep 11 22:12 pcmC0D3p
crw------- 1 Weston root 116, 8 Sep 11 22:12 pcmC0D4c
crw------- 1 Weston root 116, 7 Sep 11 22:12 pcmC0D4p
crw------- 1 Weston root 116, 19 Sep 11 22:12 pcmC1D0c
crw------- 1 Weston root 116, 3 Sep 11 22:12 seq
crw------- 1 Weston root 116, 2 Sep 11 22:12 timer
When i try to run alsamixer I get this:
[root@localhost ~]# alsamixer
alsamixer: function snd_ctl_open failed for default: No such device
[root@localhost ~]#

When I look at my modprobe config file I see this.. Not sure if it is ok?
[root@localhost etc]# cat modprobe.conf
alias eth0 skge
alias eth1 forcedeth
alias scsi_hostadapter sata_sil
alias scsi_hostadapter1 sata_nv
alias snd-card-0 snd-emu10k1
options snd-card-0 index=0
options snd-emu10k1 index=0
remove snd-emu10k1 { /usr/sbin/alsactl store 0 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-emu10k1
alias snd-card-1 snd-intel8x0
options snd-card-1 index=1
options snd-intel8x0 index=1
remove snd-intel8x0 { /usr/sbin/alsactl store 1 >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
[root@localhost etc]#
Please help. This is driving me nuts?
 
Old 09-12-2006, 02:56 AM   #2
baikonur
Member
 
Registered: Oct 2005
Location: germany
Distribution: debian
Posts: 255
Blog Entries: 5

Rep: Reputation: 30
When my ALSA conked out lately I just re-ran alsaconf and got it back.
 
Old 09-12-2006, 07:40 AM   #3
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Thanks for the reply. I am a little shy of taking your advice because of the statement in a wiki webesite. Let me know what you think?

I was using the wiki web site shown below to help me out and was worried about the Never part mentioned below. Would this apply to me? I think it would since my sound card is in a PCI slot right?

http://wiki.archlinux.org/index.php/Alsa
All necessary modules should be detected and loaded automatically by udev. No special configuration has to be done unless you use ISA cards. NEVER use alsaconf if you have a PCI or ISAPNP sound card, the entries alsaconf adds to the modprobe.conf file might break udev's autodetection.
Additional information: I get this message when I log in:
Sound server informational message:
Error while initializing the sound driver:
device: default can't be opened for playback (No such file or directory)
The sound server will continue, using the null output device.
Something interesting that I noticed is that my reciever shows the PCM connection which it never has before if the sound card is not working before? Which says that my stereo thinks it is seeing a pcm connection?

Gray
 
Old 09-12-2006, 09:54 AM   #4
baikonur
Member
 
Registered: Oct 2005
Location: germany
Distribution: debian
Posts: 255
Blog Entries: 5

Rep: Reputation: 30
I really don't know. I have an onboard sound chip on my notebook, which makes it a device on the PCI-bus. Alsaconf didn't break my hotplugging system or anything. I noticed that the wiki mentions support for OSS and ISA-Soundcards... that makes me wonder how up-to-date it really is.
I would give alsaconf a try.
You could backup your modprobe.conf / modules.conf if you're really worried. And maybe your /dev directory.
But hey, this is just what I would do. Maybe that isn't the good solution at all. My sound configuration isn't as complex as yours.
Code:
lsmod | grep snd
snd_hda_intel          19668  2
snd_hda_codec         147312  1 snd_hda_intel
Good luck!!
Ps: My soundcard doesn't do everything I want either:
link
 
Old 09-12-2006, 02:54 PM   #5
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Actually I could make copies like you said and see what happens. I am just wondering what happened and of course I want my sound back. Somewhere I changed a config file or something? not sure how or when. I was using a FC5 set up guide to set up my system and all was good until I rebooted.. then Nada, nothing, kaput! < check spelling. Aaaghh this is a pain. Anyone else have any suggestions?
 
Old 09-12-2006, 05:28 PM   #6
ntubski
Senior Member
 
Registered: Nov 2005
Distribution: Arch
Posts: 3,013

Rep: Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225Reputation: 1225
Everytime my sound screws it turned out to be bad mixer settings. Just a suggestion
 
Old 09-12-2006, 07:14 PM   #7
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Re: Alsa not working

I am using the Alsasound built into the kernel ... whenever I rebuild the kernel I need to run alsaconf.

I have never had a problem with this.
I have a maestro 3 pci sound card.
 
Old 09-12-2006, 09:00 PM   #8
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Ok, what am i doing wrong here?

[root@localhost /]# alsaconf
-bash: alsaconf: command not found
 
Old 09-12-2006, 10:10 PM   #9
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Re: Alsa not working

Quote:
Originally Posted by Legolas327
Ok, what am i doing wrong here?

[root@localhost /]# alsaconf
-bash: alsaconf: command not found
Sounds like you do not have alsa-util installed.
 
Old 09-12-2006, 11:59 PM   #10
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Quote:
Quote:
Sounds like you do not have alsa-util installed.
I don't know if I did or not, I did loaded it once before but /shrug It didn't to see it when I looked?

Now for the good news. I was doing a yumex update(rpm update) and ran into a dependency problem with bind-9.3.2-33.fc5. In tying to fix it and I accidently removed the bind rpm which apparently removed/disconnected loads of other applications (can't tell which because they all flashed by my screen as being removed). Crap.. Crap.. crap LOL. As a result, none of my repositories worked and infact, I didn't have and internet connection anymore...just great!!! I did a rescue login with my FC5 DVD and got my internet connection again, reinstalled bind, rebooted and checked my rpms again! (sorry I don't mean to be wordy) my update check showed that alsamixergui-0.9.0-0.3.rc1.fc5 was missing (I had it before). So I loaded it up. rebooted and now I have sound.

Here it is Now:
[root@localhost ~]# rpm -q alsa-util
package alsa-util is not installed
[root@localhost ~]# rpm -qa alsa*
alsa-tools-1.0.10-2.fc5
alsa-lib-1.0.11-4.rc2
alsamixergui-0.9.0-0.3.rc1.fc5
alsa-utils-1.0.11-4.rc2
alsa-lib-devel-1.0.11-4.rc2
[root@localhost ~]#
Question: I would like to back up config files, save listing, modprobe or what-ever I can save/backup. Any suggestions?
From what I have just posed does anyone know or think they know what happened to fix my sound?
 
Old 11-29-2006, 04:41 PM   #11
Legolas327
Member
 
Registered: Apr 2006
Location: Atlanta, GA
Distribution: Ubuntu 9.10
Posts: 69

Original Poster
Rep: Reputation: 15
Red face

This is a reply posting for anyone that has followed this thread. I resolved my issue and I think I conclusively, absolutely, resolved my issue this time

Let me state that I have read just about every ALSA article regarding possible absolutely problems and help suggestions out there. In reading all of them and performing many different corrective tasks, I got a little wiser and started seeing patterns. Every suggestion worked; however, only temporary which begged the question why would my simple computer configuration with the same distro and hardware be so different from the rest of the world that my sound card is detected, not detected, detected.. and so forth.

I finally came to believe/realized that since I was doing everything correctly at the software end so it must be something else.. and it was!

For the rest of you s like me:

CHECK YOUR BIOS sound card detection settings!!!!

My Asus card bios setting for sound card detection was set to AUTO<<< NOT GOOD!! Or at least for me.

After turning OFF the onboard sound card detection all of my detection toggling went bye bye. Now I am all good, there doesn't seem to be any conflict and my Audigy sound card is detected consistently at log in.

I sincerely hope no one else has to go through 6 months of sound card detection toggling.

Legolas
 
Old 11-29-2006, 06:22 PM   #12
derxob
Member
 
Registered: Apr 2006
Location: Los Angeles, California
Distribution: Slackware, Ubuntu
Posts: 68

Rep: Reputation: 15
I'd suggest first checking to see if the mixer settings are correct by running alsamixer. Make sure nothing is muted and nothing is turned down, then try. If that is the case, then store your settings so this does not happen again after you reboot. To store the settings, run alsactl store as root.

Good luck
 
Old 12-22-2006, 05:07 PM   #13
shilam938
LQ Newbie
 
Registered: Dec 2006
Posts: 9

Rep: Reputation: 0
Quote:
Originally Posted by Legolas327
After turning OFF the onboard sound card detection all of my detection toggling went bye bye. Now I am all good, there doesn't seem to be any conflict and my Audigy sound card is detected consistently at log in.

Legolas
Not for everbody !!
I have exactly the same problem as you have and even the same sound card.
I also turned off the onboard sound card detection and my sound worked...
for two days.

now I have the problem back, the card is not always detected.
I really think it's a alsa bug with this hardware.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound card not working anymore on FC5 jialin Fedora 3 04-29-2006 08:08 PM
ALSA not working for Creative Sound Blaster Live 24 Bit sound card vishalsonu Linux - Hardware 7 08-20-2005 02:02 PM
ALSA--> Sound not working browncow Linux - Newbie 8 05-28-2005 01:38 PM
Sound: alsa is not working ryan.n Linux - General 6 10-12-2004 10:19 PM
Sound was working.. rebooted.. alsa start errors... no sound now.. Zero-0-Effect Linux From Scratch 5 03-21-2004 10:58 PM


All times are GMT -5. The time now is 06:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration