LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-07-2016, 10:08 AM   #1
marconap
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Rep: Reputation: 0
Alsa sound not working after removing Pulseaudio


Hi all, I removed pulseaudio in order to get sound working because my monitor is connected through hdmi but I want to keep the audio signal on the PC speaker. I didn't find any trick to make this so I decided to remove pulseaudio.
After removing, all alsa commands give the following errors:

ALSA lib conf.c:3028: ( snd_config_update_r ) Cannot access file /etc/alsa-pulse.conf
ALSA lib pcm.c:2205: ( snd_pcm_open_noupdate ) Unknown PCM default

So, I defined the ALSA_CONFIG_PATH and now I obtain the second error only (Unknown PCM default). If I run alsaconf every seems ok. The test sound from Yast works correctly, but I need to play sounds with aplay at command line level.
The second audio card (hdmi) is unconfigured, but nothing changes if I configure it.

Any suggestion?

Thanks a lot
Marco

Last edited by marconap; 06-07-2016 at 10:10 AM.
 
Old 06-07-2016, 10:43 AM   #2
dolphin_oracle
Member
 
Registered: Dec 2013
Posts: 335

Rep: Reputation: Disabled
opensuse?

the easy way to do this is in pavucontrol (the pusleaudio configuration settings manager) and disable the HDMI profile.
 
Old 06-07-2016, 10:54 AM   #3
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,514
Blog Entries: 1

Rep: Reputation: 489Reputation: 489Reputation: 489Reputation: 489Reputation: 489
pulseaudio over jackd might be what you're after. Or not. In my case the HDMI audio is hw:0,3 which is hard to point at with just pulseaudio / pavucontrol. I know it's that because of $( cat /proc/asound/card0/pcm3p/info ).

You can change pulseaudio options which let you start and stop it, instead of removing it entirely. By default it restarts if it crashes. Just add "autospawn = no" to /etc/pulse/client.conf (in debian). You might need to have multiple .asoundrc configurations when you switch between audio setups.

$ pulseaudio --kill

$ pulseaudio --start

-----

FILE: .asoundrc
Code:
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 0
for using alsa.

-----

FILE: .asoundrc
Code:
pcm.pulse { type pulse }
ctl.pulse { type pulse }
pcm.!default { type pulse }
ctl.!default { type pulse }
for using pulseaudio.

-----

I tend to have both in the .asoundrc and comment (#) out the one I'm not using. The over jackd variant is little more complex and not without it's quirks. But you can access the soundcard with pulseaudio and jackd at the same time. Which is nice for things like jackeq.
 
Old 06-07-2016, 11:11 AM   #4
marconap
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
X11 bell

Thanks, now I got the aplay working.. I solved defining the ALSA_CONFIG_PATH and assigning audio group to the only user of the PC.
But my original problem is to get the X11 bell to work :-(

Marco
 
Old 06-07-2016, 11:27 AM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,514
Blog Entries: 1

Rep: Reputation: 489Reputation: 489Reputation: 489Reputation: 489Reputation: 489
xkbbell ?

$ sudo apt-get install x11-xkb-utils

Not sure if that's the "bell" you're after.
 
Old 06-07-2016, 11:45 AM   #6
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 2,514
Blog Entries: 1

Rep: Reputation: 489Reputation: 489Reputation: 489Reputation: 489Reputation: 489
$ xkbbell -display :0

And then ^G aka [CTRL] + [G] beeps. If that was what you're after. Probably uses the pcspkr output which wont do anything if your motherboard doesn't have that hardware.
 
Old 06-08-2016, 03:24 AM   #7
marconap
LQ Newbie
 
Registered: Feb 2008
Posts: 12

Original Poster
Rep: Reputation: 0
xkbbell is installed but mute. The monitor is connected trough hdmi and I have the suspect that the sound is flowing in that channel. Aplay xxx.wav works fine with the sound card.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Jessie - Have Pulseaudio and ALSA installed. Everything is unmuted and settings show sound outputting but no sound actually playing. jjd3592 Linux - Software 12 03-07-2016 08:10 AM
Debian 8 PulseAudio/Alsa Mic picking up no sound glinkels Linux - Newbie 9 08-21-2015 08:20 PM
[SOLVED] My sound card is not being detected by Debian 8 (Alsa and Pulseaudio) glinkels Linux - Newbie 8 08-08-2015 02:23 PM
Alsa plugin (pulseaudio) not working ordealbyfire83 Linux From Scratch 7 10-22-2014 12:26 AM
sound is very faint (alsa and pulseaudio, Fedora 10) bach-fiend Linux - Newbie 3 02-16-2009 04:11 PM


All times are GMT -5. The time now is 01:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration