LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-16-2005, 08:51 AM   #1
ubernoob8371
LQ Newbie
 
Registered: Apr 2005
Posts: 2

Rep: Reputation: 0
alsa master vloume & 5.1


The problem: The master volume control (alsamixer) only controls the front speaker outs, but has no effect on the rear out or the C/LFE out. All individual controls in the mixer work fine, (I think - 1wk. noob). Sound is fine (no noise, hissing, whines, etc.)



The Setup: some mobo w/ SIS530 & 5595 chipsets, AMD K62-450, 64Megs Ram
Soundblaster Live 5.1
Slack 10.0 distro with 2.6.11.7 kernel, running only Bash (X subsystems installed no frontend though) mp3blaster-3.2.0
gcc 3.3.4 all relevant software is current according to the install docs. and web pages.


I do not get any errors / error messages when running anything.



can't kill and yank (separate PC, which is soon to be Slack
but i think these are the only lines you need from the following


--lspci

00:0c.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 0a)
00:0c.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 0a)


-- lsmod

uhci_hcd 27696
ehci_hcd 25736
sis5513 12136
ohci_hcd 15976
usbcore 98968



I don't really remember everything I've looked at tonight, but these seemed pretty common requests. And when you tell me what you actually need to know or what I need to do. Please be specific

This setup is going into my trunk as the first step of a forever project. I was planning on installing this weekend, this is the last problem,...

If you just reply with a list of links to what I need to read / install / do, that will get me fixed.

Thanks,

8371
 
Old 04-17-2005, 01:46 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 52
i think the solution may be to write a script to manipulate amixer settings so you can move them all at once

example: you make a bash script called volumeup or whatever
#!/bin/bash
amixer set Surround 5+
and put all the sliders you want to move at once in there
then
chmod 755 volumeup
cp volumeup /usr/bin

then the command volumeup should do what you want
 
Old 04-19-2005, 11:19 PM   #3
ubernoob8371
LQ Newbie
 
Registered: Apr 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thank you

Foo_bar_foo, Thanks for the suggestion, that is a good workaround, but I would rather not change shells to change the volume, I'll get it figured out sometime. Thank you again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alsa via82xx - master volume has no effect (dxs 1 does work) crispibits Linux - Software 3 01-11-2007 11:50 AM
Gnome: make volume hotkeys alter PCM chanel instead of MASTER (ALSA) qwijibow Linux - General 1 11-13-2005 10:42 PM
ALSA master volume in Intel sound card miguelmmg Slackware 1 09-19-2005 11:32 AM
No PCM or Master mixer after ALSA install LloydM Linux - Hardware 12 06-24-2005 01:28 PM
Can't change master volume in ALSA.. NO SOUND! SonoranFun Linux - Newbie 5 06-16-2005 08:38 PM


All times are GMT -5. The time now is 09:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration