LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-28-2016, 08:06 AM   #1
Chronic13
LQ Newbie
 
Registered: Nov 2016
Location: Tokyo
Distribution: Fedora
Posts: 15

Rep: Reputation: Disabled
Question alsa installed but no sound


Installed alsa

Also tried using pavucontrol

Lots of options, but no sound...

I think I need to change my default sound card...
 
Old 11-28-2016, 09:42 AM   #2
erik2282
Member
 
Registered: May 2011
Location: TX
Distribution: Debian, CentOS
Posts: 577

Rep: Reputation: 158Reputation: 158
Have you ran alsamixer and poked around in there?
 
Old 11-28-2016, 11:23 AM   #3
Chronic13
LQ Newbie
 
Registered: Nov 2016
Location: Tokyo
Distribution: Fedora
Posts: 15

Original Poster
Rep: Reputation: Disabled
Yes, I've poked around extensively there. Quite confused.

All of my sound cards are being recognized, yet I'm getting no output from my monitor.

Any suggestions?

Thanks!
 
Old 11-28-2016, 12:10 PM   #4
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,160

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
Have you made sure the sound isn't set to "mute" in whatever volume control is provided? Fedora used to have something in System Preferences. It seems silly, but I've seen distros that actually install like that!
 
Old 11-28-2016, 12:18 PM   #5
Chronic13
LQ Newbie
 
Registered: Nov 2016
Location: Tokyo
Distribution: Fedora
Posts: 15

Original Poster
Rep: Reputation: Disabled
Lightbulb

Thank you for your suggestion. I am fairly certain the system is not muted.

Perhaps the following code will help shine a light on what's going on.

Code:
[root@localhost user]# lspci -nnk | grep -i -A7 audio
00:1b.0 Audio device [0403]: Intel Corporation 9 Series Chipset Family HD Audio Controller [8086:8ca0]
	Subsystem: ASUSTeK Computer Inc. Device [1043:860b]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 9 Series Chipset Family PCI Express Root Port 1 [8086:8c90] (rev d0)
	Kernel driver in use: pcieport
	Kernel modules: shpchp
00:1c.3 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev d0)
--
02:00.1 Audio device [0403]: NVIDIA Corporation GM204 High Definition Audio Controller [10de:0fbb] (rev a1)
	Subsystem: eVga.com. Corp. Device [3842:2983]
	Kernel driver in use: snd_hda_intel
	Kernel modules: snd_hda_intel
04:00.0 PCI bridge [0604]: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge [1b21:1080] (rev 04)
06:00.0 Network controller [0280]: Broadcom Limited BCM4360 802.11ac Wireless Network Adapter [14e4:43a0] (rev 03)
	Subsystem: ASUSTeK Computer Inc. Device [1043:85df]
	Kernel driver in use: bcma-pci-bridge
Code:
[root@localhost user]# lsmod | grep snd
snd_hda_codec_hdmi     45056  1
snd_hda_codec_realtek    86016  1
snd_hda_codec_generic    73728  1 snd_hda_codec_realtek
snd_hda_intel          36864  11
snd_hda_codec         126976  4 snd_hda_intel,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hda_core           81920  5 snd_hda_intel,snd_hda_codec,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_hda_codec_realtek
snd_hwdep              16384  1 snd_hda_codec
snd_seq                69632  0
snd_seq_device         16384  1 snd_seq
snd_pcm               118784  4 snd_hda_intel,snd_hda_codec,snd_hda_core,snd_hda_codec_hdmi
snd_timer              32768  2 snd_seq,snd_pcm
snd                    86016  32 snd_hda_intel,snd_hwdep,snd_seq,snd_hda_codec,snd_timer,snd_hda_codec_hdmi,snd_hda_codec_generic,snd_seq_device,snd_hda_codec_realtek,snd_pcm
soundcore              16384  1 snd
Code:
[root@localhost user]# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: NVidia [HDA NVidia], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
Code:
[root@localhost user]# dmesg | grep -iC 3 "audio"
[   27.313992] asus_wmi: BIOS WMI version: 0.9
[   27.314010] asus_wmi: SFUN value: 0x0
[   27.314087] snd_hda_intel 0000:02:00.1: Disabling MSI
[   27.314091] snd_hda_intel 0000:02:00.1: Handle vga_switcheroo audio client
[   27.314252] input: Eee PC WMI hotkeys as /devices/platform/eeepc-wmi/input/input13
[   27.314362] asus_wmi: Number of fans: 1
[   27.323550] vgaarb: device changed decodes: PCI:0000:02:00.0,olddecodes=io+mem,decodes=none:owns=io+mem
[   27.323610] nvidia-nvlink: Nvlink Core is being initialized, major device number 241
[   27.323620] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  375.20  Tue Nov 15 16:49:10 PST 2016 (using threaded interrupts)
[   27.353826] snd_hda_codec_realtek hdaudioC0D0: autoconfig for ALC892: line_outs=3 (0x14/0x15/0x16/0x0/0x0) type:line
[   27.353827] snd_hda_codec_realtek hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   27.353828] snd_hda_codec_realtek hdaudioC0D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[   27.353828] snd_hda_codec_realtek hdaudioC0D0:    mono: mono_out=0x0
[   27.353829] snd_hda_codec_realtek hdaudioC0D0:    dig-out=0x11/0x1e
[   27.353829] snd_hda_codec_realtek hdaudioC0D0:    inputs:
[   27.353830] snd_hda_codec_realtek hdaudioC0D0:      Front Mic=0x19
[   27.353831] snd_hda_codec_realtek hdaudioC0D0:      Rear Mic=0x18
[   27.353831] snd_hda_codec_realtek hdaudioC0D0:      Line=0x1a
[   27.359998] nvidia-modeset: Loading NVIDIA Kernel Mode Setting Driver for UNIX platforms  375.20  Tue Nov 15 16:43:27 PST 2016
[   27.363398] [drm] [nvidia-drm] [GPU ID 0x00000200] Loading driver
[   27.367622] input: HDA Intel PCH Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
--
[   30.937207] NVRM: drivers including, but not limited to, vesafb, may result in
[   30.937207] NVRM: corruption and stability problems, and is not supported.
[   30.937682] nvidia-modeset: Allocated GPU:0 (GPU-bf7ec85b-16ba-7fa4-4828-abdbcd9d5178) @ PCI:0000:02:00.0
[   31.018095] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 6
[   31.911061] e1000e: eno1 NIC Link is Up 1000 Mbps Full Duplex, Flow Control: Rx/Tx
[   31.911089] IPv6: ADDRCONF(NETDEV_CHANGE): eno1: link becomes ready
[   49.131494] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 0
[   49.327483] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 40
[   49.745266] fuse init (API version 7.25)
[ 6423.841569] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 9
[11673.264098] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 5
[13611.794689] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 3
[13831.911765] show_signal_msg: 189 callbacks suppressed
[13831.911767] WebKitWebProces[5974]: segfault at 1570 ip 00007f087a945809 sp 00007ffd77175f78 error 4 in libGLdispatch.so.0.0.0[7f087a945000+19000]
Thank you!
 
Old 11-28-2016, 12:50 PM   #6
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,817

Rep: Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408Reputation: 2408
A few very IMPORTANT things you left out
WHAT IS THE OPERATING SYSTEM?
and its version !

WHAT is the desktop??
gnome is VERY different than KDE for sound
 
Old 11-28-2016, 12:59 PM   #7
Chronic13
LQ Newbie
 
Registered: Nov 2016
Location: Tokyo
Distribution: Fedora
Posts: 15

Original Poster
Rep: Reputation: Disabled
My apologies.

Operating system is Fedora 24 Version 4.8.8-200

Code:
uname -a
Linux localhost.localdomain 4.8.8-200.fc24.x86_64 #1 SMP Tue Nov 15 19:41:51 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
Desktop: gnome

Thanks!
 
Old 11-28-2016, 01:51 PM   #8
techboy317
LQ Newbie
 
Registered: Oct 2016
Posts: 3

Rep: Reputation: Disabled
Quote:
Originally Posted by Chronic13 View Post
Installed alsa
Try PulseAudio?
 
Old 11-28-2016, 02:08 PM   #9
notKlaatu
Member
 
Registered: Sep 2010
Location: Wellington, New Zealand
Distribution: Slackware
Posts: 893

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
What is your default soundcard? Try creating a file ~/.asoundrc to define what sound card you want ALSA to default to. Assuming you want to use your computer's soundcard and not HDMI (you don't actually specify which you want, so I'm assuming), the file should contain something like this:

Code:
defaults.ctl.card 0
defaults.pcm.card 0
defaults.timer.card 0

pcm.!default {
type hw
card 0
device 0
}

ctl.!default {
type hw
card 0
device 0
}

pcm.dsp {
type plug
slave.pcm "dmix"
}
You might want to reboot for safety (or you can opt to restart ALSA and Pulse, if you're a strict Non-Rebootian).

Once logged back in, re-check ALSA mixer to ensure volumes are up and everything's non muted.

Then open pavucontrol and check the Configuration tab: turn OFF the HDMI device and activate the Built-In Audio option (a likely setting is Analog Stereo Duplex, such that your internal soundcard is serving both input and output).

Check the Output Devices tab: make sure your output device is set to your speakers or headphones or whatever it is you want sound from (again, you have not specified this in your question, so I'm assuming).

Leave pavucontrol open so you can see output levels.

Open some sound application (you don't specify in your question what you are testing with). Go into its preferences and make sure it's using Pulse Audio as its output device. If no Pulse is listed, fallback on ALSA.

Play some sound.

In general, this is a pretty good overview of the Linux Audio experience, from understanding to configuring to troubleshooting. It may be helpful: http://slackermedia.info/handbook/do...?id=linuxaudio
 
1 members found this post helpful.
Old 11-28-2016, 09:59 PM   #10
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 210

Rep: Reputation: 48
Try this:

Code:
alsactl init && alsactl store
 
Old 11-28-2016, 10:00 PM   #11
c0wb0y
Member
 
Registered: Jan 2012
Location: Inside the oven
Distribution: Windows
Posts: 210

Rep: Reputation: 48
Try this:

Code:
alsactl init && alsactl store
 
Old 11-28-2016, 11:03 PM   #12
Chronic13
LQ Newbie
 
Registered: Nov 2016
Location: Tokyo
Distribution: Fedora
Posts: 15

Original Poster
Rep: Reputation: Disabled
Smile

Thank you all for your suggestions.

notKlaatu - I made the file as you suggested and I was able to choose my default sound card. After a reboot (I'm no non-rebootian), I am hearing sound for the first time.

One thing I do find curious though is under Configuration, I am getting sound on the profile Digital Stereo (HDMI2) Output

Since I know I don't have any HDMI ports currently being used, I find it odd that it's mislabelled.

Under the Output Devices tab, It does say HDMI / DisplayPort 2 (plugged in), but it threw me for a bit.

Thanks again!
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Jessie - Have Pulseaudio and ALSA installed. Everything is unmuted and settings show sound outputting but no sound actually playing. jjd3592 Linux - Software 12 03-07-2016 08:10 AM
No sound with a CM8738 sound card -- alsa installed istar80 Linux - Hardware 1 06-17-2005 03:02 PM
no sound in Fedora, ALSA is installed Hockeyfan Linux - Software 4 05-15-2004 02:54 AM
ALSA installed, still no sound //alias Linux - Newbie 4 07-01-2003 03:34 PM
alsa installed, but no sound? neenee Slackware 34 04-29-2003 03:33 AM


All times are GMT -5. The time now is 12:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration