LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-01-2003, 08:04 AM   #1
gentlemani
LQ Newbie
 
Registered: Aug 2003
Distribution: Mandrake 9.1
Posts: 2

Rep: Reputation: 0
Angry ALSA insmod failed!


Hi!

I am trying to install the sound on my Mandrake 9.1 for 3 days now!

After 2 days the ALSA-Installation works with no errors.
But when I try to insert the modules:
modprobe snd-via82xx
these lines are displayed:
/lib/modules/2.4.21-0.13mdk/kernel/sound/acore/snd.o: unresolved symbol snd_verbose_printk
modprobe: insmod /lib/modules/2.4.21-0.13mdk/kernel/sound/acore/snd.o failed
modprobe: insmod snd-via82xx failed


Please help me! What can I do?
THANKS!

Last edited by gentlemani; 08-01-2003 at 08:17 AM.
 
Old 08-01-2003, 08:27 AM   #2
gentlemani
LQ Newbie
 
Registered: Aug 2003
Distribution: Mandrake 9.1
Posts: 2

Original Poster
Rep: Reputation: 0
Maybe someone would help with this information

lspci -v
...
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio Controller (rev 50)
Subsystem: FIRST INTERNATIONAL Computer Inc: Unknown device 1840
Flags: medium devsel, IRQ 4
I/O ports at 1800 [size=256]
I/O ports at 101c [size=4]
I/O ports at 1018 [size=4]
Capabilities: [c0] Power Management version 2
...

lsmod
Module Size Used by Not tainted
ide-floppy 15580 0 (autoclean)
sd_mod 13100 0 (autoclean) (unused)
via82cxxx_audio 22172 0 (unused)
uart401 8196 0 [via82cxxx_audio]
ac97_codec 12488 0 [via82cxxx_audio]
sound 70644 0 [via82cxxx_audio uart401]
soundcore 6276 0 [via82cxxx_audio sound]
sg 34636 0 (autoclean)
radeon 107428 17
agpgart 40896 3 (autoclean)
lp 8096 0
parport_pc 25096 1
parport 34176 1 [lp parport_pc]
nfsd 74256 0 (autoclean)
orinoco_cs 5652 1
orinoco 36972 0 [orinoco_cs]
hermes 7524 0 [orinoco_cs orinoco]
ds 8456 2 [orinoco_cs]
yenta_socket 13056 2
pcmcia_core 57184 0 [orinoco_cs ds yenta_socket]
af_packet 14952 1 (autoclean)
sr_mod 16920 0 (autoclean)
floppy 55132 0
tulip 44032 0 (autoclean) (unused)
ohci1394 19048 0 (unused)
ieee1394 45900 0 [ohci1394]
supermount 15296 2 (autoclean)
ide-cd 33856 0
cdrom 31648 0 [sr_mod ide-cd]
ide-scsi 11280 0
scsi_mod 103284 4 [sd_mod sg sr_mod ide-scsi]
usb-uhci 24652 0 (unused)
usbcore 72992 1 [usb-uhci]
rtc 8060 0 (autoclean)
ext3 59916 2
jbd 38972 2 [ext3]


Ohh please! Help me!
 
Old 08-01-2003, 12:08 PM   #3
Alf829
Member
 
Registered: Jul 2003
Distribution: Fedora Core 2 & 5
Posts: 110

Rep: Reputation: 15
Hi gentlemani,

First, use rmmod to remove all sound related modules before you try the modprobe snd-via82xx command.

If that still doesn't work, then there's this site related to ALSA on which someone posted a fix for unresolved symbols:

http://alsa.opensrc.org/index.php?pa...solved+Symbols

Hope this helps.

Cheers,
alf829
 
Old 08-01-2003, 01:31 PM   #4
martinman
Member
 
Registered: Apr 2003
Distribution: Gentoo 1.4
Posts: 290

Rep: Reputation: 30
then, if you still need help, the guys in the #creative room on freenode will help you TONS with alsa. The founder of that channel was up till 3am helping me install and configure alsa, hehe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
after alsa update, alsa must be loaded with insmod??? postal26 Slackware 1 05-24-2004 09:15 AM
insmod forcedeth failed Spasmolytic Slackware 3 05-01-2004 11:59 PM
What is the meaning of insmod i810_rng failed bugsbunny Linux - Newbie 4 04-07-2004 09:08 AM
insmod snd-emu10k1 failed huntz Red Hat 3 09-22-2003 12:41 PM
insmod ehci-hcd failed cpudney Linux - Laptop and Netbook 0 08-03-2003 08:53 AM


All times are GMT -5. The time now is 10:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration