LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 08-24-2005, 07:29 AM   #1
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Rep: Reputation: 15
Question ALSA-frustration


Hello,

I have read through the posts regarding ALSA, as well as the info at the ALSA site. I am overwhelmed and confused

My problem is: my system has an onboard soundcard, but I want to use a card that is in a pci slot. I have tried to disable the onboard sound through bios, but I find no mention of the onboard sound there(bios). I know that there has to be a way to set the default card in linux (I am running Debian, kernel 2.6); that is the way I want to go. Can anyone tell me how to set which card is default?

I know that there is system info that I should post, but I am a real newbie and do not know where tho find whatever you may need. Let me know, and I will post.

Thanks for any assistance!
 
Old 08-24-2005, 10:37 AM   #2
Zeistler
Member
 
Registered: May 2004
Distribution: Slackware
Posts: 108

Rep: Reputation: 15
The Linux kernel has a modular design and newer versions of it checks the hardware and then loads the correct modules. So the first thing you need to investigate is what the names of the soundcard drivers (modules) are. You can see this in the Alsa soundcard database on their homepage.

There is a few terminal commands that are good to know in these situations (they are usually run as root command: su root):
lsmod - lists all modules the kernel has currently loaded.
modprobe - Manually loads a module (adding an -r removes it)


Now you need to prevent the module of the onboard chip from being loaded. This is done by adding its name to the file /etc/hotplug/blacklist. Now the linux kernel will (hopefully) ignore the onboard driver and load the pci card driver instead.
 
Old 08-24-2005, 03:36 PM   #3
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
it is also possible to controll which card is seen as "default" by editing
/usr/share/alsa.conf

defaults.ctl.card 2
defaults.pcm.card 2

so on and so forth
 
Old 08-24-2005, 06:02 PM   #4
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
Ok. Here is what lsmod gives (the part that has snd_ in it):

snd_seq_oss 29440 0
snd_seq_midi 8096 0
snd_seq_midi_event 7552 2 snd_seq_oss,snd_seq_midi
snd_seq 46608 5 snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_ens1371 23012 2
snd_rawmidi 23232 2 snd_seq_midi,snd_ens1371
snd_seq_device 7944 4 snd_seq_oss,snd_seq_midi,snd_seq,snd_rawmidi
snd_pcm_oss 48168 0
snd_mixer_oss 16640 1 snd_pcm_oss
snd_pcm 85412 3 snd_ens1371,snd_pcm_oss
snd_page_alloc 11144 1 snd_pcm
snd_timer 23172 3 snd_seq,snd_pcm
snd_ac97_codec 59268 1 snd_ens1371
snd 50148 14 snd_seq_oss,snd_seq_midi,snd_seq_midi_event,snd_seq,snd_ens1371,snd_rawmidi,snd_seq_device,snd_pcm_o ss,snd_mixer_oss,snd_pcm,snd_timer,snd_ac97_codec
soundcore 9824 1 snd
gameport 4736 1 snd_ens1371

The ens1371 is the card that I want to use. The onboard card is C-Media Electronics Inc CM8738 (according to lspci). I do not see where the onboard driver is being loaded. Is it? Maybe ALSA is not running and my sound is coming from elsewhere? What is my next step?
 
Old 08-24-2005, 11:31 PM   #5
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
it looks like you are good to go
let us see
cat /proc/asound/cards
just to be sure

is there any problem you are having ?
 
Old 08-25-2005, 06:10 AM   #6
jrcreasy
Member
 
Registered: Aug 2005
Location: Kimesville, NC
Distribution: Debian Sarge
Posts: 39

Original Poster
Rep: Reputation: 15
I still have the same problem; sound is produced through the onboard card.

Here is what cat /proc/asound/cards gives:

roger-basement:~# cat /proc/asound/cards
0 [CMI8738MC6 ]: CMI8738-MC6 - C-Media PCI CMI8738-MC6
C-Media PCI CMI8738-MC6 (model 55) at 0xd800, irq 17

What is this showing? I know that is the onboard card, so if this is which card is being used, perhaps this gives a clue as to what I need to change?
 
Old 08-25-2005, 08:18 AM   #7
DefRay
LQ Newbie
 
Registered: Aug 2005
Location: Germany
Distribution: Debian sid
Posts: 15

Rep: Reputation: 0
try looking into /etc/modules.conf

there should be sound options there (similar to alsa), change the module there to the other card.
But be careful with editing this file...

afterwards do a "update-modules"

that should be it, if everything in alsa's config points to the right soundcard ...
sometimes I even had to reboot because of alsa... but if the right modules are loaded it should work without.

also there should be some config-programm coming with alsa.... alsaconf or something, did you try that ?

btw: there's a lot of guides and documentation on the alsa-site for every soundchip supported: http://alsa-project.org

Last edited by DefRay; 08-25-2005 at 08:21 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation Frustration dairic Linux - Newbie 3 10-18-2004 02:07 AM
Emacs Frustration skibud2 Linux - Software 1 09-17-2003 11:36 PM
Samba frustration debest Linux - Networking 5 08-09-2003 12:29 AM
Frustration with Mandrake 9.1 frkstein Linux - General 2 04-02-2003 08:09 AM
architecture frustration neo77777 Linux - General 1 06-30-2002 05:30 PM


All times are GMT -5. The time now is 09:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration