LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   "Allow executing file as program" stuck (http://www.linuxquestions.org/questions/linux-newbie-8/allow-executing-file-as-program-stuck-880675/)

Steve W 05-14-2011 01:54 AM

"Allow executing file as program" stuck
 
I am using Ubuntu 9.10, Nautilus 2.28.1.

When I view a text file properties, Permissions tab, the "Execute" checkbox will not allow the tick to be removed from the box. If I double-click on a text file, Nautilus will always put up a prompt asking whether I want to view the file or execute it as a script. Removing the tick stops it doing this.

I used to be able to remove it - anyone know why I can't now? Nautilus just puts the tick back in again. Even if I sudo nautilus and try changing it as root...

jschiwal 05-14-2011 02:03 AM

You don't need sudo to root to remove the 'x' permission bit of a file you own.

You didn't give many details. For example, if the filesystem is vfat or ntfs, the permissions are determined at mount-time by the mount options. You can't change the permissions on individual files on these filesystems. The filesystem isn't native, and the ownership & permissions effect all files the same. These permissions are virtual.

Steve W 05-14-2011 07:11 AM

Quote:

if the filesystem if vfat or ntfs...
Ah! You've hit the nail on the head - I kick myself now for not realising before.

The text files affected are on the NTFS partition of my hard drive, because I also access them through Windows (it's a dual boot machine). If I create an sample text file on my ext3 partition, there is no problem changing that setting.

Thank you for clearing up my query.

jschiwal 05-18-2011 03:03 AM

For mass storage drives, and NTFS and vfat file systems, I'd recommend mounting them so that the 'x' bit of files is not set. Of course you need to the 'x' bit on directories.


All times are GMT -5. The time now is 11:08 PM.