LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-18-2010, 08:52 AM   #1
MeeLee
Member
 
Registered: Aug 2009
Posts: 48

Rep: Reputation: 3
Allow domain user access to share


Does anyone know how you allow a domain user to access a smb share when the linux machine (RHEL) that the share is on is on the same subnet as the domain but not joined to it (it has the name of a DC for the domain configured in /etc/hosts.conf also)

Many thanks in advance,

Lee
 
Old 10-18-2010, 07:29 PM   #2
sys64738
Member
 
Registered: May 2008
Location: NRW/Germany
Posts: 105

Rep: Reputation: 30
Hi,

that machine (RHEL) is not joined to the Domain the users are in?
I would recommend to do so. That will make it much easier for users to access that share.
Or is there a reason not to do so?
Can you post your smb.conf?
 
Old 10-18-2010, 09:29 PM   #3
pheak
LQ Newbie
 
Registered: Aug 2009
Location: Cambodia
Distribution: Centos
Posts: 4

Rep: Reputation: 0
hi
if you desire don't join DC domain and still share data on RHEL you should add/edit follow string
or copy

[global]
workgroup = YourWorkGroupName
server string = Samba Server linux
interfaces = eth0 #your network card to lan that you want
password server = fserver #server name
smb passwd file = /etc/samba/smbpasswd
passdb backend = tdbsam
passwd program = /user/bin/passwd %u
username map = /etc/samba/smbusers
log file = /var/log/samba/log.%m
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
add machine script = /usr/sbin/useradd -s /bin/false -d /home/nobody %u
domain logons = No
os level = 65
preferred master = Yes
domain master = Yes
dns proxy = No
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
path = /home
admin users = admin
guest ok = Yes
hosts allow = 192.168.10. #Should Change
cups options = raw

[netlogon]
comment = Network logon service
path = /home/netlogon
share modes = No

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[data]
comment = for all user
path = /data #Should Change to your share's directory
username = bbu
read only = No

[soft]
path = /soft #Should Change to your share's directory
read only = No



To access from MS windows client
Run > \\YourRHELName or \\YourRHEL_IP
 
Old 10-19-2010, 03:46 AM   #4
MeeLee
Member
 
Registered: Aug 2009
Posts: 48

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by sys64738 View Post
Hi,

that machine (RHEL) is not joined to the Domain the users are in?
I would recommend to do so. That will make it much easier for users to access that share.
Or is there a reason not to do so?
Can you post your smb.conf?
Yes. It is not joined to the domain that the users are in. The reason for this is that there is an web application that deals with LDAP authentication and talks to Active Directory. Whenever we have joined the server to the domain the application goes really strange with the authentication and it's pot luck as to whether users can login or not. Keeping it off the domain and letting the application do all the authentication work irons everything out and it is a lot smoother.

Since the server is mainly just for the web application we decided that it would be best to leave it off the domain, as the only other thing we need to access from it are the logfiles...hence my asking this question.

Thanks,

Lee
 
Old 10-19-2010, 03:47 AM   #5
MeeLee
Member
 
Registered: Aug 2009
Posts: 48

Original Poster
Rep: Reputation: 3
Quote:
Originally Posted by pheak View Post
hi
if you desire don't join DC domain and still share data on RHEL you should add/edit follow string
or copy

[global]
workgroup = YourWorkGroupName
server string = Samba Server linux
interfaces = eth0 #your network card to lan that you want
password server = fserver #server name
smb passwd file = /etc/samba/smbpasswd
passdb backend = tdbsam
passwd program = /user/bin/passwd %u
username map = /etc/samba/smbusers
log file = /var/log/samba/log.%m
max log size = 0
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
add machine script = /usr/sbin/useradd -s /bin/false -d /home/nobody %u
domain logons = No
os level = 65
preferred master = Yes
domain master = Yes
dns proxy = No
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
path = /home
admin users = admin
guest ok = Yes
hosts allow = 192.168.10. #Should Change
cups options = raw

[netlogon]
comment = Network logon service
path = /home/netlogon
share modes = No

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[data]
comment = for all user
path = /data #Should Change to your share's directory
username = bbu
read only = No

[soft]
path = /soft #Should Change to your share's directory
read only = No



To access from MS windows client
Run > \\YourRHELName or \\YourRHEL_IP
Many thanks. Will have a look and then get back to you if there were any issues...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Restrict access by domain per user lothario Linux - Networking 1 02-06-2009 09:37 PM
share directory with samba domain user permission neo571 Linux - Networking 4 12-02-2008 06:37 AM
How to access samba share in a Windows domain environment qdog007 Linux - Software 6 03-01-2007 12:56 AM
Terastation access through DOMAIN User mgchandrababu Linux - Networking 0 11-06-2006 04:25 AM
Domain User Access Rights engnet Linux - Security 0 10-30-2005 01:40 AM


All times are GMT -5. The time now is 10:14 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration