LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-26-2007, 02:04 AM   #1
blizblarg
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Rep: Reputation: 0
All I want is wireless to work!


I've lost count of how many threads and mini-tutorials I've gone through trying to get this work.

(I can do little more than navigate the filesystem in terminal... just so you know how much I know.)

I have a Linksys wpc54g ver 3, and am running the latest Debian (kernel version is 2.6.18-5-686).

I first thought that I was going to have to use ndiswrapper to get this to work, so I got to reading. After multiple failures, I found out that since some version a while ago, the driver was included in the package.

Okay, so I slide my wireless card in, it lights up. I go into the Network Admin, and put in my ESSID and activate the card (eth1). I deactivate my wired LAN and try to surf... nada. I right click on the connection icon near the clock and it says I have no signal (but I'm typing this on a PC right next to this laptop which uses that same network).

Here's my ifconfig...

Code:
eth0      Link encap:Ethernet  HWaddr 00:08:74:94:D0:85
          inet addr:192.168.1.108  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::208:74ff:fe94:d085/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:36038 errors:0 dropped:0 overruns:0 frame:0
          TX packets:21746 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:48152545 (45.9 MiB)  TX bytes:1938062 (1.8 MiB)
          Interrupt:11 Base address:0x2c00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:91 errors:0 dropped:0 overruns:0 frame:0
          TX packets:91 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:7084 (6.9 KiB)  TX bytes:7084 (6.9 KiB)
And my iwconfig...

Code:
iwconfig eth1
eth1      IEEE 802.11b/g  ESSID:"machouse"  Nickname:"Broadcom 4318"
          Mode:Managed  Access Point: Invalid
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
Also, I try to click the drop down for the available wireless networks, but it's empty! I ran a "iwlist eth1 scan" and this was my result...
Code:
eth1      Interface doesn't support scanning : No such device
I feel totally lost. Before, when I tried to learn Linux, I got so frustrated, I threw that other OS back on. Now, I have no choice, as I can no longer find the license key, and I'm poor.

If you've gotten this far, I appreciate your time.
 
Old 10-26-2007, 03:09 AM   #2
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
I don't know Debian never used nor seen it. From what I can see the problem is this
Code:
iwconfig eth1
eth1      IEEE 802.11b/g  ESSID:"machouse"  Nickname:"Broadcom 4318"
          Mode:Managed  Access Point: Invalid
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
On my system (Slackware 12) there is a /etc/rc.d/rc.wireless.conf file where I configure the aspects of the wireless. In a terminal do a ifconfig eth1 (if eth1 is your wireless card and write down the MAC address) then in the Debian equevillent of /etc/rc.d/rc.wireless.conf add something like

Code:
00:08:74:94:D0:85) (MAC Address you wrote down)
   ESSID="machouse"
   MODE="Managed"
   CHANNEL="1" (Must match Access Point)
;;
What I would also look into is the security your Access Point is using, as a test you can make it wide open security and test it. you may be using WEP/WPA/WPA2 if the security on the Access Point is anything above WEP you will need to be using wpa_supplicant package to get WPA or WPA2 working.

Sorry I don't know Debian but hope the information I have supplied helps.

Last edited by KrazyKanuk; 10-26-2007 at 03:11 AM. Reason: Gave wrong filename
 
Old 10-26-2007, 12:00 PM   #3
blizblarg
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Original Poster
Rep: Reputation: 0
Okay, last night I could at least see the wireless connection when I right-clicked on the network icon near the clock. Now, when I activate the wireless card, that doesn't happen, and when I press OK to exit Network Admin, when I come back, the changes have been reverted!

Do I need to give more info? What am I doing wrong?

KrazyKanuk: I had rc#.d directories, but none of them had an rc.wireless.conf. Also, now that activating the card no longer really happens (the Network Admin tool seems to be lying to me), ifconfig doesn't show eth1, but iwconfig does.

Last edited by blizblarg; 10-26-2007 at 12:04 PM.
 
Old 10-26-2007, 06:26 PM   #4
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
I have never had good luck with GUI tools I ALWAYS use a terminal window either at the terminal or through a SSH connection. OK we know that you have the right modules and drivers for the wireless card and it is working or iwconfig eth1 would show nothing but an error. If you do a ifconfig -a it will show all network cards ifconfig eth1 will just show the eth1 device. It had me wondering what the difference was between Debian and Slackware as far as the /etc/rc.d/rc.wireless.conf goes you don't have it but I bet you have a /etc/network/interfaces (I googled it can send me a check later ). What I don't know is if you get your address from your access point by means of DHCP or if you have a static address, as well as security of your access point if you have WEP/WPA/WPA2. The site I saw that gave me the location of the wireless file was http://www.quietearth.us/articles/20...t2500-wireless
it also used ra0 as the device name not sure if that matters or not.

Here it is with a static address
Code:
auto eth1
iface eth1 inet static
address 192.168.1.2
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
up iwconfig eth1 essid machouse
up iwconfig eth1 channel auto # or if you have specified a channel
up iwconfig eth1 key abcdef00000012345600000000
Here it is with DHCP
Code:
iface eth1 inet dhcp
up iwconfig eth1 essid machouse
up iwconfig eth1 channel auto # or if you have specified a channel
up iwconfig eth1 key abcdef00000012345600000000
If these don't work means you have WPA/WPA2 security on the Access Point and there is more to be done to configure it, if that is the case do a "apt-get install wpasupplicant" while your waiting. I can't take credit for the code listed above it was copied from the site I listed above.
 
Old 10-26-2007, 08:47 PM   #5
MRXGRCH
LQ Newbie
 
Registered: Nov 2006
Posts: 7

Rep: Reputation: 0
Perhaps since you guys know what youre doing, you can help me. I have an old Dell Inspiron 1000 with a dell PCI wireless card and I am running Puppy from a usb flash drive. I have installed windows drivers with ndiswrapper, and I can get the "driver present, hardware present" message in the console (even though I cannot get the lights on the card to turn on). iwlist scan works and picks up our home network. The problem is that I cannot get the WPA encryption to work. I have tried modifying the wpa_supplicant.conf file to match the ones I have seen all through the web, however when I try wpa_supplicant -i wlan0 -Dndiswrapper -c/etc/wpa_supplicant.conf the console hangs, and I have to reboot to get back into it again. Even when I try to change the ESSID on the card with iwconfig, the card still reads "ESSID: off/any". I am somewhat at a loss of what to do....I am fairly new to linux...can anyone help?
 
Old 10-26-2007, 10:40 PM   #6
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
OK what location in terminal do you configure wireless on your distribution check in there for an ESSID line. If the console hangs try a CTRL c to get it back. When you do a "ndiswrapper -l" (without quotes") does it list the driver you are using? I use to call wpa_supplicant like
Code:
wpa_supplicant -dw -c/etc/wpa_supplicant.conf -D<driver> -i<interface>
Before you edit /etc/wpa_supplicant.conf run
Code:
wpa_passphrase <your ssid> <your password for acess point>
and copy the hex key value in the file it creates for psk

My /etc/wpa_dupplicant.conf looked like this
Code:
ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

network={
   scan_ssid=0
   ssid="your ssid"
   proto=WPA
   key_mgmt=WPA-PSK
   pairwise=CCMP TKIP
   group=CCMP WEP104 WEP40
   psk="the copied hex key from above"
}
How are you getting the card to pick up the correct info for your network when the lights won't turn on, do they turn on at all like if you do it in WinBLOWEZ?
 
Old 10-27-2007, 08:31 AM   #7
MRXGRCH
LQ Newbie
 
Registered: Nov 2006
Posts: 7

Rep: Reputation: 0
OK....that worked wonders. The card now scans and finds the network....but when I try to connect, I get two errors: "GTK cipher mismatch" and "non-WPA network not allowed". Any hints? I know that the network is encrypted with WPA1 because it says so when i do an iwlist scan, and I am sure that the password is correct (i did go and find the hex key). Soo...what progress I did make is pretty cool, but all I need is this last step...any help?
 
Old 10-27-2007, 10:53 AM   #8
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
What version of wpa_suplicant are you using? The only thing I can think of is maybe you are using an older wpa_supplicant. One other thing is on occasion I get an error or two in the terminal that I running wpa_supplicant in but if I open another terminal I can ping within the LAN and also any address you can think of on the internet, are you stopping it because of the error or does wpa_supplicant stop by it's self?
 
Old 10-27-2007, 08:13 PM   #9
MRXGRCH
LQ Newbie
 
Registered: Nov 2006
Posts: 7

Rep: Reputation: 0
Alright, Ill try that....but I am fairly certain that the comp isnt connecting at all. It seems to go into a loop where it scans, finds my network, then gives both errors that i listed above, then waits and scans again. I have tried letting it go on for a while, and it keeps on giving me those errors. Its almost like I have the password wrong...but I checked on wam, and I know its right on. Also, the card will not associate with the essid that i want when i do iwconfig wlan0 essid. Will it automatically do this If i can get wpa_supplicant to work?
 
Old 10-27-2007, 08:19 PM   #10
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
The ESSID should be set before wpa_supplicant. The wpa_supplicant is like the energizer bunny it keeps going and going and going until you stop it mine has bee going since this thread has started and is still going.
 
Old 10-27-2007, 08:21 PM   #11
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
Since I have been up since yesterday someone else will have to help you tonight, coffee is no longer doing the trick to keep me awake so I will be hitting the bed shortly.
 
Old 10-27-2007, 09:36 PM   #12
MRXGRCH
LQ Newbie
 
Registered: Nov 2006
Posts: 7

Rep: Reputation: 0
Hey, thanks for your help. Its been murder, and i couldnt have gon anywhere without it.
 
Old 10-28-2007, 11:44 AM   #13
fair_is_fair
Member
 
Registered: May 2005
Posts: 516

Rep: Reputation: 52
It appears you are running the Broadcom 4318? These cards are very problematic. I have two of these in different laptops. I've had no success with the linux engineered bcm43xx driver which is included in recent kernels.

You may have to blacklist the bcm43xx and use ndiswrapper with a windows driver to get this card working properly. There should be a full tutorial at Debian for the process.

I use Pclos on both these machines because the windows driver install is mostly a no-brainer and works perfectly. But if you have the time and patience, you will succeed with a manual install.
 
Old 10-30-2007, 02:28 AM   #14
KrazyKanuk
Member
 
Registered: Sep 2007
Location: Nottingham, Maryland
Distribution: Slackware 13/64 bit
Posts: 91

Rep: Reputation: 15
Did you two ever get your wireless working with wpa_supplicant and the likes?
 
Old 03-03-2009, 02:48 PM   #15
blizblarg
LQ Newbie
 
Registered: Oct 2007
Posts: 3

Original Poster
Rep: Reputation: 0
No I went back to Windows.

Vista sucks, btw.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless won't work after reboot w/ Mepis& integrated Dell Wireless 1370 WLAN MiniPCI longboarder543 Linux - Wireless Networking 1 03-01-2006 07:14 PM
I can't get my wireless to work snowboard4fod Linux - Wireless Networking 3 02-08-2006 08:56 AM
Will Ubuntu Work work With my Wireless Card? PulsarSL Ubuntu 3 10-07-2005 11:33 PM


All times are GMT -5. The time now is 07:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration