LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-18-2003, 09:13 PM   #1
davalos
LQ Newbie
 
Registered: May 2003
Location: san jose
Distribution: redhat 9
Posts: 18

Rep: Reputation: 0
aliases in .bashrc file


Hey,

i added the alias ls='ls -F' to my .bashrc file to take away the coloring of dir, files, etc, but for some reason it only works when i ssh to my box. I'd really like to turn off the coloring and just use the "-F" switch when doing an "ls"

Can anyone assist me here?

thanks
 
Old 08-18-2003, 09:15 PM   #2
martinman
Member
 
Registered: Apr 2003
Distribution: Gentoo 1.4
Posts: 290

Rep: Reputation: 30
make sure you followed this proceedure: http://www.mcsr.olemiss.edu/unixhelp...ias_bash2.html
 
Old 08-19-2003, 03:35 AM   #3
lfur
Member
 
Registered: Jul 2003
Location: Slovenia
Distribution: Slackware & FreeBSD
Posts: 209

Rep: Reputation: 30
You have to put:
alias ls='ls --color=never'

in your .bashrc or /etc/profile for system wide settings
 
Old 08-19-2003, 07:18 PM   #4
davalos
LQ Newbie
 
Registered: May 2003
Location: san jose
Distribution: redhat 9
Posts: 18

Original Poster
Rep: Reputation: 0
that might work on slackware but its not working on RH9 don't know what the deal is at this point. i'm kind of tired of having to do alias ls='ls -F' everytime i open up a new shell oh well, guess i'll puts around a bit more
 
Old 08-19-2003, 07:21 PM   #5
davalos
LQ Newbie
 
Registered: May 2003
Location: san jose
Distribution: redhat 9
Posts: 18

Original Poster
Rep: Reputation: 0
so i added the alias to the .bash_profile file and that seemed to have fixed my problem...weird, but i'll take it.
 
Old 08-19-2003, 07:23 PM   #6
davalos
LQ Newbie
 
Registered: May 2003
Location: san jose
Distribution: redhat 9
Posts: 18

Original Poster
Rep: Reputation: 0
ok problem is only half-way solved. if i open a new terminal i still have to do source .bash_profile which pretty much leaves in the the same place, i have to take the extra step to enable my alias.
 
Old 08-19-2003, 11:51 PM   #7
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 46
You will until you log out and back in. Then it will work on all of your consoles

Or you could just get out of everything except your login console, do a source .bash_profile and then it will work on all child consoles.
 
Old 08-21-2003, 02:03 PM   #8
lfur
Member
 
Registered: Jul 2003
Location: Slovenia
Distribution: Slackware & FreeBSD
Posts: 209

Rep: Reputation: 30
Quote:
if i open a new terminal i still have to do source .bash_profile
if you mean xterm (or somethink alike) with terminal, you can use:
xterm -ls
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Eterm doesn't import aliases from bashrc oldmanofthesea Linux - General 1 05-16-2005 08:17 AM
bashrc Aliases don't work soren625 Linux - Newbie 10 01-27-2005 09:59 AM
making aliases - no bashrc file disorderly Linux - Newbie 9 09-27-2004 05:57 PM
adding aliases, refreshing .bashrc NonSumPisces Linux - Newbie 8 06-26-2004 12:39 AM
.bashrc aliases Crashed_Again Linux - General 8 01-30-2003 07:42 PM


All times are GMT -5. The time now is 07:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration