LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-07-2016, 09:04 PM   #1
actinide
Member
 
Registered: Jan 2012
Posts: 154

Rep: Reputation: Disabled
Alias command


Can anybody tell me how to create an alias for macchanger-gtk.
I've tried but nothing works any help would be great.
 
Old 08-07-2016, 10:27 PM   #2
grail
LQ Guru
 
Registered: Sep 2009
Location: Perth
Distribution: Manjaro
Posts: 9,243

Rep: Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684
Please show us your attempt and explain exactly what is not working?
 
Old 08-08-2016, 01:00 AM   #3
ondoho
Senior Member
 
Registered: Dec 2013
Posts: 4,159

Rep: Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822Reputation: 822
i'm feeling generous:
Code:
alias mc=macchanger-gtk
put that into ~/.bashrc, it will be persistent.
only works in terminal.
 
Old 08-08-2016, 08:50 AM   #4
actinide
Member
 
Registered: Jan 2012
Posts: 154

Original Poster
Rep: Reputation: Disabled
The command I use is this

alias mmc='macchanger-gtk'

it works the first time, after that it gives me this output "You must be root for use macchanger-gtk"
I've tried root but i get this instead "No command 'mmc' found, did you mean:"
 
Old 08-08-2016, 10:51 AM   #5
grail
LQ Guru
 
Registered: Sep 2009
Location: Perth
Distribution: Manjaro
Posts: 9,243

Rep: Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684
First thing to remember is that when you create an alias it is yours and no elses by default, hence if you change to root (or any other user) it will not exist for them. You can of course make it global to all users but this is generally not the solution.

You mentioned it works the first time, so just to clarify, the following are the steps you take:
Code:
$ alias mmc='macchanger-gtk'
$ mmc
<something happens here>
$ mmc
You must be root for use macchanger-gtk
$
Please confirm the above is what you are referring to and this is as your standard user?
 
Old 08-08-2016, 10:57 AM   #6
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,158
Blog Entries: 10

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
Code:
alias mmc="sudo macchanger-gtk"
 
Old 08-08-2016, 11:28 AM   #7
actinide
Member
 
Registered: Jan 2012
Posts: 154

Original Poster
Rep: Reputation: Disabled
Still doesn't work any ideas.
 
Old 08-08-2016, 12:05 PM   #8
grail
LQ Guru
 
Registered: Sep 2009
Location: Perth
Distribution: Manjaro
Posts: 9,243

Rep: Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684
Please show us exact steps and messages as "doesn't work" holds no information we can assist with.
 
Old 08-08-2016, 12:19 PM   #9
actinide
Member
 
Registered: Jan 2012
Posts: 154

Original Poster
Rep: Reputation: Disabled
This what I typed into the terminal.

alias mmc ='macchanger-gtk'

output bash: No command 'mmc' found, did you mean:

No command 'mmc' found, did you mean:
Command 'mc' from package 'mc' (universe)
Command 'mzc' from package 'racket' (universe)
Command 'qmc' from package 'qmc' (universe)
Command 'mic' from package 'mic2' (universe)
Command 'moc' from package 'qtchooser' (main)
Command 'mm' from package 'multimail' (universe)
Command 'mpc' from package 'mpc' (universe)
Command 'mmv' from package 'mmv' (universe)
Command 'mmg' from package 'mkvtoolnix-gui' (universe)
Command 'imc' from package 'italc-management-console' (universe)
Command 'zmc' from package 'zoneminder' (universe)
Command 'mmd' from package 'mtools' (main)
Command 'wmc' from package 'wine1.6' (universe)
Command 'smc' from package 'smc' (universe)
mmc: command not found
 
Old 08-08-2016, 12:49 PM   #10
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,158
Blog Entries: 10

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
Quote:
Originally Posted by actinide View Post
Still doesn't work any ideas.
Close all your terminal(s).
Edit your ~./bashrc and add:
Code:
alias mmc="sudo macchanger-gtk"
using any editor you like.

Save your ~/.bashrc
open a terminal and type
Code:
mmc
 
Old 08-08-2016, 01:08 PM   #11
actinide
Member
 
Registered: Jan 2012
Posts: 154

Original Poster
Rep: Reputation: Disabled
This going to sound stupid but how do I edit the ~./bashrc
 
Old 08-08-2016, 01:11 PM   #12
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,258

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Pick a text editor and open it. You can do it graphically from a file browser, or you can launch one of the hundreds of Linux text editors from the command line.

vi ~/.bashrc
emacs ~/.bashrc
pico ~/.bashrc
nano ~/.bashrc
gedit ~/.bashrc
kate ~/.bashrc
...
 
Old 08-08-2016, 01:16 PM   #13
actinide
Member
 
Registered: Jan 2012
Posts: 154

Original Poster
Rep: Reputation: Disabled
Do that now what, Sorry I'm new to this
 
Old 08-08-2016, 01:47 PM   #14
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,158
Blog Entries: 10

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
Quote:
Originally Posted by actinide View Post
Do that now what, Sorry I'm new to this
What editor did you use?
 
Old 08-08-2016, 01:47 PM   #15
grail
LQ Guru
 
Registered: Sep 2009
Location: Perth
Distribution: Manjaro
Posts: 9,243

Rep: Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684Reputation: 2684
As no one has said yet, the reason you received all the errors above is because you left a space between mmc and = sign. Bash requires no space between the two otherwise it considers both alias
and mmc to be commands. This will be the same in your .bashrc file.

Once you have edited the file you need a new login to test if it has worked and generally you can simply open a new terminal to test that.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bash: command works at command line, but not via an alias porphyry5 Programming 3 03-17-2012 03:48 PM
tar command alias command rlg Linux - Newbie 0 03-11-2008 08:21 AM
directory for alias command ernestk Linux - Server 1 08-30-2007 06:56 PM
Use for the alias command Metablade Linux - Newbie 4 10-12-2005 06:44 PM
alias command zeviddalop Linux - Newbie 3 01-12-2005 10:59 PM


All times are GMT -5. The time now is 12:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration