LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-02-2004, 11:58 PM   #1
Talon107
LQ Newbie
 
Registered: Aug 2004
Posts: 10

Rep: Reputation: 0
AH!! I need windows back :(


I am a pure linux newbie

Anyway, I have 2 HD's and previously had XP installed on the first one.

Popped in RH 9.0 and used the auto-format feature (on the second HD) and it worked good 'in all... used GRUB as the boot loader.

Anyway, when I would reboot the loader showed RH and 'dos' like I assumed was normal.

Before even checking to see if windows still booted (I didn't see why it wouldn't) I installed the new kernel for RH.

Anyway, it shows two different kernels in the boot loader + 'dos'.

When I click on dos, it just said booting 'dos', then something like hd0,0 chainloader.

And thats like all... it just stops cold.

Linux loads fine, but there are important things still on my windows drive...





Any help would be appreciated.. thanks in advance.

And excuse my newbieness But i figured this was the right place to go to.
 
Old 08-03-2004, 12:14 AM   #2
alandd
LQ Newbie
 
Registered: Sep 2003
Location: Gilbert, AZ, USA
Distribution: Was Fedora Core but now on OpenSUSE
Posts: 13

Rep: Reputation: 0
Re: AH!! I need windows back :(

Newbie-ness need not be excused. We are all newbies at one time or another.

I admit that I am not a Windows XP experienced person. BUT, I found a couple of links that might help you. I found these with a google search (what else) on the terms ""windows xp" dual boot red hat linux howto"

http://www.geocities.com/epark/linux...w2k-HOWTO.html
http://www.overclockersclub.com/guid..._fedora_xp.php

Perhaps these or other pages can provide you the information you need to get back to your windows boot.
 
Old 08-03-2004, 12:21 AM   #3
OEP
Member
 
Registered: Apr 2004
Location: AL, USA
Distribution: FC4, Gentoo
Posts: 58

Rep: Reputation: 15
Also, it would be helpful if we could see your grub configuration file.

type:
vim /boot/grub/grub.conf

at a terminal and it should display some text. If you could copy and paste that here, that might help some too.

Also I've heard that making the HD with grub on it master can sometimes solve a problem, but I wouldn't try that now because you would have to make a few configuration changes.
 
Old 08-03-2004, 12:25 AM   #4
Talon107
LQ Newbie
 
Registered: Aug 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Thanks for the quick response guys .


Here's the config.

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd1,0)
# kernel /vmlinuz-version ro root=/dev/hdc2
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd1,0)/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-31.9)
root (hd1,0)
kernel /vmlinuz-2.4.20-31.9 ro root=LABEL=/ hdd=ide-scsi
initrd /initrd-2.4.20-31.9.img
title Red Hat Linux (2.4.20-6)
root (hd1,0)
kernel /vmlinuz-2.4.20-6 ro root=LABEL=/ hdd=ide-scsi
initrd /initrd-2.4.20-6.img
title DOS
rootnoverify (hd0,0)
chainloader +1
 
Old 08-03-2004, 12:45 AM   #5
OEP
Member
 
Registered: Apr 2004
Location: AL, USA
Distribution: FC4, Gentoo
Posts: 58

Rep: Reputation: 15
Well I can think of a few things to try. Your grub.conf file looks ok to me, so maybe reinstalling grub would work.

become root:
su

setup grub:
/sbin/grub-install /dev/hda

It's worth a shot.
 
Old 08-03-2004, 01:37 AM   #6
slackist
Member
 
Registered: Feb 2004
Location: Phuket
Distribution: Slackware 14.1 and Slackware Arm
Posts: 478

Rep: Reputation: 41
Re: AH!! I need windows back :(

Quote:
Originally posted by Talon107

Linux loads fine, but there are important things still on my windows drive...
If by "important things" you mean documents or other files you can mount the windows drive and read/copy them with RH running


Just a thought,
mark
 
Old 08-03-2004, 01:48 AM   #7
Talon107
LQ Newbie
 
Registered: Aug 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Reinstalled GRUB. Didn't work..


Can't mount windows drive.
XP = NTFS
 
Old 08-03-2004, 02:45 AM   #8
OEP
Member
 
Registered: Apr 2004
Location: AL, USA
Distribution: FC4, Gentoo
Posts: 58

Rep: Reputation: 15
become root and try:

/sbin/fdisk /dev/hda

press the letter 'p' and enter, and paste the output here.
 
Old 08-03-2004, 02:52 AM   #9
Talon107
LQ Newbie
 
Registered: Aug 2004
Posts: 10

Original Poster
Rep: Reputation: 0
Code:
[root@x1-6-00-e0-6f-3c-94-69 plex]# /sbin/fdisk /dev/hda

The number of cylinders for this disk is set to 29065.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/hda: 15.0 GB, 15000330240 bytes
16 heads, 63 sectors/track, 29065 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot    Start       End    Blocks   Id  System
/dev/hda1   *         1     29055  14643216    7  HPFS/NTFS
 
Old 08-03-2004, 03:11 AM   #10
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Redhat 9 doesn't include NTFS support by default
http://linux-ntfs.sourceforge.net/rpm/index.html

As for the bootloader issue, here's what I recommend you do:

1. Back up current MBR to another file by using "dd if=/dev/hda of=mbr.bin bs=512 count=1" and copy mbr.bin into a floppy disk( make sure it's FAT format).

2. Boot with WinXP CDROM into the recovery console, and do a "fixmbr", if its successful it should load Windows directly when you reboot.

3.Copy mbr.bin to c:\ from the floppy, and add this to c:\boot.ini(hidden by default):
Code:
c:\mbr.bin="Redhat 9"
reboot and see if you're able to boot Redhat by selecting it from the boot menu.

Last edited by Demonbane; 08-03-2004 at 03:13 AM.
 
Old 08-03-2004, 03:33 AM   #11
OEP
Member
 
Registered: Apr 2004
Location: AL, USA
Distribution: FC4, Gentoo
Posts: 58

Rep: Reputation: 15
Ah, that's an interesting trick. I'll remember that one
 
Old 08-03-2004, 04:44 AM   #12
Origami
LQ Newbie
 
Registered: Aug 2004
Posts: 2

Rep: Reputation: 0
Unhappy

I have a similar problem.

I installed Linux on my notebook to try it, but it's much too slow to enjoy it. So I want to reinstall the Windows which was there before. It's not possible to directly change the BIOS settings while booting, you need a Windows tool from the manufacturer's web site to change the boot order. Before installing Linux, I changed the order from hd-floppy-cd to floppy-cd-hd, but the setting wasn't kept (don't know why..), so I can only boot from the hd.

How can I persuade GRUB to boot from the Windows 98 CD?

CD-ROM: hdc
 
Old 08-03-2004, 05:02 AM   #13
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Quote:
I have a similar problem.

I installed Linux on my notebook to try it, but it's much too slow to enjoy it. So I want to reinstall the Windows which was there before. It's not possible to directly change the BIOS settings while booting, you need a Windows tool from the manufacturer's web site to change the boot order. Before installing Linux, I changed the order from hd-floppy-cd to floppy-cd-hd, but the setting wasn't kept (don't know why..), so I can only boot from the hd.

How can I persuade GRUB to boot from the Windows 98 CD?

CD-ROM: hdc
Your bios still needs to support booting from CD-ROM for this to work, but looks like your does so give this a shot:

Download this
put it in your /boot and add this to your /boot/grub/grub.conf (or men.lst)
Code:
title CDROM
chainloader /boot/bootflop.bin +1
If you have a separate boot partiton remove "/boot" from the path.
This bootsector file will first try to boot from the floppy, then the cdrom, so make sure you have nothing inserted in your fdd.

Last edited by Demonbane; 08-03-2004 at 05:04 AM.
 
Old 08-04-2004, 01:07 AM   #14
dns21
Member
 
Registered: Feb 2004
Location: AZ
Distribution: Slackware, Ubuntu, CentOS, Debian
Posts: 139

Rep: Reputation: 15
Quote:
Originally posted by Demonbane
Redhat 9 doesn't include NTFS support by default
http://linux-ntfs.sourceforge.net/rpm/index.html

As for the bootloader issue, here's what I recommend you do:

1. Back up current MBR to another file by using "dd if=/dev/hda of=mbr.bin bs=512 count=1" and copy mbr.bin into a floppy disk( make sure it's FAT format).

2. Boot with WinXP CDROM into the recovery console, and do a "fixmbr", if its successful it should load Windows directly when you reboot.

3.Copy mbr.bin to c:\ from the floppy, and add this to c:\boot.ini(hidden by default):
Code:
c:\mbr.bin="Redhat 9"
reboot and see if you're able to boot Redhat by selecting it from the boot menu.
Ok... I attempted to do this; however, once I did the "fixmbr" number, I tried to copy mbr.bin to c:\ only, it did not want to read the disk. Windows will not start. Linux will not start.

I have no idea what to do right now. This is a challenge I have never had to face. Any help anybody can give, I would greatly appreciate.
 
Old 08-04-2004, 01:26 AM   #15
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Well you need to give specific details on your problem, as I doubt these instructions from my previous post is going to work for everyone.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Going back to windows? sonic04002 General 8 11-13-2005 01:48 PM
i need windows back seanz6688 General 37 03-01-2004 04:08 PM
Back to Windows Baz Linux - Newbie 13 02-17-2004 02:49 PM
Can't get Windows back!!!!!!!! NathanCohen2003 Mandriva 3 08-27-2003 01:45 PM
Cant get back into Windows : ( thetruevoice Linux - Software 3 09-07-2001 11:25 AM


All times are GMT -5. The time now is 04:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration