LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-16-2010, 08:48 AM   #1
UbuntuRevolution
Member
 
Registered: Aug 2010
Posts: 60

Rep: Reputation: 15
AGP Problems... AGP where i Active it ?


hi i try to play lineage 2 on linux, but the program dont run beceause he say AGP is not activeted. where i active the AGP on my linux? ubuntu 10.04 for my game run ? ubuntu 10,04 on a notebook and my Grafifc hardware is : Inter@GMA 4500M Up to 1308 MB DVMT



thanks

Last edited by UbuntuRevolution; 08-16-2010 at 09:24 AM.
 
Old 08-16-2010, 10:33 AM   #2
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
The GMA4500 should be PCIe, not AGP. I think you should show us the exact error message you are getting form the game.

Adam
 
Old 08-16-2010, 10:43 AM   #3
UbuntuRevolution
Member
 
Registered: Aug 2010
Posts: 60

Original Poster
Rep: Reputation: 15
on console :

wine .wine/drive_c/Program\ Files/Lineage\ II/system/l2.exe
fixme:reg:GetNativeSystemInfo (0x1a87019) using GetSystemInfo()
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:mountmgr:harddisk_ioctl unsupported ioctl 74080
fixme:mountmgr:harddisk_ioctl unsupported ioctl 2d1400
fixmerocess:GetProcessWorkingSetSize (0xffffffff,0x32e588,0x32e584): stub
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e5f8,0x00000000), stub!
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e6a0,0x00000000), stub!
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32a258,0x00000000), stub!


On start of the game my game error is: (The game may not be consistant because AGP is deacivated. Please Activate AGP for consistancy)

is my error : thanks
 
Old 08-16-2010, 10:47 AM   #4
Kenny_Strawn
Senior Member
 
Registered: Feb 2010
Location: /usa/ca/orange_county/lake_forest
Distribution: ArchBang, Google Android 2.1 + Motoblur (on Motortola Flipside), Google Chrome OS (on Cr-48)
Posts: 1,791
Blog Entries: 62

Rep: Reputation: 54
Quote:
Originally Posted by UbuntuRevolution View Post
on console :

Code:
wine .wine/drive_c/Program\ Files/Lineage\ II/system/l2.exe 
fixme:reg:GetNativeSystemInfo (0x1a87019) using GetSystemInfo()
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:mountmgr:harddisk_ioctl unsupported ioctl 74080
fixme:mountmgr:harddisk_ioctl unsupported ioctl 2d1400
fixme:process:GetProcessWorkingSetSize (0xffffffff,0x32e588,0x32e584): stub
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e5f8,0x00000000), stub!
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e6a0,0x00000000), stub!
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32a258,0x00000000), stub!

On start of the game my game error is: (The game may not be consistant because AGP is deacivated. Please Activate AGP for consistancy)

is my error : thanks
Please wrap [code] tags around your terminal output, thanks.
 
Old 08-16-2010, 11:07 AM   #5
UbuntuRevolution
Member
 
Registered: Aug 2010
Posts: 60

Original Poster
Rep: Reputation: 15
sorry i dont understand.. wrap? i dont understand.

my problem is when a start my game ( lineage 2 ) i have 1 error (The game may not be consistant because AGP is deacivated. Please Activate AGP for consistancy)


can u tell me please where i active the AGP ? thanks
 
Old 08-16-2010, 11:16 AM   #6
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
You don't activate AGP for an intel GMA4500. That just makes no sense since the GMA4500 is a PCIe card. I suggest filing a bug report with the wine folks

Adam
 
Old 08-16-2010, 11:28 AM   #7
UbuntuRevolution
Member
 
Registered: Aug 2010
Posts: 60

Original Poster
Rep: Reputation: 15
so now what i can do to play the game ? :O
 
Old 08-16-2010, 11:33 AM   #8
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Hmm... Maybe your opengl drivers just aren't working properly. What's the output of 'glxinfo | grep -i render'?

Adam
 
Old 08-16-2010, 12:00 PM   #9
UbuntuRevolution
Member
 
Registered: Aug 2010
Posts: 60

Original Poster
Rep: Reputation: 15
~$ glxinfo | grep -i render
direct rendering: Yes
OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset GEM 20091221 2009Q4 x86/MMX/SSE2




it's all ok ? sorry im very new on linux
 
Old 08-16-2010, 12:05 PM   #10
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
Yes, your 3D drivers are working just fine. You need to report this problem to the wine folks and hope that they can fix it for you.

Adam
 
Old 08-16-2010, 03:27 PM   #11
UbuntuRevolution
Member
 
Registered: Aug 2010
Posts: 60

Original Poster
Rep: Reputation: 15
i thing u are right the games now Works. but look at sreenn:

http://img266.imageshack.us/img266/5...eenshot3pk.png



-laptop:~$ wine .wine/drive_c/Program\ Files/Lineage\ II/system/l2.exe
fixme:reg:GetNativeSystemInfo (0x1a87019) using GetSystemInfo()
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:mountmgr:harddisk_ioctl unsupported ioctl 74080
fixme:mountmgr:harddisk_ioctl unsupported ioctl 2d1400
fixmerocess:GetProcessWorkingSetSize (0xffffffff,0x32e588,0x32e584): stub
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e5f8,0x00000000), stub!
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e6a0,0x00000000), stub!
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32a258,0x00000000), stub!
fixme:toolhelp:CreateToolhelp32Snapshot Unimplemented: heap list snapshot
fixme:mountmgr:harddisk_ioctl unsupported ioctl 74080
fixme:mountmgr:harddisk_ioctl unsupported ioctl 2d1400
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32a65c,0x00000000), stub!
do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.
fixme:keyboard:RegisterHotKey (0x20072,49269,0x00000001,1B): stub
fixme:imm:ImmReleaseContext (0x20072, 0x1394a8): stub
fixme:d3d:state_patchedgestyle (WINED3DRS_PATCHEDGESTYLE,1065353216) not yet implemented
err:d3d_shader:shader_glsl_deselect_depth_blt >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glUseProgramObjectARB @ glsl_shader.c / 4612
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_UNSUPPORTED (0x8cdd)
fixme:d3d:context_check_fbo_status Color attachment 0: (0xdcb0138) WINED3DFMT_B8G8R8A8_UNORM 1024x1024
fixme:d3d:context_check_fbo_status Depth attachment: (0xdcb0280) WINED3DFMT_D24_UNORM_S8_UINT 1024x1024
err:d3d:IWineD3DDeviceImpl_ClearSurface >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glClear @ device.c / 4450
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_UNSUPPORTED (0x8cdd)
fixme:d3d:context_check_fbo_status Color attachment 0: (0xdcb0138) WINED3DFMT_B8G8R8A8_UNORM 1024x1024
fixme:d3d:context_check_fbo_status Depth attachment: (0xdcb0280) WINED3DFMT_D24_UNORM_S8_UINT 1024x1024
err:d3d_draw:drawStridedFast >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glDrawElements @ drawprim.c / 47
err:d3d_shader:shader_glsl_deselect_depth_blt >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glUseProgramObjectARB @ glsl_shader.c / 4612
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_UNSUPPORTED (0x8cdd)
fixme:d3d:context_check_fbo_status Color attachment 0: (0xdcb0138) WINED3DFMT_B8G8R8A8_UNORM 1024x1024
fixme:d3d:context_check_fbo_status Depth attachment: (0xdcb0280) WINED3DFMT_D24_UNORM_S8_UINT 1024x1024
err:d3d:IWineD3DDeviceImpl_ClearSurface >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glClear @ device.c / 4450
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_UNSUPPORTED (0x8cdd)
fixme:d3d:context_check_fbo_status Color attachment 0: (0xdcb0138) WINED3DFMT_B8G8R8A8_UNORM 1024x1024
fixme:d3d:context_check_fbo_status Depth attachment: (0xdcb0280) WINED3DFMT_D24_UNORM_S8_UINT 1024x1024
err:d3d_draw:drawStridedFast >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glDrawElements @ drawprim.c / 47
err:d3d_shader:shader_glsl_deselect_depth_blt >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glUseProgramObjectARB @ glsl_shader.c / 4612
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_UNSUPPORTED (0x8cdd)
fixme:d3d:context_check_fbo_status Color attachment 0: (0xdcb0138) WINED3DFMT_B8G8R8A8_UNORM 1024x1024
fixme:d3d:context_check_fbo_status Depth attachment: (0xdcb0280) WINED3DFMT_D24_UNORM_S8_UINT 1024x1024
err:d3d:IWineD3DDeviceImpl_ClearSurface >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glClear @ device.c / 4450
fixme:d3d:context_check_fbo_status FBO status GL_FRAMEBUFFER_UNSUPPORTED (0x8cdd)
fixme:d3d:context_check_fbo_status Color attachment 0: (0xdcb0138) WINED3DFMT_B8G8R8A8_UNORM 1024x1024
fixme:d3d:context_check_fbo_status Depth attachment: (0xdcb0280) WINED3DFMT_D24_UNORM_S8_UINT 1024x1024
err:d3d_draw:drawStridedFast >>>>>>>>>>>>>>>>> GL_INVALID_FRAMEBUFFER_OPERATION (0x506) from glDrawElements @ drawprim.c / 47
fixme:d3d_caps:wined3d_guess_card No card selector available for GL vendor 4 and card vendor 0000.
fixme:win:EnumDisplayDevicesW ((null),0,0x32e2f4,0x00000000), stub!
fixme:keyboard:UnregisterHotKey (0x20072,49269): stub
fixme:d3d:state_patchedgestyle (WINED3DRS_PATCHEDGESTYLE,1065353216) not yet implemented



i dont have bottons for login.. configure etc etc i dont have any bottos. and all my l2 in good installed. i dont know what to do please any one help me . thanks
 
Old 08-16-2010, 07:00 PM   #12
UbuntuRevolution
Member
 
Registered: Aug 2010
Posts: 60

Original Poster
Rep: Reputation: 15
on that screen on the window of the game ( Lineage2 ) i dont have the bottos like ( login, Cancel, ) any botton
 
Old 08-16-2010, 07:16 PM   #13
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
And did you report this problem to the wine folks? Did you check the wine game's database to see if others have gotten it working or to see what hardware is required?

Adam
 
Old 08-16-2010, 07:34 PM   #14
UbuntuRevolution
Member
 
Registered: Aug 2010
Posts: 60

Original Poster
Rep: Reputation: 15
yes i do all, i report.. and my hardware is aall ok, dont know why i dont have any bottons ... :| im seach in google about that like more 10 hours and nothing
 
Old 08-16-2010, 07:41 PM   #15
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 396Reputation: 396Reputation: 396Reputation: 396
For many many years, most wine developers primary used nvidia cards, so they are the best supported GPUs out there. Combined with the fact that the intel GPUs are not high end, I think it's pretty likely that your GPU or drivers just can't handle that game under wine. You'll just have to wait to gear back from the wine developers.

Adam
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Missing agp-gart modules (moving from PCI to AGP video card) JLTB Debian 1 03-31-2005 04:08 AM
I have an onboard AGP, but want to use my nVidia card in my AGP slot. xorg.conf help LordRaven Slackware 16 09-17-2004 05:36 PM
Problems with radeon9200 and agp saruman Linux - Hardware 1 12-17-2003 12:26 PM
SiS AGP Problems mike9010 Linux - Hardware 6 08-27-2003 07:48 AM
nvidia agp problems matt_the_n00b Linux - Newbie 1 07-22-2003 09:27 AM


All times are GMT -5. The time now is 10:38 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration