LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-29-2011, 10:11 PM   #1
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Rep: Reputation: 4
After messing around with Compiz Settings in Ubuntu 11.04, something messed up


For instance, once I tried to enable desktop cube and the like, Docky seems to have crashed or something, because there was a black bar taking up 1/3 of the bottom screen, like when you don't have 3D Hardware Acceleration available. How do I change it back to the way it was?

What I enabled was desktop cube, rotation, negative, opengl, and composite


Okay, the black bar is gone, but now there's no header around the windows, like where the minimize, maximize, and close button are.

Last edited by theif519; 06-29-2011 at 10:19 PM.
 
Old 06-29-2011, 11:06 PM   #2
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
You're still in Compiz.
You should have compiz settings manger, where you can re-enable menu bar. I have to go to my machine and look at settings.
Which graphics are you using intel or nvidia?
 
Old 06-29-2011, 11:14 PM   #3
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Open compiz Settings Manager and check the box next to Windows Decoration.
 
1 members found this post helpful.
Old 06-29-2011, 11:31 PM   #4
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by EDDY1 View Post
You're still in Compiz.
You should have compiz settings manger, where you can re-enable menu bar. I have to go to my machine and look at settings.
Which graphics are you using intel or nvidia?
I'm using Intel
 
Old 06-29-2011, 11:33 PM   #5
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
The machine I checked is intel so it's the same solution.
Compiz Settings Manager is in System>Preferences>CompizConfig Settings Manager.
Window Decoration

Last edited by EDDY1; 06-29-2011 at 11:35 PM.
 
Old 06-29-2011, 11:34 PM   #6
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by EDDY1 View Post
The machine I checked is intel so it's the same solution.
Thank you! It worked. I suppose I shouldn't mess around with Compiz then, because it asked me if I wanted to disable it to enable something else.
 
Old 06-29-2011, 11:37 PM   #7
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Actually, another thing, now I can't move anything. When I unmaximize it, it automatically goes into a corner and I can't move it from there.
 
Old 06-29-2011, 11:39 PM   #8
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Cool glad it worked
Now you should check to see if you have under Applications>Other, you should have Compiz & Metacity. Metacity is what you want when you don't want compiz enabled.
 
Old 06-29-2011, 11:42 PM   #9
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by EDDY1 View Post
Cool glad it worked
Now you should check to see if you have under Applications>Other, you should have Compiz & Metacity. Metacity is what you want when you don't want compiz enabled.
I checked under Applications > Other and I can't find Compiz & Metacity at all. Should I get it from the Ubuntu Software Center?
 
Old 06-29-2011, 11:42 PM   #10
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
Actually, another thing, now I can't move anything. When I unmaximize it, it automatically goes into a corner and I can't move it from there.
Check the box next to "Move Window".
 
1 members found this post helpful.
Old 06-29-2011, 11:46 PM   #11
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
I checked under Applications > Other and I can't find Compiz & Metacity at all. Should I get it from the Ubuntu Software Center?
I have debian so my setup is a little different. You may have to go to "Main Menu" under System>Preferences & find it, but I would check there 1st.

Last edited by EDDY1; 06-29-2011 at 11:47 PM.
 
1 members found this post helpful.
Old 06-29-2011, 11:46 PM   #12
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by EDDY1 View Post
Check the box next to "Move Window".
THANK YOU AGAIN! It worked. I didn't know everything was so reliant on Compiz that I couldn't even move a window without it XD

You said I should disable Compiz for Metacity, right? Is that still required?
 
Old 06-29-2011, 11:47 PM   #13
theif519
Member
 
Registered: Mar 2011
Location: Philadelphia, PA
Distribution: Kubuntu 12.10
Posts: 255

Original Poster
Rep: Reputation: 4
Quote:
Originally Posted by EDDY1 View Post
I have debian so my setup is a little different. You may have to go to "Main Menu" under System>Preferences & find it.
I have it now, but all I see are two gray boxes with a question mark and clicking on it did nothing.

---------- Post added 06-29-11 at 11:48 PM ----------

Also, another problem, the snapping windows thing, like Windows' Aero Snap, is also gone.
 
Old 06-29-2011, 11:49 PM   #14
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
It's not necessary when you log out you'll be in Metacity on re-login.
You can enable compiz when you want to.
 
Old 06-29-2011, 11:55 PM   #15
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
I haven't gotten very far with compiz, but all of your settings and transparency are there to play with.
Now I want to know how you got the dome working?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz on Ubuntu(Studio) - Resizing windows causes Compiz to crash! lostinpurdy Linux - Desktop 1 03-27-2008 11:02 PM
is puppy messing with my boot settings? darinbolson Puppy 2 09-23-2006 08:16 AM
I messed up my network card config settings...help tamere SUSE / openSUSE 3 02-01-2006 05:06 PM
messed with net settings, now X won't start mgyamada Linux - Newbie 2 01-18-2005 12:27 PM
change with monitor settings messed up boot centr0 Linux - Newbie 2 02-26-2003 10:31 PM


All times are GMT -5. The time now is 10:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration