LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-13-2009, 05:31 AM   #1
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Rep: Reputation: 18
After installing Fedora 10 I cannot get Ubuntu 8.10 to load from grub


I have recently been running Ubuntu 8.10 and after seeing a review on Fedora 10 I tried installing it with the intention of dual booting. However since I did this I cannot load up Ubuntu.

Previously I had ubuntu on the whole hard disk, when I installed fedora 10 I put ubuntu into a partition sdb1 (hd0,0) and fedora into another sdb3 (hd0,2)

When I noticed that Ubuntu was not on the GRUB menu at all I edited the file menu.lst in the boot/grub folder and now it looks like this:

default=0
timeout=10
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.5-117.fc10.i686)
root (hd0,2)
Kernel /boot/vmlinuz-2.6.27.5-117.fc10.i686 ro
root=UUID=29e1b313-f65e-$
initrd /boot/initrd-2.6.27.5-117.fc10.i686.img

title Ubuntu 8.10
root (hd0,0)
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=090cd95b-0a94-4d65-96a$
initrd /boot/initrd-2.6.27-11-generic

title Microsoft Windows XP Home Edition
root (hd1,0)
savedefault
makeactive
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1


The menu comes up fine, Fedora and XP (I need rhino for work OK, otherwise it wouldn't be there) work fine, however when I try to load up Ubuntu it does not go to the usual graphic instead I get line after line of text that eventually finishes with:

Gave up waiting for root device. Common problems:
- Boot args (cat /proc/cmdline)
- Check rootdelay= (did the system wait long enough?)
- Check root= (did the system wait for the right device?)
- Missing modules (cat /proc/modules; ls /dev)
ALERT! /dev/disk/by-uuid/090cd95b-0a94-4d65-96a$ does not exist. Dropping to a shell!

BusyBox v1.10.2 (Ubuntu 1:1.10.2-1ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands.

(initramfs)


I took the lines for the ubuntu part of the grub menu from the old menu.lst so I am assuming I have done something wrong. There are no spelling errors as I simply copied and pasted from one to the other. please help.
 
Old 02-13-2009, 06:47 AM   #2
ilikejam
Senior Member
 
Registered: Aug 2003
Location: Glasgow
Distribution: Fedora / Solaris
Posts: 3,109

Rep: Reputation: 96
Hi.

Maybe the Fedora installer's messed about with your disk UUIDs.

The line:
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=090cd95b-0a94-4d65-96a$
in grub.conf/menu.lst is what will probably need to be changed.

You should be able to find the current UUID of the Ubuntu root partition by booting back into Fedora and doing:
# ls -l /dev/disk/by-uuid | grep sdb1

This is all assuming the Fedora install didn't clobber Ubuntu completely, though...

Dave
 
Old 02-13-2009, 08:13 AM   #3
CJS
Member
 
Registered: May 2008
Location: California, USA
Distribution: Ubuntu 8.10
Posts: 247

Rep: Reputation: 49
I would recommend linking to your Ubuntu's menu.lst so you don't have to copy over all the boot stanzas to your Fedora's grub.conf. The safest way to do that is to "chain load" the Ubuntu partition, because Fedora's version of Grub may not be compatible with Ubuntu's version that uses UUIDs instead of root lines, and also supports the newer 256 byte inode ext3 partitions. Anyway, to give it a try, how about booting your Ubuntu Live CD (the Ubuntu install CD), open a terminal (Applications > Accessories > Terminal) and do:
Code:
sudo grub
grub> root (hd0,0)
grub> setup (hd0,0)
grub> quit
Then in your Fedora grub.conf just add:
Code:
title Ubuntu Grub Menu
root (hd0,0)
chainloader +1
Let me know if that works OK for you or not.
 
Old 02-14-2009, 07:11 AM   #4
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
Thanks for all the help

Thanks guys for all your help, I appreciate the time.

However I now have a new problem, after posting this I switched off my computer (Fedora 10 was in use then), however a while later I then went to switch the PC back on and nothing will boot up now.

After checking the CD drive it then fails to load the grub menu, I think that I will cut my loses here and just re-format and install Ubuntu again, I have all my documents etc on an external hard disk so it should not be a problem.

I will let you know if this fixes, I am planning to try this again, but next time I will.

CJS: thanks, that sounds like a better solution for GRUB than the one I tried initially, I wish I had tried this method first, hindsight is a great thing.
 
Old 02-14-2009, 07:43 AM   #5
Udi
Member
 
Registered: Jan 2009
Posts: 165

Rep: Reputation: 44
If you already formatted - then never mind...

But usually the easiest way to reinstall Ubuntu's GRUB is to do:
1) Boot the live D
2) Mount your Ubuntu partition (sdb1 in your case)
3) Run grub-install like this:

sudo grub-install --root-directory=/mnt/sdb1/boot/grub /dev/sdb
 
Old 02-14-2009, 01:11 PM   #6
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
Another attempt

Ok here goes again.

The GRUB menu loads fine, however when I try and load Ubuntu I get this message:

Error 13: Invalid or unsupported executable format

When I select windows XP all that appears is a blinking cursor and nothing happens, no noise from the drives, no flashes from the light.

My menu.lst file in the boot/grub directory now looks like this:

default=1
timeout=5
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.5-117.fc10.i686)
root (hd0,2)
kernel /boot/vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=cdd894fc-275f-$
initrd /boot/initrd-2.6.27.5-117.fc10.i686.img
title Ubuntu 8.10
root (hd0,0)
chainloader +1
title Windows XP
root (hd1,0)
chainloader +1


CJS: when I entered the command:

setup (hd0,0)

I get the line

Error 17: Cannot mount selected partition

Udi: I tried that through the live CD but ended up with this message:

Probing devices to guess BIOS drives. This may take a long time.
/dev/sbd: Not found or not a block device.
 
Old 02-14-2009, 01:19 PM   #7
CJS
Member
 
Registered: May 2008
Location: California, USA
Distribution: Ubuntu 8.10
Posts: 247

Rep: Reputation: 49
Did you run the grub command as root user? Also, did you make sure to do "root (hd0,0)" before "setup (hd0,0)? And about booting XP, you need the mapping lines in your Grub entry:
Code:
title Windows XP
root (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1
If you still have problems, how about downloading the Boot Info Script to your desktop, and then do the following as root user, but replace <username> with your username:
Code:
bash /home/<username>/Desktop/boot_info_script*.sh
That will create a "RESULTS.txt" file in the same directory from where the script is run, namely your desktop; please copy/paste the contents of the RESULTS.txt file to your next post. That will help clarify your setup and hopefully what the solution to your booting problems might be.
 
Old 02-14-2009, 02:06 PM   #8
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
boot info script

CJS - Thanks, that has sorted the windows problem, that was a rookie mistake on my part not to notice that.

I ran boot info script, here is the result.txt:

============================= Boot Info Summary: ==============================

=> Grub0.97 is installed in the MBR of /dev/sda and looks on boot drive #2 in
partition #1 for /boot/grub/stage2 and /boot/grub/menu.lst.
=> Grub0.97 is installed in the MBR of /dev/sdb and looks at sector 618882137
on boot drive #1 for the stage2 file. A stage2 file is at this location on
/dev/sdb. Stage2 looks on partition #3 for /boot/grub/grub.conf.
=> Syslinux is installed in the MBR of /dev/sdc

sda1: _________________________________________________________________________

File system: ntfs
Boot sector type: Windows XP
Boot sector info: No errors found in the Boot Parameter Block.
Operating System: Windows XP
Boot files/dirs: /boot.ini /ntldr /NTDETECT.COM

sda2: _________________________________________________________________________

File system: lvm2pv
Boot sector type: -
Boot sector info:
Mounting failed:
mount: unknown filesystem type 'lvm2pv'

sdb1: _________________________________________________________________________

File system: ext3
Boot sector type: -
Boot sector info:
Operating System:
Boot files/dirs: /boot/grub/menu.lst

sdb2: _________________________________________________________________________

File system: Extended Partition
Boot sector type: -
Boot sector info:

sdb5: _________________________________________________________________________

File system: swap
Boot sector type: -
Boot sector info:

sdb3: _________________________________________________________________________

File system: ext3
Boot sector type: -
Boot sector info:
Operating System: Fedora release 10 (Cambridge)
Kernel on an ()
Boot files/dirs: /boot/grub/menu.lst /boot/grub/grub.conf /etc/fstab

sdc1: _________________________________________________________________________

File system: vfat
Boot sector type: Fat32
Boot sector info: No errors found in the Boot Parameter Block.
Operating System:
Boot files/dirs: /boot/grub/menu.lst

=========================== Drive/Partition Info: =============================

Drive sda: _____________________________________________________________________

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders, total 156301488 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0xc920c920

Partition Boot Start End Size Id System

/dev/sda1 * 63 156,280,319 156,280,257 7 HPFS/NTFS
/dev/sda2 156,280,320 156,296,384 16,065 8e Linux LVM


Drive sdb: _____________________________________________________________________

Disk /dev/sdb: 323.9 GB, 323928170496 bytes
255 heads, 63 sectors/track, 39382 cylinders, total 632672208 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0x3f64f7a6

Partition Boot Start End Size Id System

/dev/sdb1 * 63 409,600,062 409,600,000 83 Linux
/dev/sdb2 620,510,625 632,671,829 12,161,205 5 Extended
/dev/sdb5 620,510,688 632,671,829 12,161,142 82 Linux swap / Solaris
/dev/sdb3 409,609,305 620,510,624 210,901,320 83 Linux


Drive sdc: _____________________________________________________________________

Disk /dev/sdc: 8019 MB, 8019509248 bytes
20 heads, 16 sectors/track, 48947 cylinders, total 15663104 sectors
Units = sectors of 1 * 512 = 512 bytes
Disk identifier: 0xc3072e18

Partition Boot Start End Size Id System

/dev/sdc1 * 80 15,663,103 15,663,024 c W95 FAT32 (LBA)

/dev/sdc1 ends after the last cylinder of /dev/sdc

blkid -c /dev/null: ____________________________________________________________

/dev/sda1: UUID="36A4190DA418D16B" TYPE="ntfs"
/dev/sda2: UUID="QTVAlo-RjLG-0Lwv-9zpD-Helw-JaOM-oTZEP5" TYPE="lvm2pv"
/dev/sdb1: UUID="1a34279b-a441-4624-8bf7-5adffd8ebd16" TYPE="ext3"
/dev/sdb3: LABEL="/" UUID="cdd894fc-275f-4fb9-981b-df60ed708bee" TYPE="ext3"
/dev/sdb5: UUID="fb182b6a-65ae-4ad3-9004-f21e76da1ef0" TYPE="swap"
/dev/sdc1: UUID="6EF1-73D5" TYPE="vfat"

=============================== "mount" output: ===============================

/dev/sdb3 on / type ext3 (rw)
/proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
gvfs-fuse-daemon on /home/kev/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=kev)
/dev/sda1 on /media/disk type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)
/dev/sdb1 on /media/disk-1 type ext3 (rw,nosuid,nodev,uhelper=hal)
/dev/sdc1 on /media/disk-2 type vfat (rw,nosuid,nodev,uhelper=hal,shortname=lower,uid=500)

================================ sda1/boot.ini: ================================

[boot loader]

timeout=30

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect


=========================== sdb1/boot/grub/menu.lst: ===========================

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 10

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
#hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
## password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=1a34279b-a441-4624-8bf7-5adffd8ebd16 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 8.10, kernel 2.6.27-11-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=1a34279b-a441-4624-8bf7-5adffd8ebd16 ro quiet splash
initrd /boot/initrd.img-2.6.27-11-generic
quiet

title Ubuntu 8.10, kernel 2.6.27-11-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.27-11-generic root=UUID=1a34279b-a441-4624-8bf7-5adffd8ebd16 ro single
initrd /boot/initrd.img-2.6.27-11-generic

title Ubuntu 8.10, kernel 2.6.24-19-generic
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=1a34279b-a441-4624-8bf7-5adffd8ebd16 ro quiet splash
initrd /boot/initrd.img-2.6.24-19-generic
quiet

title Ubuntu 8.10, kernel 2.6.24-19-generic (recovery mode)
root (hd0,0)
kernel /boot/vmlinuz-2.6.24-19-generic root=UUID=1a34279b-a441-4624-8bf7-5adffd8ebd16 ro single
initrd /boot/initrd.img-2.6.24-19-generic

title Ubuntu 8.10, memtest86+
root (hd0,0)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title Other operating systems:
root


# This entry automatically added by the Debian installer for a non-linux OS
# on /dev/sda1
title Microsoft Windows XP Home Edition
root (hd1,0)
savedefault
makeactive
chainloader +1


=================== sdb1: Location of files loaded by Grub: ===================


135.9GB: boot/grub/menu.lst
135.5GB: boot/grub/stage2
135.4GB: boot/initrd.img-2.6.24-19-generic
135.3GB: boot/initrd.img-2.6.27-11-generic
135.3GB: boot/vmlinuz-2.6.24-19-generic
135.3GB: boot/vmlinuz-2.6.27-11-generic
135.3GB: initrd.img
135.4GB: initrd.img.old
135.3GB: vmlinuz
135.3GB: vmlinuz.old

========================== sdb3/boot/grub/grub.conf: ==========================

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,2)
# kernel /boot/vmlinuz-version ro root=/dev/sdb3
# initrd /boot/initrd-version.img
#boot=/dev/sdb
default=1
timeout=5
splashimage=(hd0,2)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.27.5-117.fc10.i686)
root (hd0,2)
kernel /boot/vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=cdd894fc-275f-4fb9-981b-df60ed708bee rhgb quiet
initrd /boot/initrd-2.6.27.5-117.fc10.i686.img
title Ubuntu 8.10
root (hd0,0)
chainloader +1
title Windows XP
root (hd1,0)
map (hd0) (hd1)
map (hd1) (hd0)
chainloader +1

=============================== sdb3/etc/fstab: ===============================


#
# /etc/fstab
# Created by anaconda on Sat Feb 14 16:25:33 2009
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
UUID=cdd894fc-275f-4fb9-981b-df60ed708bee / ext3 defaults 1 1
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
UUID=fb182b6a-65ae-4ad3-9004-f21e76da1ef0 swap swap defaults 0 0

=================== sdb3: Location of files loaded by Grub: ===================


316.8GB: boot/grub/grub.conf
316.8GB: boot/grub/menu.lst
316.8GB: boot/grub/stage2
316.9GB: boot/initrd-2.6.27.5-117.fc10.i686.img
316.8GB: boot/vmlinuz-2.6.27.5-117.fc10.i686

=========================== sdc1/boot/grub/menu.lst: ===========================

# You can edit this file to add your own distribution
# You can choose default to 0 to select first entry
# which it is usually the entry for the default distro
#
#
# You can also set timeout to something as 10
#
# This is the shortcut to call Super Grub Disk (commented)
#title Super Grub Disk
## The two commands: setgrubdevice and usbshift are needed
## so that SGD works well.
#usbshift
#configfile $(grub_device)/boot/sgd/menu.lst
#
# Just after default and timeout statements you have to put
# setgrubdevice so that grub device is correctly set.




default 0
timeout 2
setgrubdevice # This is compulsory
#sgdgfxmenu /boot/grub/message
foreground ffffff
background 0c00ff
color white/brown yellow/cyan


#title Inicio normal / Normal Boot
#kernel $(grub_device)/vmlinuz lang=es a11y=none root=/dev/ram0 ramdisk_size=100000 initrd=initramfs quiet BOOT=live splash
#initrd $(grub_device)/initramfs

#title Soporte de accesibilidad / Accesibility Support -->
#configfile $(grub_device)/boot/grub/menu2.lst

title Super Grub Disk
# The two commands: setgrubdevice and usbshift are needed
# so that SGD works well.
usbshift
configfile $(grub_device)/boot/sgd/sgd.lst

#title Normal boot. Kernel is aware of Boot device
#kernel $(grub_device)/vmlinuz lang=es a11y=none root=/dev/ram0 ramdisk_size=100000 initrd=initramfs quiet BOOT=live splash boot_device=$(grub_device)
#initrd $(grub_device)/initramfs

#title Normal boot. Selecting kernel and initrd files depending on grub_device
#kernel $(grub_device)/vmlinuz_$(grub_device_string) lang=es a11y=none root=/dev/ram0 ramdisk_size=100000 initrd=initramfs quiet BOOT=live splash
#initrd $(grub_device)/initramfs_$(grub_device_string)

#title Selecthd test
#configfile $(grub_device)/boot/grub/choose/selecthd.lst

#title findp test
#configfile $(grub_device)/boot/grub/choose/selectpart.lst
#title set SGD variables and boot SGD
#
#configfile $(grub_device)/boot/sgd/menu.lst

=================== sdc1: Location of files loaded by Grub: ===================


.7GB: boot/grub/menu.lst
.7GB: boot/grub/stage2
 
Old 02-14-2009, 02:13 PM   #9
CJS
Member
 
Registered: May 2008
Location: California, USA
Distribution: Ubuntu 8.10
Posts: 247

Rep: Reputation: 49
I think there are some problems with your Ubuntu install on sdb1, because it looks like it is missing its /etc/fstab file and probably some other system files. Your grub.conf is set to boot it if you first do the folowing as root user:
Code:
grub
grub> root (hd1,0)
grub> setup (hd1,0)
grub> quit
But also please post:
Code:
sudo mount /dev/sdb1 /mnt && ls -l /mnt; du -sh /mnt/*
Then try booting Ubuntu from Grub, but I'm really doubtful it will work at this point since I think your Ubuntu install has problems.
 
Old 02-14-2009, 03:11 PM   #10
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
Ubuntu Install

I did have Ubuntu running today without any problems after formatting the hard disk and re-installing Ubuntu first, this worked no bother, and the Fedora second. I will run this and then post the output of the last command you gave me.
 
Old 02-14-2009, 03:16 PM   #11
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
do you think it would be worth reinstalling Ubuntu at this point then?
 
Old 02-14-2009, 03:19 PM   #12
CJS
Member
 
Registered: May 2008
Location: California, USA
Distribution: Ubuntu 8.10
Posts: 247

Rep: Reputation: 49
Quote:
Originally Posted by kmacphail View Post
do you think it would be worth reinstalling Ubuntu at this point then?
How about running the Grub commands first, try booting Ubuntu, and also post the output of the mount command; that will give us a better idea if it is a good idea to reinstall at this point.
 
Old 02-14-2009, 03:26 PM   #13
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
I have just tried running the GRUB commands, this took me to the Ubuntu GRUB menu, but when I selected Ubuntu it started the graphic but the orange part went back and forward and then stopped, I will try this in recovery mode in a minute to get a better idea, but just now I am putting in the mount command.
 
Old 02-14-2009, 03:29 PM   #14
kmacphail
Member
 
Registered: Jan 2009
Location: Isle of Lewis
Distribution: Gentoo, Crunchbang (XFCE)
Posts: 133
Blog Entries: 1

Original Poster
Rep: Reputation: 18
When I tried that command I received the message:

mount: you must specify the filesystem type
du: cannot access '/mnt/*': No such file or directory


The volume is mounted, I did this on the Fedora terminal, did you mean for me to attempt it using the live CD?
 
Old 02-14-2009, 03:34 PM   #15
CJS
Member
 
Registered: May 2008
Location: California, USA
Distribution: Ubuntu 8.10
Posts: 247

Rep: Reputation: 49
I think you are better off just reinstalling Ubuntu at this point. When you go through the installer, I would recommend clicking the "Advanced" button near the end of the installation setup, and there you can specify to have Grub installed to "/dev/sdb1" or the partition you are installing Ubuntu to. Then you should be able to boot Ubuntu using your existing entry in Fedora's grub.conf file. Good luck and let me know how it goes.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows wipes out GRUB - can't load Ubuntu! vincebs Linux - General 3 07-17-2006 04:09 PM
my fedora core 4 cant load my grub an2ny_18 Linux - Software 2 03-09-2006 08:51 PM
After installing Grub did not Load?????? bricfa Fedora 5 01-16-2006 04:13 PM
GRUB can't load Windows XP... Ubuntu for AMD K8 can't boot up Navyblue Linux - Newbie 20 07-31-2005 11:19 AM
Grub will not load Windows XP with Ubuntu dual boot Alex4R Linux - Software 1 03-26-2005 12:29 PM


All times are GMT -5. The time now is 02:41 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration