LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-03-2014, 12:22 PM   #1
tanni
LQ Newbie
 
Registered: Feb 2014
Posts: 4

Rep: Reputation: Disabled
AFS hard mount failing


Hi all,

Specs: DeLL XPS 15Z running a CERN SL Carbon distro.

Last thing I did was download a kernel update. I guess I shouldn't.

System fails to boot now:

afs: hard-mount waiting for a vlserver... (returns code 1)
lost contact with volume location server..

Any ideas what's going on?

Cheers
 
Old 02-04-2014, 05:38 AM   #2
pingwinowiewc
Member
 
Registered: Feb 2014
Location: Europe
Distribution: Debian, Mint, Arch (multiboot)
Posts: 90

Rep: Reputation: Disabled
boot into surveilance mode, do the following:

- clear both /tmp and /var/tmp,
- unmount /home, /dev/sd0, /fstab
- unsign X11 core-unit

After all above, restart computer and boot normally. Give feedback.
 
Old 02-04-2014, 12:41 PM   #3
tanni
LQ Newbie
 
Registered: Feb 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
Thumbs up

Thanks for the feedback. The issue appeared to be simpler:

I assume the new kernel download didn't complete properly.
When booting statically, ie without an internet connection,
the OpenAFS mounting was failing to reach the "base" server machine.

The problem was solved instantaneously once connected to internet.
 
Old 02-05-2014, 12:20 PM   #4
tanni
LQ Newbie
 
Registered: Feb 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
Unhappy Unresolved

Looks like unresolved.

Now tried to boot without Ethernet cable plagued (wireless need pass to go through) and problem persists.
In details here are the messages from the boot log screen:

...(trying to connect to) www.openafs.org/dl/liscence10.html
Disabling lock debugging due to kernel taint
Enabling dynamically allocated vcaches
Starting AFS cache scan...found 5 non-empty cache files (0%)
Lost contact with volume location server ...in cell cern.ch (code -1)

Feedback/solutions will be appreciated.

Last edited by tanni; 02-05-2014 at 12:22 PM.
 
Old 02-10-2014, 10:53 AM   #5
tanni
LQ Newbie
 
Registered: Feb 2014
Posts: 4

Original Poster
Rep: Reputation: Disabled
To pingwinowiewc

Can you please explain in more details (newbie here)
how to proceed with steps you recommended.
- Login in surveillance mode > how ?
- Clear /tmp /var/tmp > delete all subfiles ?
- unmount /home, /dev/sd0, /fstab > shell command? Is it safe?
- unsign X11 core-unit > how ?

Looking for feedback. Need to solve issue soon,
 
Old 02-19-2014, 09:11 AM   #6
pingwinowiewc
Member
 
Registered: Feb 2014
Location: Europe
Distribution: Debian, Mint, Arch (multiboot)
Posts: 90

Rep: Reputation: Disabled
ad 1. You enter surveilance mode by selecting it on grub's (or lilo) screen....
ad 2. yes, just manually delete all files (and subfolders if such exists),
ad 3. when done in surveilance mode it is safe (never ever do it in normal mode because you will damage your distro),
ad 4. when in surveilance mode, issue apt-get purge xserver-xorg* It will do the magick for you.
 
Old 02-21-2014, 10:45 AM   #7
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,932

Rep: Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692
Quote:
Originally Posted by tanni View Post
Looks like unresolved.
Now tried to boot without Ethernet cable plagued (wireless need pass to go through) and problem persists. In details here are the messages from the boot log screen:

...(trying to connect to) www.openafs.org/dl/liscence10.html
Disabling lock debugging due to kernel taint
Enabling dynamically allocated vcaches
Starting AFS cache scan...found 5 non-empty cache files (0%)
Lost contact with volume location server ...in cell cern.ch (code -1)

Feedback/solutions will be appreciated.
Simple enough: it would seem like the AFSD service is trying to start at boot-time, regardless of whether it's connected to the network or not. So, without a network connection, it's sitting there doing nothing until it gets one. Since this machine seems to be on/off the network, stop the AFSD service from starting automatically at boot-time.

I'm not familiar with your distro, but the openAFS guide is here:
http://docs.openafs.org/AdminGuide/i....html#HDRWQ392

..and has some hints. The CERN/SL documentation even mentions AFS at boot:
http://linux.web.cern.ch/linux/scien.../install.shtml
http://linux.web.cern.ch/linux/scien.../install.shtml

Seems like the standard chkconfig statement (see the man page) will work. Boot up on the network, and run (as root/sudo), "chkconfig --del afs", which will remove the service from auto-starting. Then disconnect from the network and reboot, and see what happens. You can always START the service manually by running "/sbin/service afs start"
 
Old 02-21-2014, 10:49 AM   #8
TB0ne
LQ Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 17,932

Rep: Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692Reputation: 3692
Quote:
Originally Posted by pingwinowiewc View Post
ad 1. You enter surveilance mode by selecting it on grub's (or lilo) screen....
ad 2. yes, just manually delete all files (and subfolders if such exists),
ad 3. when done in surveilance mode it is safe (never ever do it in normal mode because you will damage your distro),
ad 4. when in surveilance mode, issue apt-get purge xserver-xorg* It will do the magick for you.
Sorry, ALL of this is wrong and misleading.
  • There is no such thing as 'surveilance' mode. It does not exist in ANY distro of Linux.
  • There aren't any such options on grub or lilo screens for this, since (again), it doesn't exist
  • Deleting things from /tmp and /var/tmp is a VERY BAD IDEA, no matter what mode you're in, unless you KNOW what those things are.
  • Issuing an "apt-get purge" won't do ANYTHING, SINCE THE DISTRO DOES NOT HAVE APT-GET...it's RPM BASED.
  • There is NOTHING wrong with the X server...the OP very clearly says that things work fine, ON THE NETWORK. The system is pausing because a network-based service can't connect. Has ZERO to do with X windows.

OP...please disregard the advice from pingwinowiewc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mount AFS Space chadefa1 Linux - Networking 2 11-18-2007 11:40 AM
NFS mount failing sidra Red Hat 3 04-20-2007 08:49 PM
Failing to mount cdrom kieranw Slackware - Installation 3 11-21-2006 06:48 PM
failing hard disk...i think... zepplin611 Linux - Hardware 3 03-03-2004 09:57 PM


All times are GMT -5. The time now is 03:18 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration