LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-06-2004, 04:35 PM   #1
ratbiter
LQ Newbie
 
Registered: Feb 2004
Posts: 1

Rep: Reputation: 0
ADSL Connection as user, not root


I've recently installed Mandrake 9.2, and am a complete and utter novice at linux. So please, be gentle

I have managed to get connected to the internet with my Alcatel Speedtouch 330 modem, using the speedtouchconf tool. However, I can only connect when logged in as root (which I understand to be a bad thing). When I try to connect as a normal user, I am told that I don't have the privileges to run Mount.

I am connecting by typing "/etc/rc.d/init.d/speedtouch start". Is there another way to connect, that doesn't involve typing this, and can I do it as a non-root user?

Thanks for your help
Alister
 
Old 02-07-2004, 06:22 AM   #2
koen plessers
Member
 
Registered: Aug 2003
Location: Belgium
Distribution: Mint
Posts: 191

Rep: Reputation: 30
Hello

What you could do is this (suppose you use a graphical interface):

Log in as user
Open a terminal
Type "su root"
Enter the root password
Enter the command to start the ADSL connection
Type exit

Bye

Koen
 
Old 02-07-2004, 11:29 AM   #3
mikshaw
LQ Addict
 
Registered: Dec 2003
Location: Maine, USA
Distribution: Slackware/SuSE/DSL
Posts: 1,320

Rep: Reputation: 45
What I did was add the DSL to a startup script, so it would automatically connect. It looks like you're halfway there as it is, since your DSL script is in /etc/rcd.d/init.d (startup stuff)
I'm not sure how Mandrake handles startup processes though. Some distros require a shortcut to a script placed in rc.* directory. Others require the command to be placed in a startup script....in this case the command would be "speedtouch start".
When I had DSL it was roaring penguin pppoe on Slackware, and I added "adsl-start" to the startup script (sorry I can't remember the exact location of this script now)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
adsl-setup or adsl-start not found as user! bnchakraborty Linux - Newbie 2 01-18-2008 10:23 PM
connection refused by X server for root user nemesix Linux - Newbie 3 11-02-2004 12:46 PM
IntelliMouse thumb buttons work as root, broken as non-root user, wheel works always digital vortex Linux - Hardware 7 03-02-2004 04:14 PM
Modem connection fast when logged in as root slow when normal user Fennek Linux - Networking 0 03-17-2003 10:59 AM
Internet connection in root, but no other user daverino Linux - Newbie 1 02-15-2002 10:46 AM


All times are GMT -5. The time now is 10:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration