LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-03-2014, 04:36 AM   #1
AdamSalman
LQ Newbie
 
Registered: Mar 2014
Distribution: Linux Mint 16
Posts: 4

Rep: Reputation: Disabled
Administrative apps and tasks not launching


Hi, I'm a newbie using Linux Mint 16, and after clicking Users and Groups in the Administrative section of system settings, I kinda messed with the settings and changed my user account setting to: Standard. It was originally on Administrative. Now NONE of the applications under the Administration section (Software Manager, Users and Groups, ect) are launching. I click the applications, then a small window shows up saying "Enter your password to perform administrative tasks. I enter my password, and nothing happens. That window just disappears and the application doesn't even launch. I even tried installing an application from Terminal but it didn't allow me to. I need to get into Users and Groups to change my user account setting back to Administrative, but that doesn't even launch because it's an Administrative task. I can't perform any administrative tasks and I need help as soon as possible, thanks for taking the time to read this.
 
Old 03-03-2014, 07:05 AM   #2
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Rep: Reputation: 19
Use the command sudo su in a terminal and then change the administrative password.
 
Old 03-03-2014, 12:40 PM   #3
AdamSalman
LQ Newbie
 
Registered: Mar 2014
Distribution: Linux Mint 16
Posts: 4

Original Poster
Rep: Reputation: Disabled
@decenter: I appreciate your time to reply, but I just now tried that and a message came out in the Terminal saying "Sorry, user adam is not allowed to execute '/bin/su' as root on adam-AU884AA-ABA-CQ5205Y" If it's possible, and my problem can not be sloved, do you mind showing me a way to re-install Linux Mint 16, without losing any of my music, photos, media, etc?
 
Old 03-03-2014, 01:12 PM   #4
anupamsr
Member
 
Registered: Sep 2004
Location: India
Distribution: Kubuntu, Archlinux, Suse, Gentoo, Mandrake
Posts: 370

Rep: Reputation: 30
Okay don't panic. I will give you the ultimate hammer to nail any and every... nail.

Get the Linux mint bootable CD, or in general any bootable CD like grml etc. (Or the bootable USB.)

Boot using this CD. (or USB.)

Get to a point where you can open a terminal.
Enter following commands:
Code:
$ sudo su -
$ cd /
$ mkdir mountdir
$ mount /dev/sda1 /mountdir (replace sda1 with whatever disk number you have)
$ cd mountdir
$ mount -t proc none proc
$ mount --bind /dev dev
$ mount --bind /sys sys
$ cd ..
$ chroot mountdir /bin/bash
$ passwd (<--- change password of root)
$ reboot
That should do it. I think the mount options of proc, dev and sys will not be essential, but let me know if they were.

Okay, now that you know have got the hammer, time to check if it is even needed or we can do other things.
1. Try creating a new account using Linux mint CD.
2. See if sudo vim works. If it does you can do wonders.
 
Old 03-03-2014, 01:21 PM   #5
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,050

Rep: Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108
Wow, there is some bad advice in this thread!

First, read this (Mint is based on Ubuntu so it uses 'sudo' too): https://help.ubuntu.com/community/RootSudo

Second, here are easy instructions (with screenshots) to boot into Recovery Mode and re-add your user to the 'sudo' group so you can be an administrator again: http://www.psychocats.net/ubuntu/fixsudo

Good luck!
 
2 members found this post helpful.
Old 03-03-2014, 01:58 PM   #6
AdamSalman
LQ Newbie
 
Registered: Mar 2014
Distribution: Linux Mint 16
Posts: 4

Original Poster
Rep: Reputation: Disabled
@ snowpine: Thanks, you have solved my problem
 
Old 03-03-2014, 09:48 PM   #7
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Rep: Reputation: 19
Its Great you have resolved with the help of link posted by snowpine. This issue is because there is no root password set in the system. It is advised that you have root password set in your system. Please set the root password by entering in to terminal and typing these commands:

sudo su

enter your(current user's) password. You will then be dropped in a root shell. So, after this type

passwd

this is where you set the password for the root account.

Now, the root account will have the password and from next time, if you lockout yourself, you can use this root password to gain access to administrative menus and resolve the issue.
 
Old 03-04-2014, 06:40 AM   #8
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,050

Rep: Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108
AdamSalman, please ignore dcenter's questionable advice that contradicts all official Mint documentation. There is no reason to set a root password in Mint/Ubuntu. The problem you presented in this thread was caused by user error, not by lack of a root password, and was easily solved without circumventing security.

Last edited by snowpine; 03-04-2014 at 08:23 AM.
 
Old 03-04-2014, 08:44 PM   #9
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Rep: Reputation: 19
Sorry if I posted wrong information. Thought it would help. I reproduced this issue. I changed my user from administrative to standard. After reboot, I couldn't execute sudo su command in terminal. It said "is not allowed to execute '/bin/su'" . But to my surprise, if I enter su and enter my user password, it goes to root prompt. (I didn't set any root password) I can even open administrative apps. I too checked the recovery menu and when I select drop to root shell, it asked for root password to continue. I rebooted again and I could unlock the user settings and change the user type standard to administrative.

Last edited by decenter; 03-04-2014 at 08:52 PM.
 
Old 03-04-2014, 09:48 PM   #10
snowpine
Senior Member
 
Registered: Feb 2009
Posts: 4,050

Rep: Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108Reputation: 1108
'sudo su' is never recommended in Ubuntu or Mint as explained here: http://ubuntuforums.org/showthread.p...26#post6188826

No official Mint documentation will ever tell you to 'sudo su'.
 
Old 03-04-2014, 10:13 PM   #11
decenter
Member
 
Registered: Sep 2011
Distribution: Fedora release 21 (Twenty One)
Posts: 156

Rep: Reputation: 19
Ok. great. Thread solved.
 
  


Reply

Tags
administrator, tasks


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Automating administrative tasks in Fedora 10 jawest Linux - Newbie 5 01-14-2011 07:30 PM
simpler GUI password for Administrative tasks while retaining complex user password? workforfood Ubuntu 1 08-29-2009 07:48 AM
Can't unlock some administrative tasks in Ubuntu 8.04 jonette20 Ubuntu 6 08-22-2009 12:21 PM
LXer: LPI Exam Training: Administrative Tasks LXer Syndicated Linux News 0 07-12-2007 10:46 AM
Access CUPS web interface "Administrative Tasks" ALInux Linux - Networking 2 05-24-2006 03:55 AM


All times are GMT -5. The time now is 10:06 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration