LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-27-2004, 01:25 AM   #1
paschim
Member
 
Registered: Apr 2004
Location: UK, south london
Posts: 51

Rep: Reputation: 15
adding user


I tried to add user by giung to su from my account and typped command

useradd XXXX

it says DOMAIN NOT BOUND, AND i CAN'T ADD USER . CAN ANYONE HELP ME PLS?
 
Old 06-27-2004, 01:39 AM   #2
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 46
please explain your environment. Seems you are not using the default authentication mechanism ... using either Samba/NFS/kerberos???
 
Old 06-27-2004, 01:42 AM   #3
paschim
Member
 
Registered: Apr 2004
Location: UK, south london
Posts: 51

Original Poster
Rep: Reputation: 15
I am using suse 9 . I just installed it yesterday. I made one user from yast and i am running in that user.

So now I want to make another user from that user and the error comes like this
YPBINDPROC_DOMAIN: Domain not bound

I just know this, I don't have deep knowledge in linux
 
Old 06-27-2004, 02:14 AM   #4
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,059

Rep: Reputation: 295Reputation: 295Reputation: 295
Looks like you somehow set your system up to use NIS for its authentication (ypbind is part of the NIS suite of utilities). Unfortunately, since I've never set this up I'm not sure how you would go about undoing it, since if you don't know what NIS is, chances are you don't want it.
I did do a little googling which may help -- first off try seeing if you have a ypbind daemon running (do ps aux | grep ypbind on the command line, if you see something besides your grep command listed, you do). If you do, kill it (killall ypbind should do nicely) then remove the /etc/defaultdomains file (actually might be best to move it off somewhere else in case something gets messed up and you need it back). Then try again and see if that helps. Also, if there's a line in your /etc/passwd file begininng with a +: you should probably remove it (this line tells NIS to import user data from an NIS server).

I'm not much of an expert on NIS, but I hope this helps some.
 
Old 06-27-2004, 05:05 AM   #5
ppuru
Senior Member
 
Registered: Mar 2003
Location: Beautiful BC
Distribution: RedHat & clones, Slackware, SuSE, OpenBSD
Posts: 1,791

Rep: Reputation: 46
does yast have an option to revert back to MD5 authentication from NIS?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
adding user hoopy Linux - General 3 09-13-2005 09:38 PM
adding a new user Cinematography MEPIS 5 07-25-2005 09:19 PM
Adding second user jnhannah Linux - Security 1 06-27-2004 02:50 PM
Adding a new user Yohhan Linux - Software 3 01-23-2003 07:17 PM
user adding sathu Linux - Newbie 1 02-12-2002 05:19 AM


All times are GMT -5. The time now is 10:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration