LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-07-2015, 07:22 AM   #1
gcdesroches
LQ Newbie
 
Registered: Dec 2015
Location: Tennessee
Posts: 6

Rep: Reputation: Disabled
add to startup programs in Debian Jessie Gnome


In the old Debian you could add a script to the startup files for a user to run at logon pretty easily. I found the startup section in the menus but the check box list from past Debian releases is gone and there is no option for navigating to your script/program to add it. There is a + bar but the only options are the preinstalled programs from the original setup. So can someone tell me which leg to stand on while chanting whatever the new chant is and how many goats to sacrifice to accomplish what used to be a simple mouse click?

Wonder why Linux is following Microsoft down the road of moving features with every release which just adds difficulty and hiding options in ever deeper menu levels just because they can. I always thought Linux was meant to be better than that.

Last edited by gcdesroches; 12-08-2015 at 05:32 AM.
 
Old 12-08-2015, 04:23 PM   #2
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Void, Debian
Posts: 808

Rep: Reputation: 216Reputation: 216Reputation: 216
Hmm, I haven't used Gnome in a while, so I need to grab the live image (1.3GB) to take a look at the dialog you are talking about. I don't mind doing that, since I had this on my distros-to-look-at list anyways, but you might want to post a screenshot of the dialog so that maybe someone can come up with an idea by looking at it.

I understand your frustration about things changing when actually they used to work well for you - but please allow me to point out that ranting at "Linux" in general is a bit unfair as the term Linux actually only refers to the kernel - which in turn has nothing to do with the issue you are having right now.

What you should be ranting at (if anything) is the desktop environment (in this case Gnome).
If you are like me then you might find it more convenient to use a more conservative desktop. E.g. XFCE tends to change less over time, but if you really want to be in control try one of the light-weight window managers such as openbox or fluxbox.
They have a steep learning curve because most of the configuration is done in simple text files, but once you get the hang of it you will find that you can port your setup from one distro to another in almost no time - without ever having to wrestle with what some GUI designer thought would be good for you.
 
Old 12-08-2015, 05:00 PM   #3
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Void, Debian
Posts: 808

Rep: Reputation: 216Reputation: 216Reputation: 216
Ok, just looked at it now. Unbelievable as it may seem, I think you are right - you can't add a custom command through the GUI. (Who thought this would be a good idea - I am wondering...)

But there seems to be a workaround. (You'll have to get your hands a bit dirty on the console though).
I created a starter for one of the proposed applications just to see what happens and found that a .desktop file was added to ~/.config/autostart
(gimp.desktop in my case because I added gimp as a startup program in my test)

In other words, if you list the entries of that folder
Code:
ls -l ~/.config/autostart
you'll see all existing startup entries.
Now you can create a .desktop file yourself and place it into that directory, and that should execute the configured command at startup.
Here is an explanation on how to write such files from the arch wiki
There are plenty of other resources on the web. Throw the term "how to write a .desktop file" at your favorite search engine.

Or, again, you might just switch to a leaner desktop environment :-) On openbox, you just add your startup commands to a script located at ~/.config/openbox/autostart and that's it...

Either way - best of luck!
 
1 members found this post helpful.
Old 12-08-2015, 05:05 PM   #4
gcdesroches
LQ Newbie
 
Registered: Dec 2015
Location: Tennessee
Posts: 6

Original Poster
Rep: Reputation: Disabled
While I was sort of "ranting at Linux" as you say, I think I was more passive aggressively ranting at Microsoft than anything. We just got the office 2013 upgrade at work and once again everything has moved.

At least here I was able to get everything back up except auto-running the script. If I was to rant at Linux for real it would be directed at the communities tendency to belittle and rag people that are "not as smart as they are" which happens in very many forums. It is this that led me to post here. This forum seems to be much more willing to educate than berate. (Thanks to all for that). In fact I think any answers I have managed to get from a forum have come from reading posts on this site.

So, I can post a screen shot once I get home to my server.
You will see that all it will show is a window with a list of the files located in /usr/share/applications
Any of these can be selected to start at logon. However a .sh file placed in that directory will not show up in the list and there is no option to select files from other locations. Seems like the last version of gnome allowed you to navigate and choose what you wanted.
 
Old 12-08-2015, 05:12 PM   #5
gcdesroches
LQ Newbie
 
Registered: Dec 2015
Location: Tennessee
Posts: 6

Original Poster
Rep: Reputation: Disabled
ls -l ~/.config/autostart shows total 0

I assume it is hidden? I can't see that path so either it is hidden or doesn't exist.

I will read your link and see if I can work it that way.

Thank you for your response. It is greatly appreciated.
 
Old 12-08-2015, 06:28 PM   #6
gcdesroches
LQ Newbie
 
Registered: Dec 2015
Location: Tennessee
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thumbs up

Well this was an adventure.

The .desktop shortcut worked.
I could not call the script directly, don't know why, it only gave the message "there was an error executing"
I ended up just placing the actual command line as the exec= parameter and telling it t launch in a terminal.
It now is happy.

Thanks again for the suggestions, you got me where I needed to go.
 
Old 12-09-2015, 03:20 AM   #7
joe_2000
Member
 
Registered: Jul 2012
Location: Aachen, Germany
Distribution: Void, Debian
Posts: 808

Rep: Reputation: 216Reputation: 216Reputation: 216
Quote:
Originally Posted by gcdesroches View Post
ls -l ~/.config/autostart shows total 0

I assume it is hidden? I can't see that path so either it is hidden or doesn't exist.
This probably just means you did not have any of the "standard" applications in auto startup.

Anyway, great you got it working!
 
  


Reply

Tags
debian jessie


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to add programs to startup after reboot.... ringding Linux - Newbie 5 07-13-2009 11:44 PM
Add programs to startup an_sush Linux - Newbie 6 07-05-2009 04:08 AM
How to add startup programs in Sessions? markw10 Ubuntu 2 03-11-2009 04:25 AM
gnome startup programs Steve Riley Red Hat 1 03-13-2008 08:28 PM
gnome startup programs lacrimae Linux - Newbie 0 04-21-2002 02:41 PM


All times are GMT -5. The time now is 09:16 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration