LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-31-2013, 03:49 AM   #1
bxxst
LQ Newbie
 
Registered: Jul 2013
Posts: 4

Rep: Reputation: Disabled
Add new multipath device on line


Hi

First of all sorry for the stupid question...

I need to add new multipath disk on line to my server (REHL 5.7 x64) without lose I/O

I have already done some step but i am on death point because i dont't find answers on network.

My step:
1- Created lun on SAN storage and map ip to server
2- Rescan device on server
# cd /sys/class/scsi_host/host1
# echo - - - > scan
# cd /sys/class/scsi_host/host2
# echo - - - > scan
3- I find new device on /sys/block and check that they are the new device correctly
# ls /sys/block/sdn/device/
and chech that scsi_device:*:*:*:*is the right lun number
4- Get the right wwid of new device for all disk
# scsi_id -g -s /block/sdn
5- Put wwid on blacklist_exceptions on /etc/multipath.conf
6- Create friendly name on /var/lib/multipath/bindings

If i run
# mulitpath -ll
i don't get new device

I done all correctly?
How i can proced to put online new device without rebooting server and/or lose I/O?

Thank for all
 
Old 08-01-2013, 07:40 AM   #2
vishesh
Member
 
Registered: Feb 2008
Distribution: Fedora,RHEL,Ubuntu
Posts: 661

Rep: Reputation: 66
Does your multipath service is running , if no then start it

/etc/init.d/multipathd start

Thanks
 
Old 08-02-2013, 04:20 PM   #3
bxxst
LQ Newbie
 
Registered: Jul 2013
Posts: 4

Original Poster
Rep: Reputation: Disabled
Solved by my self

I done all right

The only steps missing was

# mutlipath -v2

and device bring up

Thanks to all
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot from multipath device on Redhat 5.4 (kernel 2.6.18.308) Zen1988 Linux - Server 0 07-08-2012 10:52 PM
device-mapper-multipath, slow failover period. Gangrif Linux - Software 2 02-07-2011 11:22 AM
Problem: Delay construction of multipath device (/ dev/dm-3) chilon Linux - Server 0 01-07-2010 12:00 PM
device mapper / multipath creating extra device, won't let me talk to the one i want chakkerz Linux - Server 1 03-16-2008 06:52 PM
partition a mappered device using multipath smile2 Linux - Hardware 1 05-04-2007 11:24 AM


All times are GMT -5. The time now is 12:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration