LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-21-2004, 12:28 AM   #1
JimDog
Member
 
Registered: Aug 2003
Location: Colorado, USA
Distribution: Fedora Core
Posts: 100

Rep: Reputation: 15
acpi (no /proc/acpi)???


So I'd like to change my linux box so that pushing the power button will not shut down the computer (perhaps run a script that prompts the user "are you sure" instead). So I looked into ACPI. I followed the HOWTO (http://www.tldp.org/HOWTO/ACPI-HOWTO/), patched, recompiled kernel, the whole bit. I even added acpi=on to grub.conf (found on some other thread). But I still have no /proc/acpi. Modules are not loading because "no such device" (I'm guesing /proc/acpi). Any ideas?

RedHat 9
Kernel 2.6.1 (w/ acpi patch)
HP Pavilion desktop computer (not a laptop; does that matter?).

Thanks in advance
 
Old 01-25-2004, 12:37 AM   #2
JimDog
Member
 
Registered: Aug 2003
Location: Colorado, USA
Distribution: Fedora Core
Posts: 100

Original Poster
Rep: Reputation: 15
anyone???

More info incase anyone out there has any ideas for me:

dmesg | grep acpi gives me this:
thermal: Unknown symbol acpi_processor_set_thermal_limit
 
Old 01-25-2004, 01:14 AM   #3
JimDog
Member
 
Registered: Aug 2003
Location: Colorado, USA
Distribution: Fedora Core
Posts: 100

Original Poster
Rep: Reputation: 15
Got it...

Found a thread somewhere else that mentioned using "acpi=force" instead of "acpi=on". I did that and now I have a /proc/acpi with all the sub directories.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
/proc/acpi/... slow opening (tm) Linux - General 1 04-21-2004 07:43 AM
/proc/acpi missing no_leaf_clover Linux - Software 3 12-18-2003 05:28 AM
/proc/acpi does not exiat jjge Linux - Software 2 09-09-2003 02:00 PM
/proc/acpi PROBLEM!!! leros Linux - Hardware 1 08-03-2003 07:39 PM
kernel 2.4.20 & acpi-20021212-2.4.20.diff => no /proc/acpi Tinkster Linux - Software 5 03-24-2003 02:56 PM


All times are GMT -5. The time now is 09:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration