LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-23-2008, 05:58 AM   #1
marensius
LQ Newbie
 
Registered: Aug 2008
Posts: 9

Rep: Reputation: 0
Acer TravelMate 6460 wireless problem


Hello,

You must be seriously tired off threads like this,but
after a while I am quite tired off reinstalling(yep I am a newb)
and searching for how to fix my wireless problem.

I am quite new in the linux world and have installed
Slackware 12.1 on my Acer TravelMate 6460 laptop.

I've managed to install Slack and slackbuildgnome.
and now my problem is.

How to enable the wireless card(dont think I have installed
it correctly) and connect to my wireless router.

when i do a scan I get

PHP Code:
wlan0     Scan completed :
          
Cell 01 Address00:18:39:21:6B:CA
                    ESSID
:"Tangedahl"
                    
Mode:Master
                    Channel
:2
                    Frequency
:2.417 GHz (Channel 2)
                    
Quality=83/100  Signal level=-51 dBm  Noise level=-127 dBm
                    Encryption key
:on
                    Bit Rates
:1 Mb/s2 Mb/s5.5 Mb/s11 Mb/s6 Mb/s
                              9 Mb
/s12 Mb/s18 Mb/s24 Mb/s36 Mb/s
                              48 Mb
/s54 Mb/s
                    Extra
:tsf=0000008a42a82a1f 
But cant seem to connect to it with using
iwconfig commands (it may be that Im doing something wrong..)

I have NOT installed any Network Cards (dont know how,yes its true)
so I hoped that it did it itself with some standard sources.

When I do a lspci command I get this;

PHP Code:
00:00.0 Host bridgeIntel Corporation Mobile 945GM/PM/GMS943/940GML and 945GT Express Memory Controller H$
00:01.0 PCI bridgeIntel Corporation Mobile 945GM/PM/GMS943/940GML and 945GT Express PCI Express Root Por$
00:1b.0 Audio deviceIntel Corporation 82801G (ICH7 FamilyHigh Definition Audio Controller (rev 02)
00:1c.0 PCI bridgeIntel Corporation 82801G (ICH7 FamilyPCI Express Port 1 (rev 02)
00:1c.1 PCI bridgeIntel Corporation 82801G (ICH7 FamilyPCI Express Port 2 (rev 02)
00:1c.2 PCI bridgeIntel Corporation 82801G (ICH7 FamilyPCI Express Port 3 (rev 02)
00:1c.3 PCI bridgeIntel Corporation 82801G (ICH7 FamilyPCI Express Port 4 (rev 02)
00:1d.0 USB ControllerIntel Corporation 82801G (ICH7 FamilyUSB UHCI Controller #1 (rev 02)
00:1d.1 USB ControllerIntel Corporation 82801G (ICH7 FamilyUSB UHCI Controller #2 (rev 02)
00:1d.2 USB ControllerIntel Corporation 82801G (ICH7 FamilyUSB UHCI Controller #3 (rev 02)
00:1d.3 USB ControllerIntel Corporation 82801G (ICH7 FamilyUSB UHCI Controller #4 (rev 02)
00:1d.7 USB ControllerIntel Corporation 82801G (ICH7 FamilyUSB2 EHCI Controller (rev 02)
00:1e.0 PCI bridgeIntel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridgeIntel Corporation 82801GBM (ICH7-MLPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 FamilySATA IDE Controller (rev 02)
00:1f.3 SMBusIntel Corporation 82801G (ICH7 FamilySMBus Controller (rev 02)
01:00.0 VGA compatible controllerATI Technologies Inc M52 [Mobility Radeon X1300]
02:00.0 Ethernet controllerBroadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02)
05:00.0 Network controllerIntel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
09:04.0 FireWire (IEEE 1394): O2 MicroIncFirewire (IEEE 1394) (rev 02)
09:04.1 CardBus bridgeO2 MicroIncUnknown device 7175 (rev 21)
09:04.2 SD Host controllerO2 MicroIncIntegrated MMC/SD Controller (rev 01)
09:04.3 Mass storage controllerO2 MicroIncIntegrated MS/xD Controller (rev 01)
09:05.0 CardBus bridgeO2 MicroIncOZ601/6912/711E0 CardBus/SmartCardBus Controller (rev 40)
09:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link
Hope that all this info tells something about my problems and solutions.
The main problem is that I cant connect to any wireless network
(my is Tangedahl) and I have not installed any network cards
(honnestly I dont know witch card I have)

Hope for some big help her, and if so please explain in details so
that I understand. Thanks for any answers in this matter.
 
Old 08-23-2008, 08:19 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Welcome to LQ!

Quote:
05:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
The really good news is that Intel cards are very well supported, and Slackware 12.1 supports teh 3945 right out of the box (in fact it is the same chipset I've got).

I'm guessing that you haven't been able to configure the card yet. How you do that depends (at least a little) on your network. If you're using either no encryption or WEP encryption, you can just use iwconfig. Based on my experience, I suspect your wireless is called wlan0. Check the output of iwconfig to be sure however. Oh, and you do have to be root when configuring the card:

iwconfig wlan0 essid Tangedahl
iwconfig wlan0 key YourWEPKeyInHex (or you can do iwconfig wlan0 key s:YourWEPKeyInText)

If those two have worked, if you look at iwconfig again, you should see a MAC address in the Access Point field. If that is there, then request an IP address:

dhcpcd wlan0

If that goes without errors, you then should be good to go.

However, if you use WPA encryption, you need to take a different method and use a program called wpa_supplicant (which should be part of the standard Slackware install). In that case you need to edit /etc/wpa_supplicant.conf so that your network configuration is present. It would look something like this:

Code:
network={
ssid="WPA_NETWORK_SSID"
scan_ssid=1
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="WPA_Passphrase"
}
You would then start it like this (again as root):

wpa_supplicant -Bw -Dwext -c/etc/wpa_supplicant.conf -iwlan0

Once you've associated with the AP, then you request an IP address with dhcpcd.

If you want to go the GUI route, I've had excellent luck with wicd, and you can find slackbuild scripts for it at Slackbuilds.org.
 
Old 08-23-2008, 11:36 AM   #3
marensius
LQ Newbie
 
Registered: Aug 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Thank you for your answer Hangdog42.

And the network has WEP key on it.
Its a linksys router I have,

I did all the commands that u said, and I've tried them before.
However when i type "dhcpcd wlan0" it disapears when
I do an ifconfig afterwards. so I try to ifconfig wlan0 up
,then it comes back, so when I try ping adress.somewhere it says
unkown host. And you have correct when you guess that
I havent been able to configure the card yet.

So to this time I've done

PHP Code:
iwconfig wlan0 essid Tangedahl
iwconfig wlan0 key s
:<my password>
dhcpcd wlan0 
and then "wlan0" disapears when I do ifconfig afterwards.
on "iwconfig" it says mode:managed, hode this is correct?

Any ideas of what Im doing wrong or any information I can
put here that would help you to help me to get it working
 
Old 08-23-2008, 04:19 PM   #4
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
I'm guessing that there is a problem associating with the access point. Run the two iwconfig command and then post the output of iwconfig wlan0 so we can see what it looks like once it has been configured (but before dhcpcd has been run). Having wlan0 disappear from the ifconfig output is pretty normal if dhcpcd has failed.

Quote:
I do ifconfig afterwards.
on "iwconfig" it says mode:managed, hode this is correct?
Being in managed mode is correct.
 
Old 08-24-2008, 03:45 AM   #5
marensius
LQ Newbie
 
Registered: Aug 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Okey, here is some more information,tell me if
theres something else I need to put here to.

I start my laptop and hit the wireless power switch or
what you want to call it (ByTheWay this switch does
not light up when I hit it as it did in Windows)

then when I have done that I check with ifconfig
how it looks(NB I have done ifconfig eth0 down here
before I check ifconfig,since I didnt want 2 network
cards stacking)

(This is the eth0 connection)
PHP Code:
eth0      Link encap:Ethernet  HWaddr 00:a0:d1:a0:d8:e1  
          inet addr
:192.168.0.2  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr
fe80::2a0:d1ff:fea0:d8e1/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU
:1500  Metric:1
          RX packets
:920 errors:3 dropped:0 overruns:0 frame:0
          TX packets
:1410 errors:0 dropped:0 overruns:0 carrier:0
          collisions
:4 txqueuelen:1000 
          RX bytes
:859612 (839.4 KiB)  TX bytes:204108 (199.3 KiB)
          
Interrupt:16 
And here is the ifconfig after I have disabled eth0
PHP Code:
lo        Link encap:Local Loopback
          inet addr
:127.0.0.1  Mask:255.0.0.0
          inet6 addr
: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU
:16436  Metric:1
          RX packets
:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets
:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions
:0 txqueuelen:0
          RX bytes
:(0.0 B)  TX bytes:(0.0 B)

wlan0     Link encap:Ethernet  HWaddr 00:18:de:75:3c:d4
          inet6 addr
fe80::218:deff:fe75:3cd4/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU
:1500  Metric:1
          RX packets
:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets
:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions
:0 txqueuelen:1000
          RX bytes
:(0.0 B)  TX bytes:588 (588.0 B)

wmaster0  Link encap:UNSPEC  HWaddr 00-18-DE-75-3C-D4-77-6C-00-00-00-00-00-00-00-00
          UP BROADCAST RUNNING MULTICAST  MTU
:1500  Metric:1
          RX packets
:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets
:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions
:0 txqueuelen:1000
          RX bytes
:(0.0 B)  TX bytes:(0.0 B
Now, I hit the two iwconfig essid/key s: commands and do an iwconfig
PHP Code:
wlan0     IEEE 802.11g  ESSID:"Tangedahl"
          
Mode:Managed  Frequency:2.417 GHz  Access Point00:18:39:21:6B:CA
          Bit Rate
=54 Mb/s   Tx-Power=27 dBm
          Retry min limit
:7   RTS thr:off   Fragment thr=2346 B
          Encryption key
:3143-4344-4437-4234-3339
          Link Quality
=98/100  Signal level=-27 dBm  Noise level=-127 dBm
          Rx invalid nwid
:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries
:0  Invalid misc:0   Missed beacon:
and at this point I am back to looking like the questionmark that I am
at this moment.

Ok, at this point I try to hit dhcpcd wlan0 and something happends
(I dont get any information so I try ifconfig)

PHP Code:
lo        Link encap:Local Loopback
          inet addr
:127.0.0.1  Mask:255.0.0.0
          inet6 addr
: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU
:16436  Metric:1
          RX packets
:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets
:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions
:0 txqueuelen:0
          RX bytes
:(0.0 B)  TX bytes:(0.0 B
 
Old 08-24-2008, 09:01 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
This is unfortunate. Your iwconfig after you configured the card looks to be just fine. You've definitely associated with your access point, which is where you want to be.

What you need to do now is to dig into your log files (/var/log/messages, /var/log/syslog and dmesg output) and see if either the wireless card or dhcpcd are leaving any clues. You also might try running dhcpcd with the -S flag and see if that helps (it forces a second DHCP_DISCOVER message which can be useful sometimes).

The other thing to try would be to set the IP address manually just to see if everything is actually working. There are three steps to this:

1) Set the IP address: ifconfig wlan0 XXX.XXX.XXX.XXX where xxx.xxx.xxx.xxx is a valid IP address for your lan.

2) Set the gateway: route add default gw yyy.yyy.yyy.yyy where yyy is the IP address of your router

3) Add at least one DNS server to /etc/resolv.conf:

nameserver zzz.zzz.zzz.zzz

Check your router, odds are there is a page that lists the DNS server your ISP has you using. Enter those. If you can't find it, try using the IP address of your router, that may work.

After those three steps are done, you should be able to access the Internet.
 
Old 08-27-2008, 06:43 AM   #7
marensius
LQ Newbie
 
Registered: Aug 2008
Posts: 9

Original Poster
Rep: Reputation: 0
Thank you for your help Hangdog42,
I have now taken my laptop to my school and
I was able to connect with the Wireless network here.

But as it seems I cant make it work at home so I belive
that the problem is now the key to login.

I'll check on it laters.
 
Old 08-27-2008, 08:12 AM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
I would double-check the WEP key, but if it seems correct, try turning off WEP encryption temporarily and see if you can connect to your home router then. If you can, then the WEP key is definitely the issue. If you still can't, then there is some other problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No wireless connection after installing Ubuntu on my Acer TravelMate 5520! Help! TommyGun Linux - Newbie 65 09-16-2011 07:34 PM
Wireless activation button on Acer Travelmate 4720 kit.johnson Linux - Hardware 3 07-31-2008 10:54 AM
Acer Wireless travelmate nerak99 Linux - Laptop and Netbook 4 04-20-2008 01:48 PM
Intel Wireless Pro 2200bg on Acer TravelMate 290 with Mandriva Linux, slight problem! tfm1 Linux - Laptop and Netbook 1 06-23-2006 04:38 AM
Mandriva 10.0 on Acer Travelmate 2413WLMin(travelmate 2410 series). Wireless... apolishch Linux - Laptop and Netbook 2 06-05-2006 09:03 AM


All times are GMT -5. The time now is 11:07 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration