LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-20-2007, 06:01 AM   #1
swarnimsoni
LQ Newbie
 
Registered: Sep 2007
Posts: 3

Rep: Reputation: 0
Question accessing ntfs file system drives


linux is not allowing me to access NTFS partitions created in windows
 
Old 09-20-2007, 06:08 AM   #2
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
You will need to install fuse and ntfs-3g to allow read/write on ntfs partitions. What distro are you using?
 
Old 09-20-2007, 07:58 AM   #3
saintkay
LQ Newbie
 
Registered: Aug 2007
Location: Kampala, Uganda, East Africa
Distribution: debian 4.0
Posts: 27

Rep: Reputation: 0
usually linux distros lack write access to ntfs drives but you can mount the partion at the prompt after logging in as root.
you can pass something simillar to this at the prompt;
mount -t ntfs /dev/hda1 (refering to the first primary partition on the primary master)
mount -t ntfs /dev/sda1 (refering to the first scsi hdd)
remember the 1st hd is a, 2nd b; 3rd is c; and last d;

hope this helps
 
Old 09-22-2007, 11:09 PM   #4
kyodo
LQ Newbie
 
Registered: Sep 2007
Posts: 5

Rep: Reputation: 0
Quote:
Originally Posted by saintkay View Post
usually linux distros lack write access to ntfs drives but you can mount the partion at the prompt after logging in as root.
you can pass something simillar to this at the prompt;
mount -t ntfs /dev/hda1 (refering to the first primary partition on the primary master)
mount -t ntfs /dev/sda1 (refering to the first scsi hdd)
remember the 1st hd is a, 2nd b; 3rd is c; and last d;

hope this helps
Hi, I'm using Red Hat Enterprise Linux 5 but I cannot mount a NTFS partition by command: mount -t ntfs /dev/hdb5 /hd_data as you say! Could you help me please?
Best regards!
 
Old 09-23-2007, 12:08 AM   #5
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
What do you mean by accessing? Reading and/or writing? You probably need to use the proper permissions on the hd_data directory (umask,uid and gid in /etc/fstab). For a partition sda1, you would put this line in /etc/fstab:

/dev/sda1 /hd_data ntfs-3g defaults,rw,gid=500,uid=500,umask=0022 0 2

The 500 refers to RedHat/Fedora systems. Other systems assign 1000 by default to the first created user.

Last edited by jay73; 09-23-2007 at 12:10 AM.
 
Old 09-25-2007, 06:30 PM   #6
kyodo
LQ Newbie
 
Registered: Sep 2007
Posts: 5

Rep: Reputation: 0
Yes, thank you, jay73! I've installed ntfsmount package and then I could mount ntfs partition in Red Hat Enterprise Linux 5.
 
Old 10-12-2007, 04:59 AM   #7
w_barnes
LQ Newbie
 
Registered: Sep 2007
Posts: 5

Rep: Reputation: 0
Hi,

I have a similar problem.

I've created an LFS system and can mount my NTFS partition (hda1)
using root but unprivledged users cannot read it. The kernel is
configured for read-only NTFS access and I do not have any other
drivers or user-space tools for NTFS.

Will adding the entry to fstab as suggested by jay73 allow everyone
to read the NTFS partition or only the user with UID=500 (1000 in
my case)? Do I need a special driver for global read-only access?
 
Old 10-14-2007, 06:10 AM   #8
w_barnes
LQ Newbie
 
Registered: Sep 2007
Posts: 5

Rep: Reputation: 0
I figured it out.

This line added to fstab will add global, read-only access to an NTFS partition using only the kernel's ntfs driver.

Code:
/dev/hda1 /media/C ntfs ro,noauto,users,nls=utf8,dmask=0222,fmask=0333 0 0
I use the noauto and users options coz I prefer to manually mount this partition (and allow anyone to do so); both can be dropped if automount at boot time is preferred.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Drives mounted with ntfs-3g don't apear on the desktop and in File Browser tvcool Fedora 1 03-10-2007 06:21 AM
How to read .chm file in fedora, can't mount ntfs file system ishti_du Linux - Newbie 12 03-06-2007 03:27 AM
Accessing NTFS drives through Slackware punksoul257 Slackware 21 05-16-2006 02:30 AM
accessing file system of MMC jogurt666 Linux - Hardware 0 05-11-2005 03:07 PM
Accessing my ntfs drives Cheese Linux - Software 2 12-02-2001 02:28 PM


All times are GMT -5. The time now is 12:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration