LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-11-2005, 11:01 AM   #1
Killer_VCS
LQ Newbie
 
Registered: Jan 2005
Location: Campbellford, Ontario
Distribution: Debian 3.2
Posts: 2

Rep: Reputation: 0
accessing cdrom drives


I'm borrowing a friend's KDE Debian 3.2 system for a bit till I get my computer back up. It's a an AMD 1800+ with 256mb of ram, a 20 gig hard drive, 52x cdrom, and a cd-rw drive..

Now, my problem is, I can't access the cd-rom drives. I know the commands and whatnot, but I get an error message saying there might be too many things mounted or something, I'll post a screen shot of it later. I just want to listen to music cd's while I'm using the computer. I've tried help files and google, but couldn't find anything. Any help is appreciated.

Last edited by Killer_VCS; 01-11-2005 at 11:06 AM.
 
Old 01-11-2005, 12:05 PM   #2
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
what IS the error msg, exactly?
did you mount it somehow like this "mount -t iso9660 /dev/cdrom /mnt/cdrom"? or how if not
 
Old 01-11-2005, 12:23 PM   #3
Genesee
Member
 
Registered: Dec 2002
Distribution: Slackware
Posts: 927

Rep: Reputation: 30
you don't need to mount audio CDs - just put in drive and run a cd player app, like kscd.
 
Old 01-11-2005, 11:53 PM   #4
Killer_VCS
LQ Newbie
 
Registered: Jan 2005
Location: Campbellford, Ontario
Distribution: Debian 3.2
Posts: 2

Original Poster
Rep: Reputation: 0
THis is the error message I get:

Could not mount device.
The reported error was:
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems

When I pop an audio cd in, it doesn't autoplay or anything, and when I try to access teh optical drives, I get the same message.
 
Old 01-12-2005, 12:19 AM   #5
nadroj
Senior Member
 
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
try that command as root, as i mentioned before, something like "mount -t iso9660 /dev/cdrom /mnt/cdrom". you might want to change "/mnt/cdrom" to "/media/cdrom", should work either though.

edit: if that still gives the same error... we can narrow it down. how many filesystems DO you have mounted? check /etc/fstab

Last edited by nadroj; 01-12-2005 at 12:23 AM.
 
Old 01-12-2005, 03:26 AM   #6
reddazz
LQ Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 74
You can't mount audio CD's coz they don't have a valid filesystem. To play audio CD's just put them in the cdrom drive, make sure you have read permissions to it and make sure your cd player program is pointing to that drive.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
accessing drives afrm Linux - Software 3 02-08-2005 11:07 PM
Give user permission to mount/use cdrom drives or usb drives zwyrbla Linux - Newbie 2 08-23-2004 05:30 PM
Accessing CD Drives/Floppy Drives rsearing Linux - Newbie 9 08-13-2004 09:53 PM
Accessing my ntfs drives Cheese Linux - Software 2 12-02-2001 03:28 PM
Accessing windows drives playmesumch00ns Linux - Newbie 5 06-14-2001 03:38 PM


All times are GMT -5. The time now is 03:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration