LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-02-2003, 08:30 AM   #1
sore
LQ Newbie
 
Registered: Dec 2002
Location: Sweden
Distribution: suse 8.2
Posts: 22

Rep: Reputation: 15
Access rights


I have sett up an apacheserver and use ftpd to upload files to it. For this I made a special user with access rights to the apache webfolder.

My problem is now that the files gets no execute or read rights for user, users or group.

The access rights look like this rw-r----- instead of rwxr-xr-x.

Can someone lead me in the right direction here please.
 
Old 01-02-2003, 09:16 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Your looking for umask.

man umask for more details.
 
Old 01-02-2003, 10:10 AM   #3
sore
LQ Newbie
 
Registered: Dec 2002
Location: Sweden
Distribution: suse 8.2
Posts: 22

Original Poster
Rep: Reputation: 15
If I do umask 000 loged in as the user who should be changed, do I then set the default access permissions for all future files created by that user to 777?
 
Old 01-02-2003, 10:21 AM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Well if you want it to be rwxr-xr-x you might want to consider 022. With a 000 you would give everyone full access but unless that is what you want ??
 
Old 01-02-2003, 10:46 AM   #5
sore
LQ Newbie
 
Registered: Dec 2002
Location: Sweden
Distribution: suse 8.2
Posts: 22

Original Poster
Rep: Reputation: 15
but when I just do umask I get the answer 022. So I already have this set I guess. This is the default state or not?

But I then dont understand why the files I upload gets another state (711 I think). Does it have anything to do with that I upload from XP or is it maby a setting in ftpd?

Last edited by sore; 01-02-2003 at 10:50 AM.
 
Old 01-02-2003, 11:18 AM   #6
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Could be a possible setting with FTP then.. check your config files. Wouldn't or don't think it would be caused by XP.
 
Old 01-02-2003, 11:31 AM   #7
sore
LQ Newbie
 
Registered: Dec 2002
Location: Sweden
Distribution: suse 8.2
Posts: 22

Original Poster
Rep: Reputation: 15
ok thank you for the help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Access rights? BC Linux - Newbie 6 11-18-2015 11:27 AM
Access rights Noido Linux - Newbie 5 06-13-2005 05:36 PM
no access to devices with group access rights flipper333 Debian 2 12-28-2004 10:25 AM
Samba Access Rights esasse Linux - Newbie 6 12-22-2004 07:45 AM
access rights popcorn5714 Linux - Newbie 3 02-02-2002 02:26 AM


All times are GMT -5. The time now is 12:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration