LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-17-2006, 04:34 PM   #1
reakinator
Member
 
Registered: Oct 2005
Location: California
Distribution: Ubuntu Feisty
Posts: 52

Rep: Reputation: 15
access privileges to mounted fat32?


Hello,

I have a fat32 partition mounted in /etc/fstab as:

/dev/sda6 /mnt/fat auto defaults,umask =000 0 0

I don't really know what these commands do (any good sources?), but they don't do what I need them to. I would like read/write/execute privileges to this entire partition, for all accounts on this computer. Does anyone know a good way to do this?

Also, how can I reload /etc/fstab after making changes, without resarting the computer?

Thanks for helping the noobs get over their noobness.

Richie
 
Old 06-17-2006, 04:48 PM   #2
b0uncer
LQ Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
Quote:
/dev/sda6 /mnt/fat auto defaults,umask =000 0 0
the first column, "/dev/sda6", is the device you're dealing with; the second, "/mnt/fat" is the place where the device gets mounted, third column ("auto") is the filesystem (which is now automatically detected if possible; you could use "vfat" in this case too); the next column are the mounting options which in this case are:

defaults = the "default" settings, read man fstab for more information about this
umask = tells the usermask that is used; use "umask=0222" if you like everyone to be able to have permissions on the device (instead of the "umask=000" that's there at the moment)

about the last two zeroes you can read from man fstab, but in this case you don't need to know more specificly (reading by yourself is a good practise), just know that you'll put zero in both columns. so, to get normal users an access, the line would look like:

/dev/sda6 /mnt/fat auto defaults,umask=0222 0 0

or if you like to add more options, like this:

/dev/sda6 /mnt/fat auto users,auto,rw,umask=0222 0 0

(users=let normal users umount the drive; auto=mount it automatically at bootup; rw=read-write access)

to "reload" /etc/fstab you can run

Code:
mount -a
which mounts all the devices specified in /etc/fstab
 
Old 06-17-2006, 11:27 PM   #3
reakinator
Member
 
Registered: Oct 2005
Location: California
Distribution: Ubuntu Feisty
Posts: 52

Original Poster
Rep: Reputation: 15
Thanks for the detailed explanation, but I still can't write to /dev/sda6 after I use either of the entries you have supplied and run 'mount -a'. I also tried restarting, just in case, but no luck. Is there anything else I can do?
 
Old 06-18-2006, 02:05 AM   #4
gilead
Senior Member
 
Registered: Dec 2005
Location: Brisbane, Australia
Distribution: Slackware64 14.0
Posts: 4,125

Rep: Reputation: 164Reputation: 164
It looks like you have a space between umask and =0000 - if that's the case, can you remove the space and try it again?
 
Old 06-18-2006, 02:35 AM   #5
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
you may want to use the uid= option too, e.g.
/dev/sda6 /mnt/fat auto users,auto,rw,uid=(Your UID),umask=0222 0 0
this will make you the "owner" of all the files and dirs and let you write to it.
 
Old 06-18-2006, 03:50 PM   #6
reakinator
Member
 
Registered: Oct 2005
Location: California
Distribution: Ubuntu Feisty
Posts: 52

Original Poster
Rep: Reputation: 15
If there is anything I need to figure out first, it is how to write files without running everything from root. But, this is turning out to be very hard when using vfat (I need to use the files in winxp also). I corrected the space in 'umask =0222', but this did not help. One of my accounts on this computer is uid=500, so I tried adding that. No help (at this point, I also figured out that 'mount -a' did not update the /etc/fstab settings, but that I had to restart). Lastly, took off the 'umask=0222' and was left with:

/dev/sda6 /mnt/fat auto users,auto,rw,uid=500,gid=500 0 0

This line allows uid=500 write permissions, but only on new files. So I have to do 'chmod a+w *' for all directories that I want to use on this account. Not really ideal, since the rest of the accounts are left out still, and this is alot of typing.

Does anyone have any suggestive readings where I can get to the bottom of this, once and for all? All I really want to be able to do is:
A) Mount a filesystem that can be shared by both linux and windows
B) allow all my accounts read/write/execute access to it.

But it hasn't been simple so far.

Anyways, thanks everyone for helping.
Richie
 
Old 06-18-2006, 05:16 PM   #7
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 48
try this.........
Code:
  
/dev/sda6 /mnt/fat auto owner,users,rw   0 0
 
Old 06-18-2006, 10:47 PM   #8
soulestream
Member
 
Registered: Nov 2005
Posts: 183

Rep: Reputation: 30
http://www.linuxforum.com/linux_tutorials/14/1.php


Soule
 
Old 06-18-2006, 11:16 PM   #9
sidesec
LQ Newbie
 
Registered: May 2005
Distribution: suse 9.1 Pro
Posts: 29

Rep: Reputation: 15
This may help - good luck !

http://my.opera.com/lounge/forums/topic.dml?id=83440
 
Old 06-19-2006, 08:30 AM   #10
binary_y2k2
Member
 
Registered: Jul 2005
Location: England, UK
Distribution: Ubuntu 8.04 Server, Kubuntu 12.04
Posts: 698
Blog Entries: 1

Rep: Reputation: 31
Quote:
Originally Posted by reakinator
<CHOP>
A) Mount a filesystem that can be shared by both linux and windows
<CHOP>
If you want windows to read/write and want large file support (4GB+) take a look at:
http://www.fs-driver.org/
and see this thread:
http://www.linuxquestions.org/questi...d.php?t=454999
 
Old 06-19-2006, 05:58 PM   #11
reakinator
Member
 
Registered: Oct 2005
Location: California
Distribution: Ubuntu Feisty
Posts: 52

Original Poster
Rep: Reputation: 15
Well, I tried just about every option on this post and the linked posts, and none gave me write access. I know this means I'm doing something wrong, but I need to move on. So, the only option that worked for me was:
Code:
/dev/sda6		/mnt/fat		auto	defaults,dmask=000,fmask=000	0 0
which gives rwx access to all users. Not the most secure, I know. But, it works for now.

By the way, I tried dmask=007 and fmask=007 and My regular user account couldn't get access..does anyone know why?

Anywho, thanks for the links, and thanks to all for trying. The three-day-quest to write to my fat drive is over.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Issues with mounted FAT32 jocast Linux - Software 3 07-22-2005 04:05 PM
FAT32 partition ro...but not mounted ro SaurianOverlord Linux - Newbie 15 04-12-2005 11:32 PM
Default File Access Privileges..! br_sriram Linux - Software 0 09-29-2004 12:10 AM
Not enough privileges to access certain folders joeman3429 Fedora 1 07-20-2004 07:46 AM
2 fat32 partitions on fbsd5/w2k dual. Can only access one fat32 so far.. mipia *BSD 1 10-06-2003 03:10 AM


All times are GMT -5. The time now is 05:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration