LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-25-2003, 01:01 AM   #1
af09
LQ Newbie
 
Registered: Nov 2003
Location: Carbondale, IL
Distribution: Gentoo
Posts: 2

Rep: Reputation: 0
Access NTFS mount @ nonroot?


I added NTFS support on my dualboot system (XP and Fedora) and mounted the NTFS to /mnt/cdrive. However I cannot chown or chmod the directory. Ultimately I want to be able to set things up to mount and change all access to read upon boot, but I cannot figure out how to allow my nonroot users access?

Note: the actual error message is "failed to change mode of 'cdrive' to 0444"

Thank!
 
Old 11-25-2003, 08:32 AM   #2
bencl5
Member
 
Registered: Nov 2003
Distribution: I use gentoo, redhat, and lorma for kicks.
Posts: 44

Rep: Reputation: 15
Viewing and Modifying the contents of another partition could be looked at as a pretty risky process if you have mission critical or confidential data. I mean potentially if you created a user account that could log on under fedora and read and write to your NTFS volume, your NTFS volume could be compromised. that is why i believe that the NTFS modules are currently only available with read support and write support is still experimental (until kernel 2.6 officially comes out) for just root.

I'd imagine there is a way to change the permissions of a user in the file /etc/shadow, but really administrative stuff should really be done as root. i mean sure it's a couple extra steps, to change the permissions on files, but really, it's not THAT bad is it? i mean other than document files what good is a windows partition anyway? you can do everything in linux you can do in windows. and more. however, if your a windows gamer you have to install wineX to play your games and that can cost you money (morally at least that is).

Last edited by bencl5; 11-25-2003 at 08:34 AM.
 
Old 11-25-2003, 10:24 AM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,969

Rep: Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752Reputation: 752
You need to modify the /etc/fstab file for the NTFS partition.
Add user option for a regular user to mount and umask=0222 for users to read only.
 
Old 11-25-2003, 02:28 PM   #4
af09
LQ Newbie
 
Registered: Nov 2003
Location: Carbondale, IL
Distribution: Gentoo
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks

Thanks for the info.

The reason I want to do this is because I have alot of audio and images on my NTFS partition that I don't really want to have redundancy on my relatively small 30GB laptop harddrive.

Thanks!
 
Old 11-25-2003, 06:52 PM   #5
aaa
Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
You can also just put 'ro' as an option to make it read-only (you'll probably still need umask= to let regular users look at it). Set ownership via the uid=[user] & gid=[group] options.
 
Old 11-25-2003, 08:11 PM   #6
YoshiSatal
LQ Newbie
 
Registered: Nov 2003
Location: Texas Baby
Distribution: Redhat 9.0
Posts: 1

Rep: Reputation: 0
I was in the exact same situation just a few days ago. I ended up adding my NTFS to /etc/fstab

You should add a line that looks something like this:
/dev/hda1 /windows ntfs ro,user,uid=500 0 0

Where /dev/hda1 is your hard drive (hda for primary master, hdb for primary slave etc) and /windows is /mnt/cdrive

I really wish Linux had stable NTFS write :sigh:
 
Old 01-14-2004, 03:27 PM   #7
jrperiod
LQ Newbie
 
Registered: Jan 2004
Location: J-ville FL
Distribution: Gentoo
Posts: 15

Rep: Reputation: 0
I know this thread is a couple months old but I added the unmask=0222 to my /etc/fstab file and it gave my user acct access to my NTFS partition witha ll of my music on it but no files or folders show up.

If I go to the same partition as root, i am able to navigate it and play my music files. what should I add to the line to be able to view the files in the partition. I cant remember exactly what it says now (im at work) but it does have "ro" and the "unmask=0222" in the line.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 07:29 PM
how to give a nonroot user write access Kilahchris Linux - Newbie 8 05-11-2005 02:10 AM
Dropline GNOME nonroot audio cry0x Slackware 6 02-27-2005 03:34 AM
can't access ntfs mount through nfs mount bezoomny Linux - Networking 9 04-14-2004 10:25 AM
Captive NTFS -- full r/w ntfs access for Linux spurious Linux - Software 6 01-09-2004 12:29 AM


All times are GMT -5. The time now is 01:06 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration