LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-28-2006, 02:44 PM   #1
digimortal001
LQ Newbie
 
Registered: Oct 2005
Posts: 5

Rep: Reputation: 0
access fat32 from suse 10


Hi everyone, already few weeks ago I installed suse 10 on my desktop PC, it works fine, but, the main purpose was to be able to access fat32 partitions becouse I left there a lots of data since i had windows.Now, after looking for some answere i still can't gain access to my fat32 partitions. I tried to do $mount /dev/sda6 in command line, but it says "Permission denied", from konqueror it says : "mount: can't find /dev/sda6 in /etc/fstab or /etc/mtab
Please check that the disk is entered correctly."

I gues I need to edit manually fstab, but I don't know what to write there...

Please help

sorry my bad english

suse 10
2.6.13-15-smp

fstab:

/dev/sda3 / reiserfs acl,user_xattr 1 1
/dev/sda1 swap swap defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/dvdrecorder /media/dvdrecorder subfs noauto,fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0 /media/floppy subfs noauto,fs=floppyfss,procuid,nodev,nosuid,sync 0 0
none /subdomain subdomainfs noauto 0 0
 
Old 03-28-2006, 04:39 PM   #2
dcdbutler
Member
 
Registered: Jan 2005
Location: Boston
Distribution: slackware
Posts: 502

Rep: Reputation: 30
The internet is awash with information about how to mount windows drives from within linux, eg

http://www.linuxquestions.org/questi...d.php?t=123651

you can add this line to /etc/fstab

Code:
/dev/sda6         /mnt/sda6         vfat         noauto,user   0   0
to get started.

Remember to do

# mkdir /mnt/sda6

if a mounting directory for your partition does not yet exist
 
Old 03-29-2006, 01:30 AM   #3
khaleel5000
Member
 
Registered: Oct 2005
Location: Pakistan
Distribution: Debian,Pclinuxos
Posts: 327

Rep: Reputation: 31
here read these , the distros might b different the concept of FSTAB
remains same


http://linux.org.mt/article/winmount
http://www.redhat.com/docs/manuals/l...a-windows.html
http://www.linuxjunior.org/cgi-bin/p...=Display&id=48
 
Old 03-29-2006, 07:17 AM   #4
digimortal001
LQ Newbie
 
Registered: Oct 2005
Posts: 5

Original Poster
Rep: Reputation: 0
thanks a lot,IŽll try it this evening, whan be back home, thanks again!!!
 
Old 03-29-2006, 08:23 AM   #5
ethics
Senior Member
 
Registered: Apr 2005
Location: London
Distribution: Arch - Latest
Posts: 1,522

Rep: Reputation: 45
something to note is that FAT32 cannot understand Unix permissions and so whe nmounting, you need to give the files a 'mask' which is basically telling it to assume certain permissions by default. This is necesary when writing and reading as users etc.

to achieve this you will need to add umask=000 to the fstab options for that mount. Again this has been covered MANY times in this forum
 
Old 03-30-2006, 12:37 AM   #6
khaleel5000
Member
 
Registered: Oct 2005
Location: Pakistan
Distribution: Debian,Pclinuxos
Posts: 327

Rep: Reputation: 31
ya ..... but u no ppl dont actually GOOGLE or search the form first (ME included)
 
Old 03-30-2006, 02:32 PM   #7
digimortal001
LQ Newbie
 
Registered: Oct 2005
Posts: 5

Original Poster
Rep: Reputation: 0
ok, that what dcdbutler wrote worked, thanks, but........as all data was in russian, now averything, folders, files, are in ???????? signs, and to rename all this it's a heel....is there some solution to see it in russian? I have kde in ukrainian( I'm ukrainian) it's aulmost like russian, konqueror in ukrainian, so why folders aren't in ukrainina to?
any ideas?
thanks
 
Old 03-30-2006, 02:38 PM   #8
demented_are_go
Member
 
Registered: Mar 2006
Distribution: Fedora Solaris Slackware
Posts: 50

Rep: Reputation: 15
nevermind, didn't read all the way down. This just might help : http://www.usinglinux.org/russian/

Last edited by demented_are_go; 03-30-2006 at 02:40 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to Access FAT32 Partitions phool4fool Linux - Newbie 7 12-03-2005 01:27 PM
cant access fat32 from user kelthuzad Linux - Hardware 3 04-28-2005 07:01 AM
cannot access FAT32 partition pafrica Linux - Newbie 3 09-04-2004 04:43 PM
Getting write access to FAT32 wgself Red Hat 1 01-16-2004 09:48 AM
2 fat32 partitions on fbsd5/w2k dual. Can only access one fat32 so far.. mipia *BSD 1 10-06-2003 03:10 AM


All times are GMT -5. The time now is 09:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration