LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-06-2008, 09:21 PM   #1
vwb5003
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Rep: Reputation: 0
"Access Denied" slave Hard Drive in Mandriva 2008 Spring DVD


This is my first post as a new member and I am a "Newbee" to Linux. Hello to all. I have installed the DVD version of Mandriva 2008 spring in a P3 running 2 160GB HDs. The hard drives came out of a Windows XP machine that died recently. The installation of Mandriva went well without problems, but, the slave drive will not allow me to write within it, drag and drop, ect. Essentially it is dead space. I have downloaded and installed NTFS-3g as I read that it was necessary for Mandrive to be able to allow read and write permissions of NTFS drives. Also please know that I am a total idiot to the command line and shells so any help that is forthcoming must be step by step and written for my total lack of experience.

Thankyou much,
vwb5003
 
Old 07-07-2008, 12:23 AM   #2
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
Hi, and welcome to LQ!

There will be a (plain text) file called fstab, /etc/fstab that holds the config for permanent drives. And also system boot commands too, so be careful, and don't change anything you don't need to, also the order of these lines is really important.

The line for my ntfs partition is as follows...

# Entry for /dev/sda1 :
UUID=4C54BBD554BBBFCE /mnt/win_c ntfs-3g defaults 0 0

You need root permissions to save changes to this file.

You can do this by (there are a few ways, but this way is easier to do no matter what menu contents you have)

open a terminal (konsole). type su and hit enter. type in the root (admin) password you used during the later stages of the install.

type in konqueror. This will open a kde browser.

Go to "settings" "Load view profile" and select file management. This normally opens the /root home directory.

use the arrows near the top left of the screen to navigate up to /

Now go to /etc and open fstab in a text editor like kate or kwrite. (right click, open with)

Now you will be able to see the lines for each partition.

if you have sata drives the partition may be labeled some thing like the above but may also look like this...

/dev/sda1 /mnt/win_c ntfs-3g defaults 0 0 This is my first partition for the winxp system.

A break down the name "sda1"
sd for sata and scuzzy drives
the next letter is a drive letter, a for the first, b for the second, c for the third.... I think you get it.

the numeral is for the partition on that drive.

So if yours is the first partition of the second drive it may be "sdb1" or "hdb1"

The next part of the line is the mount point "/mnt/win_c" as in /mnt/("name of drive partition")

The next part is the file system, "ntfs-3g" and the last parts are the "access" and "inode". all separated by a single space and usually in colour.

So if the line is there already then you may be able to just change the last part for "access"

Be care full here, because after a reboot you may not be able to access it at all.

Next save the file overwriting the old one (it will be saved as fstab~ (backup))

close konqueror, and type "exit" in the root konsole to end that session, close all other windows, and reboot to see the changes. (easy way)

For more info search for fstab with your favourite search engine of from a terminal type "man fstab" (without the quote marks)

Hope this helps, I will get an email alert if you have any more question, so just ask, there heaps of experienced people here that may also contribute.

Cheers, Glenn

Last edited by GlennsPref; 07-07-2008 at 12:37 AM. Reason: spelling and gramma and WARNINGS.
 
Old 07-07-2008, 12:37 AM   #3
dudeman41465
Member
 
Registered: Jun 2005
Location: Kentucky
Distribution: Ubuntu
Posts: 794

Rep: Reputation: 56
If you're using it as a Mandriva machine now, just re-format it as ext3 which all Linux distributions should read and write to natively.
 
Old 07-07-2008, 02:56 AM   #4
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
Smile How?

Quote:
Originally Posted by dudeman41465 View Post
If you're using it as a Mandriva machine now, just re-format it as ext3 which all Linux distributions should read and write to natively.
You forgot to explain how a novice would do that. :-p
 
Old 07-07-2008, 10:47 AM   #5
vwb5003
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Original Poster
Rep: Reputation: 0
GlennPref and Dudeman41465, Thankyou both for your kind assistance I have pasted your instructions into a word odt. and saved for when I get home from work.

vwb5003
 
Old 07-13-2008, 04:59 PM   #6
vwb5003
LQ Newbie
 
Registered: Jul 2008
Posts: 3

Original Poster
Rep: Reputation: 0
GlennsPref, vwb5003 here again. Don't know if you remember our correspondence over 6 and 7 July about "Access Denied" to my slave drive in mandriva 2008 but this is where I am currently at. I have followed your instructions to this point. The listing for my second drive in Konqueror under file permissions is:

UUID=a68495e7-2834-4c66-9947-c37a6fe324a7 /home/second160 ext3 defaults 1 2

I am assuming that the defaults of 1 2 are wrong and should be 0 0 for this drive to allow me to write to it. If I am right how do I change these defaults and keep them as I have already pasted line into the already open konsole and entered 0 0 as the defaults, exited the konsole, and, rebooted the machine. I then went back to the konsole and opened konqueror and the line was back to what you see above.
I do apologize for this disturbance and I do thank-you heartily for you time and patients.

Sincerely,
vwb5003
 
Old 07-13-2008, 07:57 PM   #7
GlennsPref
Senior Member
 
Registered: Apr 2004
Location: Brisbane, Australia
Distribution: pclinuxos slackware64 tails kali
Posts: 3,372
Blog Entries: 33

Rep: Reputation: 217Reputation: 217Reputation: 217
Hi, the instructions I gave above, open /etc/fstab as root.

to do this, open a konsole, type su (and press enter) and enter the root password.

Type in konqueror (and press enter)

find the file, and edit it as instructed above.

If the file system is ext3 as you mention, then

UUID=a68495e7-2834-4c66-9947-c37a6fe324a7 /home/second160 ext3 defaults 1 2

should work. But if you have not reformatted the old ntfs file system you may need to mount it someplace else9 like /mnt/second160. The numbers following the line are for indexing and access time recording (changing the "last accessed time") This will be different if it directory is a system or not.

These questions need to be answered before we can continue,

1) do you require any old files from the ntfs partition(file system)?

2) have you reformatted the partition as ext3?
 
Old 09-22-2008, 09:02 AM   #8
DarkoX
LQ Newbie
 
Registered: Mar 2001
Location: Rijeka,Croatia
Posts: 8

Rep: Reputation: 0
It seems that mandriva & other distribution won't mount ntfs disk if windows didn't have clean shutdown,or partitions contain some errors.
You can go to windows and perform chkdsk /f from windows console or try this under Mandriva :
Go to console login as root and try for example
mount /dev/sda1 -o force
Dirty bit is now cleared & disk is mounted.
Go again to Storage Media & try to open disk.
It should work.
You will have a new problem after reboot,Mandriva will complain that mount point directory doesn't exist.This is some bug .Folder /media doesn't have now enough permissions.

From console as root type chmod 777 /media
This will fix that problem.

For people that deleted device entrys from /etc/fstab :

Switch the computer off,disconnect all ntfs hard disks then Turn On,wait until system is up,then again switch off computer,connect disks and again turn the computer on.Mandriva will recreate /etc/fstab properly.
Fix the permissions for /media folder after all this.
You have to change permissions /media folder as i described above.
 
Old 09-22-2008, 01:18 PM   #9
DarkoX
LQ Newbie
 
Registered: Mar 2001
Location: Rijeka,Croatia
Posts: 8

Rep: Reputation: 0
Access Denied

Problem with missing mount point directory was caused by me.I changed some permissions using system tools(Configure your computer->Tune permission on system).So under normal circumstances message "Folder /media/hd doesn't exist" will not appear.
It is enough to type in console as root
mount /dev/sda1 -o force
to fix "Access denied" problem
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install mandriva 2008 spring DVD armywil Mandriva 12 06-13-2008 08:29 AM
LXer: The Perfect Server - Mandriva 2008 Spring Free (Mandriva 2008.1) LXer Syndicated Linux News 0 04-10-2008 04:10 PM
Mandriva 2008 boot stalls on "setting hostname localhost:" on HPdv9700t cmack43 Linux - Laptop and Netbook 0 02-24-2008 07:00 PM
External Hard Drive "locked" in Mandriva 2006 VapourTrail Linux - Software 1 03-04-2006 12:53 AM
mandriva 10.1 install stops at "hard drive detection" Devoid_Janitor Mandriva 0 08-08-2005 11:30 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 08:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration