LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-27-2003, 04:59 PM   #1
kosmognov
LQ Newbie
 
Registered: May 2003
Distribution: suse 9.0, Slack 9.1, Mandrake 10, etc...
Posts: 23

Rep: Reputation: 15
AC 97 Onboard Sound card and Slackware


Does anyone knows how to get the onboard AC 97 sound card to work? I have a AsRock k7vt2 motherboard and a slackware 9.0 instalation. thankx
 
Old 05-27-2003, 06:06 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Please post the output of

lspci -v

Cheers,
Tink
 
Old 05-27-2003, 06:30 PM   #3
kosmognov
LQ Newbie
 
Registered: May 2003
Distribution: suse 9.0, Slack 9.1, Mandrake 10, etc...
Posts: 23

Original Poster
Rep: Reputation: 15
root@Mustaf:~# lspci -v
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
Subsystem: Unknown device 1849:3099
Flags: bus master, 66Mhz, medium devsel, latency 0
Memory at e0000000 (32-bit, prefetchable) [size=32M]
Capabilities: [a0] AGP version 2.0
Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP] (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Memory behind bridge: dde00000-dfefffff
Prefetchable memory behind bridge: d9d00000-ddcfffff
Capabilities: [80] Power Management version 2

00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. USB
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at e400 [size=32]
Capabilities: [80] Power Management version 2

00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. USB
Flags: bus master, medium devsel, latency 64, IRQ 3
I/O ports at e800 [size=32]
Capabilities: [80] Power Management version 2

00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. USB
Flags: bus master, medium devsel, latency 64, IRQ 5
I/O ports at ec00 [size=32]
Capabilities: [80] Power Management version 2

00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82) (prog-if 20 [EHCI])
Subsystem: VIA Technologies, Inc. USB 2.0
Flags: bus master, medium devsel, latency 64, IRQ 10
Memory at dfffff00 (32-bit, non-prefetchable) [size=256]
Capabilities: [80] Power Management version 2

00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
Subsystem: Unknown device 1849:3177
Flags: bus master, stepping, medium devsel, latency 0
Capabilities: [c0] Power Management version 2

00:11.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 06) (prog-if 8a [Master SecP PriP])
Subsystem: Unknown device 1849:0571
Flags: bus master, medium devsel, latency 32, IRQ 14
I/O ports at fc00 [size=16]
Capabilities: [c0] Power Management version 2

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio Controller (rev 50)
Subsystem: VIA Technologies, Inc.: Unknown device 4161
Flags: medium devsel, IRQ 5
I/O ports at e000 [size=256]
Capabilities: [c0] Power Management version 2

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
Subsystem: Unknown device 1849:3065
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at dc00 [size=256]
Memory at dffffe00 (32-bit, non-prefetchable) [size=256]
Capabilities: [40] Power Management version 2

01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15) (prog-if 00 [VGA])
Subsystem: Palit Microsystems Inc.: Unknown device 002d
Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
Memory at de000000 (32-bit, non-prefetchable) [size=16M]
Memory at da000000 (32-bit, prefetchable) [size=32M]
Expansion ROM at dfef0000 [disabled] [size=64K]
Capabilities: [60] Power Management version 1
Capabilities: [44] AGP version 2.0

root@Mustaf:~#
 
Old 05-27-2003, 06:51 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Try a

modprobe via82cxxx_audio

Cheers,
Tink
 
Old 05-28-2003, 08:00 AM   #5
kosmognov
LQ Newbie
 
Registered: May 2003
Distribution: suse 9.0, Slack 9.1, Mandrake 10, etc...
Posts: 23

Original Poster
Rep: Reputation: 15
root@Mustaf:~# modprobe via82cxxx_audio
/lib/modules/2.4.20/kernel/drivers/sound/via82cxxx _audio.o.gz: init_module: No such device
/lib/modules/2.4.20/kernel/drivers/sound/via82cxxx _audio.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or t he output from dmesg
/lib/modules/2.4.20/kernel/drivers/sound/via82cxxx _audio.o.gz: insmod /lib/modules/2.4.20/kernel/dri vers/sound/via82cxxx_audio.o.gz failed
/lib/modules/2.4.20/kernel/drivers/sound/via82cxxx _audio.o.gz: insmod via82cxxx_audio failed
root@Mustaf:~#
 
Old 05-28-2003, 08:49 AM   #6
max2003
LQ Newbie
 
Registered: May 2003
Distribution: Slackware 9.1
Posts: 26

Rep: Reputation: 15
Try with ALSA.
 
Old 05-28-2003, 08:57 AM   #7
kosmognov
LQ Newbie
 
Registered: May 2003
Distribution: suse 9.0, Slack 9.1, Mandrake 10, etc...
Posts: 23

Original Poster
Rep: Reputation: 15
er... yes i've heard about it... but as you can see (below my nickname) you have Newbie... I think I should have Super duper newbie...
so therefore I don't know how to ...
please post every single detail...

thanks...
 
Old 05-28-2003, 10:16 PM   #8
luucorp
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
hi, guys
i have this brolem , too?
plz help.
thansk in adv
 
Old 05-29-2003, 02:10 AM   #9
kosmognov
LQ Newbie
 
Registered: May 2003
Distribution: suse 9.0, Slack 9.1, Mandrake 10, etc...
Posts: 23

Original Poster
Rep: Reputation: 15
Don't!!

Listen ... it hs been a While since I tryed to solve this problem, and now I hve to install everything again because I was trying too much stuff and ome off them went wrong.

I think That the only solution is to add the correct option to the Xconfig and to recompile the kernel... but if you want my advice... do wht i'm gonna do buy a cheap and compatible sound card or install something like mandrake.
 
Old 05-29-2003, 11:40 PM   #10
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
That's a quite silly thing to say mate, I have that
chipset on two motherboards, and it works just dandy.

Cheers,
Tink
 
Old 05-29-2003, 11:44 PM   #11
luucorp
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
you can post link to downl packet_driver for it

thank in adv
 
Old 05-30-2003, 02:55 AM   #12
kosmognov
LQ Newbie
 
Registered: May 2003
Distribution: suse 9.0, Slack 9.1, Mandrake 10, etc...
Posts: 23

Original Poster
Rep: Reputation: 15
yep that would help...

Insert a quote into your message
 
Old 05-30-2003, 05:27 AM   #13
luucorp
LQ Newbie
 
Registered: May 2003
Posts: 11

Rep: Reputation: 0
mean?
 
Old 06-02-2003, 04:14 PM   #14
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
I don't think he was being mean ...

Cheers,
Tink
 
Old 06-02-2003, 05:27 PM   #15
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Rep: Reputation: 30
try insmod ac97 and insmod ac97_codec, and tell us the results
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
keep onboard sound card enabled when a second sound card has been added ViralHex Linux - Hardware 0 06-08-2004 01:06 PM
Diabling onboard sound card and enabling pci slot sound card abhatia Linux - Hardware 4 01-12-2004 02:10 AM
midi / synth sound with SIS7012 aka Intel i8x0 onboard sound card does not work wahwah Linux - Hardware 1 11-10-2003 05:25 PM
A7N8X + Mandrake 9.1 + onboard sound card = No SOUND st_purple Linux - Hardware 3 11-07-2003 08:30 AM
Sound blaster Live config with onboard sound card HChan Linux - Hardware 1 04-30-2003 01:47 AM


All times are GMT -5. The time now is 08:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration