LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   AC 97 Onboard Sound card and Slackware (http://www.linuxquestions.org/questions/linux-newbie-8/ac-97-onboard-sound-card-and-slackware-62155/)

kosmognov 05-27-2003 04:59 PM

AC 97 Onboard Sound card and Slackware
 
Does anyone knows how to get the onboard AC 97 sound card to work? I have a AsRock k7vt2 motherboard and a slackware 9.0 instalation. thankx

Tinkster 05-27-2003 06:06 PM

Please post the output of

lspci -v

Cheers,
Tink

kosmognov 05-27-2003 06:30 PM

root@Mustaf:~# lspci -v
00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
Subsystem: Unknown device 1849:3099
Flags: bus master, 66Mhz, medium devsel, latency 0
Memory at e0000000 (32-bit, prefetchable) [size=32M]
Capabilities: [a0] AGP version 2.0
Capabilities: [c0] Power Management version 2

00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP] (prog-if 00 [Normal decode])
Flags: bus master, 66Mhz, medium devsel, latency 0
Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
Memory behind bridge: dde00000-dfefffff
Prefetchable memory behind bridge: d9d00000-ddcfffff
Capabilities: [80] Power Management version 2

00:10.0 USB Controller: VIA Technologies, Inc. USB (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. USB
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at e400 [size=32]
Capabilities: [80] Power Management version 2

00:10.1 USB Controller: VIA Technologies, Inc. USB (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. USB
Flags: bus master, medium devsel, latency 64, IRQ 3
I/O ports at e800 [size=32]
Capabilities: [80] Power Management version 2

00:10.2 USB Controller: VIA Technologies, Inc. USB (rev 80) (prog-if 00 [UHCI])
Subsystem: VIA Technologies, Inc. USB
Flags: bus master, medium devsel, latency 64, IRQ 5
I/O ports at ec00 [size=32]
Capabilities: [80] Power Management version 2

00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82) (prog-if 20 [EHCI])
Subsystem: VIA Technologies, Inc. USB 2.0
Flags: bus master, medium devsel, latency 64, IRQ 10
Memory at dfffff00 (32-bit, non-prefetchable) [size=256]
Capabilities: [80] Power Management version 2

00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
Subsystem: Unknown device 1849:3177
Flags: bus master, stepping, medium devsel, latency 0
Capabilities: [c0] Power Management version 2

00:11.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 06) (prog-if 8a [Master SecP PriP])
Subsystem: Unknown device 1849:0571
Flags: bus master, medium devsel, latency 32, IRQ 14
I/O ports at fc00 [size=16]
Capabilities: [c0] Power Management version 2

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233 AC97 Audio Controller (rev 50)
Subsystem: VIA Technologies, Inc.: Unknown device 4161
Flags: medium devsel, IRQ 5
I/O ports at e000 [size=256]
Capabilities: [c0] Power Management version 2

00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
Subsystem: Unknown device 1849:3065
Flags: bus master, medium devsel, latency 64, IRQ 11
I/O ports at dc00 [size=256]
Memory at dffffe00 (32-bit, non-prefetchable) [size=256]
Capabilities: [40] Power Management version 2

01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15) (prog-if 00 [VGA])
Subsystem: Palit Microsystems Inc.: Unknown device 002d
Flags: bus master, 66Mhz, medium devsel, latency 64, IRQ 11
Memory at de000000 (32-bit, non-prefetchable) [size=16M]
Memory at da000000 (32-bit, prefetchable) [size=32M]
Expansion ROM at dfef0000 [disabled] [size=64K]
Capabilities: [60] Power Management version 1
Capabilities: [44] AGP version 2.0

root@Mustaf:~#

Tinkster 05-27-2003 06:51 PM

Try a

modprobe via82cxxx_audio

Cheers,
Tink

kosmognov 05-28-2003 08:00 AM

root@Mustaf:~# modprobe via82cxxx_audio
/lib/modules/2.4.20/kernel/drivers/sound/via82cxxx _audio.o.gz: init_module: No such device
/lib/modules/2.4.20/kernel/drivers/sound/via82cxxx _audio.o.gz: Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or t he output from dmesg
/lib/modules/2.4.20/kernel/drivers/sound/via82cxxx _audio.o.gz: insmod /lib/modules/2.4.20/kernel/dri vers/sound/via82cxxx_audio.o.gz failed
/lib/modules/2.4.20/kernel/drivers/sound/via82cxxx _audio.o.gz: insmod via82cxxx_audio failed
root@Mustaf:~#

max2003 05-28-2003 08:49 AM

Try with ALSA.

kosmognov 05-28-2003 08:57 AM

er... yes i've heard about it... but as you can see (below my nickname) you have Newbie... I think I should have Super duper newbie...
so therefore I don't know how to ...
please post every single detail...

thanks...

luucorp 05-28-2003 10:16 PM

hi, guys
i have this brolem , too?
plz help.
thansk in adv

kosmognov 05-29-2003 02:10 AM

Don't!!
 
Listen ... it hs been a While since I tryed to solve this problem, and now I hve to install everything again because I was trying too much stuff and ome off them went wrong.

I think That the only solution is to add the correct option to the Xconfig and to recompile the kernel... but if you want my advice... do wht i'm gonna do buy a cheap and compatible sound card or install something like mandrake.

Tinkster 05-29-2003 11:40 PM

That's a quite silly thing to say mate, I have that
chipset on two motherboards, and it works just dandy.

Cheers,
Tink

luucorp 05-29-2003 11:44 PM

you can post link to downl packet_driver for it

thank in adv

kosmognov 05-30-2003 02:55 AM

yep that would help...
 
Insert a quote into your message

luucorp 05-30-2003 05:27 AM

mean?

Tinkster 06-02-2003 04:14 PM

I don't think he was being mean ...

Cheers,
Tink

kazuni 06-02-2003 05:27 PM

try insmod ac97 and insmod ac97_codec, and tell us the results :)


All times are GMT -5. The time now is 03:25 AM.