LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-24-2003, 02:51 PM   #1
rvijay17
LQ Newbie
 
Registered: Oct 2002
Posts: 29

Rep: Reputation: 15
abrupt closure of mplayer -> no sound


hello,

whenever i play a movie using mplayer and if it closes abruptly, once or twice, i never get my sound back. i have to then reboot to get the sound.

what should I do ?

and plus, even after closing mplayer, why does 'ps -ef' show me mplayer.

regards,
vijay.
 
Old 06-24-2003, 02:57 PM   #2
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
It seems that mplayer exited abnormally. You can simply kill the process and it should free up your sound instead of rebooting.

You may want to run mplayer from a shell to see why it is exiting abnormally.
 
Old 06-24-2003, 03:03 PM   #3
rvijay17
LQ Newbie
 
Registered: Oct 2002
Posts: 29

Original Poster
Rep: Reputation: 15
the problem here is with the movie and not mplayer, and thats why I guess it closes down itself. the solution would be not to watch the movie, but why does it take away the sound.

I try to kill the process but it shows :
root 1187 658 0 00:05 ? 00:00:04 /usr/bin/mplayer /mnt/D:/MoreMovies/avseq02.mpg
root 1188 1187 0 00:05 ? 00:00:00 [mplayer <defunct>]
root 1197 658 1 00:06 ? 00:00:24 /usr/bin/mplayer /mnt/D:/MoreMovies/avseq02.mpg
root 1198 1197 0 00:06 ? 00:00:03 [mplayer <defunct>]
r

regards,
vijay.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
what is closure and marshaller in gobject?? Dstruct0 Programming 0 08-22-2005 05:46 PM
No sound in mplayer or mplayer firefox plugin case1984 Linux - Newbie 1 01-21-2005 01:58 AM
mplayer sound error? I have sound! necbrownie Slackware 4 01-13-2005 05:36 AM
MPlayer / Mplayer Plugin no Sound apjonesy Linux - Software 5 08-06-2004 05:27 AM
occasional kdm log-out and application closure crashes dizzi Slackware 4 07-15-2004 06:10 AM


All times are GMT -5. The time now is 11:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration