LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-25-2009, 03:22 AM   #1
vinaytp
Member
 
Registered: Apr 2009
Location: Bengaluru, India
Distribution: RHEL 5.4, 6.0, Ubuntu 10.04
Posts: 704

Rep: Reputation: 55
about konsole


hi all.......

i am using konsole for command line interface if i type the command

echo $TERM output is xterm and not konsole why is it so ... can any one tell me please......

thanks in advance........
 
Old 06-25-2009, 04:14 AM   #2
jdkaye
LQ Guru
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 5,464

Rep: Reputation: Disabled
That's the value of the environment variable TERM which I guess defaults to xterm on your system (mine too). It has nothing to do with the terminal program you're actually running.

If you run the same command in a virtual terminal (say, tty1) the output is not "xterm" but rather "linux"
cheers,
jdk

Last edited by jdkaye; 06-25-2009 at 04:18 AM.
 
Old 06-25-2009, 05:29 AM   #3
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,072

Rep: Reputation: 384Reputation: 384Reputation: 384Reputation: 384
Quote:
Originally Posted by jdkaye View Post
That's the value of the environment variable TERM which I guess defaults to xterm on your system (mine too). It has nothing to do with the terminal program you're actually running.
Actually, the terminal program you use should be setting it correctly. Otherwise what would be the reason to set that variable at all?? That variable is used in lots of scripts precisely to identify the type of terminal you are running. In a pure txt VT it will be "linux", inside GNU screen it will be "screen" no matter what terminal do you use. I use urxvt and I can see:

Code:
$ echo $TERM
rxvt-unicode
So I'd rather say that konsole is not setting it right for whatever reason. I would start checking the konsole configuration dialogs and see if it has some kind of profiles or settings to emulate other terminals or something like that. Most terminals can set a different terminal name via an option, in urxvt it's "-tn <termname>". So konsole might also have such option.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Konsole always give SuperUser Konsole - can't get regular shell checkmate3001 Linux - Desktop 3 08-05-2008 10:00 AM
konsole acts as "Root Konsole" ab44045 Linux - General 11 06-11-2007 05:18 PM
konsole MrMullen Linux - General 2 03-11-2005 02:04 PM
Help with Konsole pablowablo Linux - Newbie 0 08-05-2004 09:37 PM
konsole Henry Slackware 4 07-12-2003 09:24 PM


All times are GMT -5. The time now is 04:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration