LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-12-2009, 06:15 AM   #1
Dumb.Coder
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Rep: Reputation: 1
Unhappy Able to connect to default Gateway, Unable to connect to internet


Hi,

We are having a setup of windows workgroup and trying to install our first linux box on VMWare in the network . I have installed OpenSuse 11.1 and have setup the connection also. My problem is that I am able to connect to ping to other machines in the network and also other machines are able to ping me back but I am unable to ping DNS servers.

Here are some of the network settings I am using..
1. Internet is shared using windows internet connection sharing.

2. Direct internet connection is on a windows machine having 2 lan cards, one is set to the static IP address and other one is having ip as 10.202.251.45.

3. VMWare networking is set to Bridged networking.

4. On my OpenSUSE box IP address is : 10.202.251.120, have set default gateway as 10.202.251.45, and DNS server ips as set in other windows machines DNS1 : 59.144.169.16 and DNS2 : 59.144.169.17

5. Here are the other details which I feel are neccessary for resolving the problem (as understood by reading other similar posts)

---OUTPUT FROM ifConfig----------
eth0 Link encap:Ethernet HWaddr 00:0C:29:8E:17:2D
inet addr:10.202.251.120 Bcast:10.202.251.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1337 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:408840 (399.2 Kb) TX bytes:3743 (3.6 Kb)
Interrupt:19 Base address:0x2024

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:200 (200.0 b) TX bytes:200 (200.0 b)
------

-------/etc/resolv.conf------------
### /etc/resolv.conf file autogenerated by netconfig!
#
# Before you change this file manually, consider to define the
# static DNS configuration using the following variables in the
# /etc/sysconfig/network/config file:
# NETCONFIG_DNS_STATIC_SEARCHLIST
# NETCONFIG_DNS_STATIC_SERVERS
# NETCONFIG_DNS_FORWARDER
# or disable DNS configuration updates via netconfig by setting:
# NETCONFIG_DNS_POLICY=''
#
# See also the netconfig(8) manual page and other documentation.
#
# Note: Manual change of this file disables netconfig too, but
# may get lost when this file contains comments or empty lines
# only, the netconfig settings are same with settings in this
# file and in case of a "netconfig update -f" call.
#
### Please remove (at least) this line when you modify the file!
search workgroup
nameserver 59.144.169.16
nameserver 59.144.169.17
---------

-----/etc/sysconfig/network/ifcfg-eth0-------------
BOOTPROTO='static'
BROADCAST=''
ETHTOOL_OPTIONS=''
IPADDR='10.202.251.120/24'
MTU=''
NAME='79c970 [PCnet32 LANCE]'
NETWORK='10.202.251.45'
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='yes'
PREFIXLEN='24'
-------------------

6. I am running GNome GUI and have disabled the firewall also (till this problem is resolved).

7. Have changed the /etc/sysconfig/network/ifcfg-etho parameter NETWORK after reading another post on forum, but no luck .

Please help me out here.

TIA,
Dumb.Coder
 
Old 02-12-2009, 07:30 AM   #2
mapryan
LQ Newbie
 
Registered: Oct 2008
Location: London, UK
Distribution: SUSE
Posts: 19

Rep: Reputation: 0
You say you've tried pinging local systems - can other systems ssh into the Suse box? Also, is it using the same DNS server as other systems (and can they ping the DNS boxes)?

Might be worth posting the output from the 'ip r' command.

What happens of you try to resolve a DNS name using the host command? You can also tell host to use specific DNS servers as well, ie:
host www.amazon.com 59.144.169.17
Maybe you could try using a different DNS server

Cheers

Mike
 
Old 02-12-2009, 09:16 AM   #3
Dumb.Coder
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Original Poster
Rep: Reputation: 1
Hi Mike,

Thanks for your reply. Here are the details for the 'ip r' command
------------------
10.202.251.0/24 dev eth0 proto kernel scope link src 10.202.251.120
169.254.0.0/16 dev eth0 scope link
127.0.0.0/8 dev lo scope link
default via 10.202.251.45 dev eth0
---------------

Also when i tried the host command, I got the following...
----------
> host www.google.com 59.144.169.17
;; connection timed out; no servers could be reached
----------

I tried ssh and sftp also and these are working fine from my local windows machines to OpenSUSE box. Other system in windows network are having the same DNS and Default Gateway configurations. The DNS servers are working fine for windows boxes.

TIA,
Dumb.Coder

Quote:
Originally Posted by mapryan View Post
You say you've tried pinging local systems - can other systems ssh into the Suse box? Also, is it using the same DNS server as other systems (and can they ping the DNS boxes)?

Might be worth posting the output from the 'ip r' command.

What happens of you try to resolve a DNS name using the host command? You can also tell host to use specific DNS servers as well, ie:
host www.amazon.com 59.144.169.17
Maybe you could try using a different DNS server

Cheers

Mike
 
Old 02-12-2009, 09:27 AM   #4
mapryan
LQ Newbie
 
Registered: Oct 2008
Location: London, UK
Distribution: SUSE
Posts: 19

Rep: Reputation: 0
How about trying an IP address rather than a domain name on the Suse system? That way you can know whether the issue is network or DNS related.

Try this (it's google.com)
curl http://74.125.77.103
 
Old 02-13-2009, 03:34 AM   #5
Dumb.Coder
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Original Poster
Rep: Reputation: 1
Hi Mike,

I tried curl as you asked and here is the output...
-----output of curl-----
curl http://74.125.77.103
curl: (7) couldn't connect to host
------

But when i tried pinging again to the IP address, it was successful. Also when I tried http://74.125.77.103 in Firefox, I was able to get the google page.

So, it means you are right, it seems a problem with DNS settings only. Please help me further to overcome this problem.

TIA,
Dumb.Coder

Quote:
Originally Posted by mapryan View Post
How about trying an IP address rather than a domain name on the Suse system? That way you can know whether the issue is network or DNS related.

Try this (it's google.com)
curl http://74.125.77.103
 
Old 02-13-2009, 10:30 AM   #6
mapryan
LQ Newbie
 
Registered: Oct 2008
Location: London, UK
Distribution: SUSE
Posts: 19

Rep: Reputation: 0
What you can do is to try and telnet to the DNS server port to verify
1: That you can connect to it
2: That something is listening

So, if you go onto the Linux box and try
59.144.169.16

You should get
Connected to 59.144.169.16.
Escape character is '^]'.

Is there's a problem, you'll get
telnet: connect to address 59.144.169.16: Connection refused
or maybe it'll just timeout

Rgds

Mike
 
Old 02-13-2009, 03:32 PM   #7
Dumb.Coder
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Original Poster
Rep: Reputation: 1
Thanks Mike,

Will try this on Monday, going for weekend off . Also I freed up around 20 GB of disk space and installed OpenSUSE directly on HD instead of VMWare . Here also I was getting same DNS related problems . Also having some display and mouse-pad related problems (Compaq Presario V3611AU), but that's for another post .

I will try telnet to DNS tomorrow or on Monday and will let you know the outcome of the exercise. Thanks again for helping me.

Regards & TIA,
Dumb.Coder


Quote:
Originally Posted by mapryan View Post
What you can do is to try and telnet to the DNS server port to verify
1: That you can connect to it
2: That something is listening

So, if you go onto the Linux box and try
59.144.169.16

You should get
Connected to 59.144.169.16.
Escape character is '^]'.

Is there's a problem, you'll get
telnet: connect to address 59.144.169.16: Connection refused
or maybe it'll just timeout

Rgds

Mike
 
Old 02-14-2009, 08:45 AM   #8
Dumb.Coder
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Original Poster
Rep: Reputation: 1
Hi Mike,

I tried telnet to the gateway and it worked and also it is pinging now (GOD knows how ). But DNS look-up still fails . When I try to ping www.google.com, it doesn't work. But when I try ping using IP Address, it works.

Please guide me further for what else we can try to overcome the issue.

TIA,
Dumb.Coder

Quote:
Originally Posted by mapryan View Post
What you can do is to try and telnet to the DNS server port to verify
1: That you can connect to it
2: That something is listening

So, if you go onto the Linux box and try
59.144.169.16

You should get
Connected to 59.144.169.16.
Escape character is '^]'.

Is there's a problem, you'll get
telnet: connect to address 59.144.169.16: Connection refused
or maybe it'll just timeout

Rgds

Mike
 
Old 02-16-2009, 02:22 AM   #9
Dumb.Coder
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Original Poster
Rep: Reputation: 1
Smile

Hi Mike,

I finally got Internet up and working on my direct HD install of OpenSUSE. Although DNS lookup still fails on VMWare . Must be some problem with VMWare network configuration.

Anyway, now I have something to work on (I will have to switch back and forth for windows and Linux). I am planning to do some .net development on Mono (trying to switch from windows to Linux). Also, I was able to install nVidia drivers and graphics related problems are now things of past .

Thank you Mike for your help in trying to diagnose the problem.

Thanks & Regards,
Dumb.Coder

Quote:
Originally Posted by Dumb.Coder View Post
Hi Mike,

I tried telnet to the gateway and it worked and also it is pinging now (GOD knows how ). But DNS look-up still fails . When I try to ping www.google.com, it doesn't work. But when I try ping using IP Address, it works.

Please guide me further for what else we can try to overcome the issue.

TIA,
Dumb.Coder
 
Old 02-16-2009, 09:01 AM   #10
mapryan
LQ Newbie
 
Registered: Oct 2008
Location: London, UK
Distribution: SUSE
Posts: 19

Rep: Reputation: 0
No problem. Glad you got there in the end 8-)
 
Old 03-17-2009, 04:07 AM   #11
thaj9182
LQ Newbie
 
Registered: Mar 2009
Posts: 1

Rep: Reputation: 0
unable to connect internet through firefox

Hi Buddy.

Today i have installed suse linux 11.1 .i am able to ping public ip,but iam not able to browse any web pages in mozilla firefox.

Kindly do the needfull.

Thanks
Thaj
 
Old 04-14-2009, 04:22 AM   #12
Dumb.Coder
LQ Newbie
 
Registered: Feb 2009
Posts: 10

Original Poster
Rep: Reputation: 1
Dear Thaj,

One possible issue related to this can be the DNS settings. Have you tried pinging www.google.com?? If you are able to ping by IP and not able to ping by DNS name, then verify the Name Server settings in the network settings of your machine.

HTH,
Dumb.Coder

Quote:
Originally Posted by thaj9182 View Post
Hi Buddy.

Today i have installed suse linux 11.1 .i am able to ping public ip,but iam not able to browse any web pages in mozilla firefox.

Kindly do the needfull.

Thanks
Thaj
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect to DHCP gateway Setya Suse/Novell 1 06-05-2007 10:16 PM
Gateway disappears, can't connect to internet eli_pack Linux - Wireless Networking 4 03-27-2006 09:06 AM
intermittent failure winPC connect internet thru ipmasq linux gateway takahaya Linux - Networking 0 05-13-2005 06:35 PM
cannot connect to internet via gateway cbunney Linux - Networking 3 09-13-2004 03:13 PM
LAN machines unable to connect to Internet through (firewall on )gateway nishi_k_79 Linux - Security 1 11-13-2003 01:30 PM


All times are GMT -5. The time now is 01:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration