LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-16-2004, 09:57 PM   #1
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Rep: Reputation: 15
Aaaaaaagh!!! Help Please


I have been trying for a WEEK now to get my ATI card working in FC2 and due to somones advice I updated to the latest version of XFree86 (4.4.1 I think) and now I can't even X to start my desktop using "vesa" drivers let alone "fglrx" Should I just reformat I reinstall FC2?
 
Old 08-16-2004, 11:13 PM   #2
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,275

Rep: Reputation: 370Reputation: 370Reputation: 370Reputation: 370
Did you install the ATA drivers? I know they can be problematic, but if you post exactly what you tried and any error messages that resulted, maybe someone who's done so can help you out. Also post the exact error that XFree86 spits at you now. Also, a more descriptive thread title would probably help out in this case.
 
Old 08-17-2004, 03:02 AM   #3
heema
Senior Member
 
Registered: Sep 2003
Location: Egypt
Distribution: Arch
Posts: 1,528

Rep: Reputation: 47
have u tried reinstalling the ati driver ?
 
Old 08-17-2004, 12:54 PM   #4
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Original Poster
Rep: Reputation: 15
When I use "sh make.sh" to generate my ATI module I get this error, but I have the latest kernel (2.6.7). What am I doing wrong?

ATI module generator V 2.0
==========================
initializing...
Error:
XFree86 drm includes at /lib/modules/2.6.7-1.494.2.2/build/include/../drivers/char/drm do not fit this driver.
This driver is designed to only work with X4.1.0 or higher.
You can match this by getting Linux kernel 2.4.8 or higher.
[root@localhost build_mod]#


And this is even after I installed X4.4.0.

Yes, I did try to reinstall the ATI Drivers and it said they were allready installed, so I forced the install again and get the same message as the above.
 
Old 08-17-2004, 01:04 PM   #5
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
ati-drivers don't seem to work fine with 2.6 kernels.
but i read somewhere on this site , there is some kind of kernel-patch,
made for these drivers.

go to the Slackware-forum, and do a forum-search for '''ati '';
thats how i came there.

egag

( it's kindof howto )
 
Old 08-17-2004, 01:57 PM   #6
svoltmer
Member
 
Registered: Apr 2004
Posts: 33

Original Poster
Rep: Reputation: 15
I've used the patch and it fails on most of the HUNKs
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
AAAAAAAGH!!!!! If Its not one thing, then rest assured its another!!!!!!! 5aboy Linux - Newbie 4 05-22-2003 07:38 PM


All times are GMT -5. The time now is 05:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration