LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-18-2004, 06:43 PM   #1
chug
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Rep: Reputation: 0
A way to cancel lilo change when you could not boot anymore ?


i've made a stupid mistake and i don't know how to recover it (as you will see it is really a newbie mistake). I have a Compaq laptop Presario 2144 and i installed, without trouble, mandrake 10 (dual boot with windows). But i notice that the ACPI wasn't install. I look around, and i saw that it seems quite simple to installl :
- urpmi acpi acpid
- change acpi=ht to acpi= force in lilo.conf
- run lilo
- reboot
But it doesn't boot at all after lilo, the ACPI seems to make problem. And i suddently undersant that i've make a stupid mistake, i have forget to keep a lilo.conf entry unchange (with acpi=ht) or do a rescue floppy boot (but i don't know how to do it).

I think i have a last chance, as i also have a MandrakeMove CD. I launch it in hope to change the lilo of my hard drive. I mount the hard drive where is my linux install on /mnt/hd6, and change the lilo.conf to the previous value. But i didn't find a way to launch the lilo command line to change the MBR. After reading the man, i have try :

lilo -v -m /mnt/hd6/boot/map -C /mnt/hd6/etc/lilo.conf

and i get the answer :

LILO version 22.5.7.2, Copyright (C) 1992-1998 Werner Almesberger
Development beyond version 21 Copyright (C) 1999-2003 John Coffman
Released 20-Aug-2003, and compiled at 16:45:54 on Sep 18 2003

Ignoring entry 'map'
Reading boot sector from /dev/hda
Using MENU secondary loader
Calling map_insert_data
Mapping message file /boot/message
Fatal: open /boot/message: No such file or directory

quite logic as the MandrakeMove doesn't have a /boot/ directory. But i don't know how to specify the path to /mnt/hd6/boot/message in the lilo command line...and may be after that there other path to change.

Is my solution possible ? and if yes with which lilo comand line ?
Or is there another solution to rescue my install ? or do i have to install it again ?

thanks by advance for your help.
chug
 
Old 07-18-2004, 06:46 PM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try "chroot /mnt/hd6"
 
Old 07-19-2004, 01:17 PM   #3
chug
LQ Newbie
 
Registered: Jul 2004
Posts: 6

Original Poster
Rep: Reputation: 0
thx it works,

chug
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo does not boot anymore, pls help! john_d13 Linux - Hardware 3 03-19-2005 01:41 AM
lilo wont boot winxp anymore Rognon Linux - General 2 02-12-2005 12:55 PM
Cant boot to windows anymore? Using lilo/mandrake af_dave Linux - General 4 07-19-2004 12:19 AM
Change LILO boot order ??? glenn69 Linux - Newbie 2 04-24-2004 08:01 PM
help!!!! i see nothing on boot (after makin change to lilo) h/w Linux - Hardware 3 11-29-2003 03:01 PM


All times are GMT -5. The time now is 07:47 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration