LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-26-2011, 08:55 AM   #1
msbstar
Member
 
Registered: Jan 2010
Distribution: Ubuntu 10.4
Posts: 122

Rep: Reputation: 16
Question A Problem with "wxPython".


Hi Everybody,

I have installed wxPython on my Ubuntu 9.10. But when I type
"import wxPython" in "python environment it returns the following
error.

Does it need a PATH to be added in ".bashrc"? If so what should I write as a PATH for it?

I would be very grateful for any help.

With best regards,
Hassan

------------------------------------------
>>> import wxPython
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
File "/scisoft/lib/python2.5/site-packages/wx-2.8-gtk2-ansi/wxPython/__init__.py", line 15, in <module>
import _wx
File "/scisoft/lib/python2.5/site-packages/wx-2.8-gtk2-ansi/wxPython/_wx.py", line 3, in <module>
from _core import *
File "/scisoft/lib/python2.5/site-packages/wx-2.8-gtk2-ansi/wxPython/_core.py", line 15, in <module>
import wx._core
File "/scisoft/lib/python2.5/site-packages/wx-2.8-gtk2-ansi/wx/__init__.py", line 45, in <module>
from wx._core import *
File "/scisoft/lib/python2.5/site-packages/wx-2.8-gtk2-ansi/wx/_core.py", line 4, in <module>
import _core_
ImportError: libtiff.so.3: cannot open shared object file: No such file or directory
>>>
---------------------------------------------------------------
---------------------------------------------------------------

Last edited by msbstar; 01-26-2011 at 09:01 AM.
 
Old 01-26-2011, 09:11 AM   #2
jcookeman
Member
 
Registered: Jul 2003
Location: London, UK
Distribution: FreeBSD, OpenSuse, Ubuntu, RHEL
Posts: 417

Rep: Reputation: 33
Do the following:

Code:
$ find /usr -name libtiff.so.*
/usr/lib32/libtiff.so.4
/usr/lib32/libtiff.so.4.3.3
I have versoin .4 and my import wx and wxPython works fine. So, you will have to either create the link libtiff.so.3 pointing to that or find out why your install is a bit "old". It works fine on mine and I'm running Ubuntu 10.10 on this machine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem "$value=`mpstat 1 1 | grep "Average"`;" Alias pipe return nothing adamlucansky Linux - General 8 09-25-2009 08:26 AM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 09:31 AM
Proposed solution for "status" (aka "problem solved") indicator demerson3 LQ Suggestions & Feedback 12 04-08-2006 03:15 PM
Problem with "3Com", "3CRSHPW_96 Wireless LAN PC Card " Adil_uk Linux - Wireless Networking 0 12-18-2005 06:45 PM
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 05:51 AM


All times are GMT -5. The time now is 02:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration