LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-29-2007, 03:49 PM   #1
LinuxRambo
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Rep: Reputation: 0
Question A problem with SSH


I have a fedora core 6 machine that I use as a server. I am on a windows machine on the same network and simply use putty to ssh to the linux box. Everything works fine for me while I am on the windows machine, but if I try to ssh from a computer not on the network I can't connect. I have a domain name registered with Dyndns and have my dmz enabled and on the right ip. I checked to make sure that the linux box was accepting on port 22. I even opened all the ports on my router to the linux box and I still can't connect with ssh. Any suggestions?
 
Old 03-29-2007, 04:15 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 235Reputation: 235Reputation: 235
Can you connect by IP? And go ahead and close all those ports except 22, that's just a bad idea and pointless..
 
Old 03-29-2007, 10:47 PM   #3
Buto
Member
 
Registered: Sep 2004
Location: So Cal
Distribution: Slackware 12
Posts: 60

Rep: Reputation: 16
I'd try pinging your IP. I know some ISP's block certain ports so you cant get to it. So you may have to end up using a different port to connect to you linux box. That's what I do. I added Ports 1822 to my /etc/ssh/sshd_config file
 
Old 03-29-2007, 11:00 PM   #4
dugas
Member
 
Registered: Jul 2004
Location: louisiana
Distribution: fedora 4/kubuntu
Posts: 116

Rep: Reputation: 15
Maybe your dsl/cable modem is blocking the port, not your router. Some modems have ip passthrough option. If your protocol is supported by your router, then you can set your modem in bridge mode and let the router authenticate....(pppoe,pppoa,....). Also, are you sure you are using the correct ip? Go to checkip.dyndns.org from your linux box and make sure.
 
Old 03-30-2007, 11:52 AM   #5
LinuxRambo
LQ Newbie
 
Registered: Mar 2007
Posts: 2

Original Poster
Rep: Reputation: 0
I tried to connect by ip and still have had no success. Also I only open the ports for a few minutes while a friend tried to connect.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ssh-agent, ssh-add and ssh-keygen AND CVS raylpc Linux - General 2 11-19-2008 02:50 AM
SSH problem - ssh-add not respond FerkoPica Linux - Security 6 05-07-2006 03:47 PM
Passwordless SSH with SSH commercial server and open ssh cereal83 Linux - General 7 04-18-2006 12:34 PM
ssh problem after creating an ssh alias. porotothorpe Linux - General 2 01-25-2006 07:56 PM


All times are GMT -5. The time now is 04:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration