LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-20-2008, 01:57 PM   #1
davidstvz
Member
 
Registered: Jun 2008
Posts: 405

Rep: Reputation: 30
A few configuring questions with regard to services like vsftpd


I assume that after I change the .conf file for vsftpd, I need to stop and start the service again. How is that done?

By the way, instead of learning the proper way, I tried something stupid that seems to have broke things a little bit.

I tried to kill the vsftpd process and then run "/usr/sbin/vsftpd &" again (as initially instructed by a certain website (vsftpdrocks.org) hoping that would restart it. Instead it tells me:

and I got:

[2] 1394
[1] Terminated /usr/sbin/vsftpd

Anyway, someone please give me an idea of how to do this properly, and let me know if my little process killing thing will require any cleaning up or a reboot (I have no idea what the above output means).
 
Old 08-20-2008, 01:58 PM   #2
davidstvz
Member
 
Registered: Jun 2008
Posts: 405

Original Poster
Rep: Reputation: 30
As a quick follow up, although it didn't look pretty (as per the above output) it apparently worked. User/password ftp is now working on the machine for me.

Still, I figure there is a better way than issuing a kill command on the vsftpd process.
 
Old 08-20-2008, 02:00 PM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
If it's configured for standalone mode which should be indicated in your conf file, that should be the proper way usually to start vsftpd. If not in standalone mode, usually it's invoked through inetd or maybe another init script, depending on what distribution you are using.
 
Old 08-20-2008, 02:02 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Quote:
Originally Posted by davidstvz View Post
Still, I figure there is a better way than issuing a kill command on the vsftpd process.
If you don't have a script to start and stop the services, write one and simply make the killing of it do it in a nice way, like kill -15 (SIGTERM) which will allow the service/daemon to cleanup any leftovers before completing dying. Kill -9 should be avoided in most cases, it's the last case effort if all else fails when you're trying to kill a process.
 
Old 08-20-2008, 02:58 PM   #5
davidstvz
Member
 
Registered: Jun 2008
Posts: 405

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by trickykid View Post
If you don't have a script to start and stop the services, write one and simply make the killing of it do it in a nice way, like kill -15 (SIGTERM) which will allow the service/daemon to cleanup any leftovers before completing dying. Kill -9 should be avoided in most cases, it's the last case effort if all else fails when you're trying to kill a process.
Ah, so killing isn't a bad idea, I just have to do it the right way.

I am currently running standalone mode, but I'm considering the xinetd method.

One more question, what does the & symbol mean as an option after starting vsftpd?

Example:

/usr/sbin/vsftpd &

?
 
Old 08-20-2008, 03:58 PM   #6
davidstvz
Member
 
Registered: Jun 2008
Posts: 405

Original Poster
Rep: Reputation: 30
EDIT:

The problem below been explained to me now in another thread.

-------------------------------------------


OK, I restarted xinetd but it "failed"

My /var/log/messages says this:

Code:
Aug 20 14:36:57 serv2 xinetd[7180]: bind failed (Address already in use (errno = 98)). service = ftp
Aug 20 14:36:57 serv2 xinetd[7180]: Service ftp failed to start and is deactivated.
Aug 20 14:36:57 serv2 xinetd[7180]: 7180 {init_services} no services. Exiting...

Last edited by davidstvz; 08-20-2008 at 05:38 PM.
 
Old 08-20-2008, 04:10 PM   #7
davidstvz
Member
 
Registered: Jun 2008
Posts: 405

Original Poster
Rep: Reputation: 30
EDIT: This has been addressed too. Thank you (my post, two above this about the & symbol still stands unanswered though!)

----------------------------

I have reverted the config files to their earlier form, but according to the logs (as best as I can tell) xinetd is still trying to start vsftpd

(I have disabled set to yes, and in the vsftpd.conf file the thing is set to standalone)

I backed up and deleted the vsftpd file in /etc/xinetd.d/ and it still won't start.

This is really starting to worry me! I need this server up and running properly within a few days and I'm not sure what the problem is here.

Last edited by davidstvz; 08-20-2008 at 05:24 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring directory services itplanett Linux - Newbie 2 08-11-2008 02:43 PM
Configuring services without X Citizen Bleys Linux - General 2 12-14-2003 01:48 PM
Configuring vsftpd Coldmiser Linux - Software 2 10-21-2003 08:17 AM
configuring services on SuSE GloVe Linux - General 1 09-19-2003 04:47 PM
Configuring services... Bogdan Linux - Newbie 3 02-06-2002 04:01 PM


All times are GMT -5. The time now is 05:33 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration