LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   A DNS learner's question->Is my DNS configuration right? (http://www.linuxquestions.org/questions/linux-newbie-8/a-dns-learners-question-is-my-dns-configuration-right-696359/)

saagar 01-10-2009 02:05 PM

A DNS learner's question->Is my DNS configuration right?
 
Friends,
I am learning to use DNS in RHEL 5. I installed bind, bind-libs, and bind-utils only. I wished to do this through /etc/named.conf and /var/named/* and not through chroot-ing. So I did not install caching-nameserver and bind-chroot. I have configured with minimum entries in /etc/named.conf as I am a learner. But,the forward and reverse lookup through dig command works fine from the localhost. But when I tried to dig from the second computer I am not getting any result. It's just still..I have configured /etc/resolv.conf in client machine with the ip address of the first computer.(nameserver 10.0.0.1). however, I have not configured an example.com domain in the /etc/sysconfig/network nor a ypserver running. Please help what need to be done more.

vi /etc/named.conf
----------------------------------
options {
directory "/var/named";
};

zone "example.com" IN {
type master;
file "fdzone";
};

zone "0.0.10.in-addr.arpa" IN {
type master;
file "revzone";
};
-------------------------------------
and my forward zone file in /var/named/fdzone is as
follows:

$TTL 1D

@ IN SOA linux1.example.com. sagar.gmail.com. (
15
20
30
40
50 )
@ IN NS linux1
linux1 IN A 10.0.0.1
linux2 IN A 10.0.0.2
===============================================
my reverse zone file in /var/named/revzone is as follows:

$TTL 1D

@ IN SOA linux1.example.com. sagar.gmail.com. (
15
20
30
40
50 )
@ IN NS linux1
1 IN PTR linux1.example.com.
2 IN PTR linux2.example.com.

=================================================

AlucardZero 01-11-2009 09:27 AM

I don't know bind, but please enclose your configuration in code tags.

Code:

[code]like this[/code]

saagar 01-11-2009 09:30 AM

ok. thanks for that.

bathory 01-11-2009 02:04 PM

The configuration file and the 2 zone files look correct.
Check if there is a firewall between server and client preventing queries.

Regards

saagar 01-12-2009 08:44 AM

Thank you bathory. I have done this successfully with the same details, but I also created two zones for the local host in /etc/named.conf as follows:
zone "localdomain" IN {
type master;
file "fdzone.local";
};
zone "0.0.127.in-addr.arpa" IN {
type master;
file "revzone.local";
};

:wq
++++++++++++++++++++++++++++++
/var/named/fdzone.local and /var/named/revzone.local files are created and configured.
+++++++++++++++++++++++++++++
Then this worked perfectly when digged from both the systems..
Thanks a lot.


All times are GMT -5. The time now is 04:55 AM.