LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-14-2004, 07:03 PM   #1
maybbach
Member
 
Registered: Feb 2004
Location: Cincinnati, OH
Distribution: SimplyMepis 3.3
Posts: 68

Rep: Reputation: 15
a couple questions


I installed Redhat 9 last night and have been having decent success getting some things to work. I do have a couple of problems. I have a Sound Blaster Live 5.1 card installed, but can't seem to get it to work. When I ran the Sound Card Configuration Utility and play the test sound, I hear it play; but when I try to play an mp3 or wav file, I hear nothing. I turned the volume up on XMSS, and checked the Volume Control to make sure nothing was on mute. I downloaded the emu10k1 file, but I'm having trouble installing it. I tried playing a cd and it didn't work, but I think it's becuase I don't have the cd-rom cable hooked up to the sound card.

I'm also having printer problems. I connected my Lexmark X73 all-in-one (usb) and it installed ok and was recognized by RH, but when I print a test page, nothing happens (also, no error messages comes up in Printer configuration).

Lastly, I installed Acrobat Reader but can't seem to launch it. It was installed to the /usr/local/Acrobat5 directory, but I can't find anything that looks like an .exe file to run it. I'd like for it to be my default pdf viewer, but don't know how to change program defaults yet.

Thanks in advance!
 
Old 04-14-2004, 07:23 PM   #2
dimi
Member
 
Registered: May 2003
Location: Sydney, Australia
Distribution: Debian
Posts: 67

Rep: Reputation: 15
Hi

Mmm this is just a guess, but have you checked the /etc/group file? I think if your are to use audio, you need to be in the audio group. Try adding your username to the audio group.

Don't really have clue about the printer, but on Acrobat Reader, if the installation was successful, then acroread should be on /usr/bin. In linux there are no .exe files, just binaries. on a terminal type acroread and hit enter. That should launch acroread. The acrobat reader executable is in /usr/local/Acrobat5/bin/ and its called acroread.

Good luck
D
 
Old 04-14-2004, 07:33 PM   #3
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
linux does not use .exe files.

Look in /usr/local/Acrobat5/bin

there wil be a file called acroread, then type ./acroread to launch it

If it still does not work edit the acroread file and add

LANG=C;
export LANG


like this, this is the top part of the file



#!/bin/sh
#

LANG=C;
export LANG

ver=5.0.8
install_dir=/usr/local/Acrobat5/Reader

#
# Prepend a colon separated environment variable
# $1 string to be prepended





save this and then launch and it should work fine. To make it your preferred pdf viewer go to the preferences menu and have a look for something like preferred applications. This is depends of the Windows manager so we need more information.

You will also want to add acroread to your $PATH. This enables to to simply type acroread and it will load instead of /usr/local/Acrobat5/bin/acroread. Add the following line to the bottom of your /etc/profile file

export PATH=$PATH:./:/usr/local/Acrobat5/bin

this will add ./ and /usr/local/Acrobat5/bin to your $PATH so instead of having to type ./ to load a file in the current directory you can just type the file name, this will also add /usr/local/Acrobat5/bin so you can just type acroread anywhere and it will load.

You will have to log out and in again for the changes to take affect though. or just type the following into the command prompt to do it straight away


export PATH=$PATH:./:/usr/local/Acrobat5/bin



For the other questions we need to know a little more about your distribution ie

What distro are u using (Fedore, SUSE, gentoo etc)
What window manager are you using (KDE, Gnome, Window Maker etc)

Last edited by jax8; 04-14-2004 at 07:35 PM.
 
Old 04-14-2004, 08:39 PM   #4
blinux1
Member
 
Registered: Nov 2002
Location: Pennsylvania
Distribution: Mandrake 9.1 and Redhat 9
Posts: 144

Rep: Reputation: 15
about your printer....did you install the drivers? Are there any drivers?
 
Old 04-14-2004, 09:08 PM   #5
maybbach
Member
 
Registered: Feb 2004
Location: Cincinnati, OH
Distribution: SimplyMepis 3.3
Posts: 68

Original Poster
Rep: Reputation: 15
thanks jax8, everything worked, i appreciate it. The only thing I haven't been able to do is set Acrobat as default PDF reader. Looking through preferences in Acrobat didn't help, so i tried changing the file type through the File types and programs in the preferences Applet. I added everything, but when i try to add the Filename extension, theres no button allowing me to do so. Btw, my Linux distro is Redhat 9, my window manager is gnome, i think.

as for the printer, lexmark doesnt make any linux drivers, so i had to use the one with redhat. i choose the drivers that were listed in the Printer configuration window (drvz42).

thanks for all the help, I appreciate it
 
Old 04-14-2004, 09:52 PM   #6
blinux1
Member
 
Registered: Nov 2002
Location: Pennsylvania
Distribution: Mandrake 9.1 and Redhat 9
Posts: 144

Rep: Reputation: 15
I remember having to install drivers from the supplementary Cd for a single function lexmark, and i remember that among the files unpackaged, there were scripts that maintained the printer from the console--adjusting and printing test pages. Perhaps you should look for some of the maintenance scripts and try those instead of the PrintDrake config or whatever you used. Also, what printing or spooling system are you planning to use?? My printer never worked with CUPS, but it had a script to add the printer to the LPRng spooling system, an older but nevertheless functioning system. Hope this helped
 
Old 04-14-2004, 11:05 PM   #7
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
try this for making acroread your default pdf viewer

right click on a pdf file and select "open with"

choose acroread, you may have to type it in as the command and then there will probably be a tick box there somewhere to make it your default application to load for pdf files.

I use KDE so gnome will be slightly different.

-jax8
 
Old 04-14-2004, 11:30 PM   #8
dimi
Member
 
Registered: May 2003
Location: Sydney, Australia
Distribution: Debian
Posts: 67

Rep: Reputation: 15
Well i'm using gnome 2.4, hope thats the same on your. Anyways in the menu panel under Applications/Desktop Preferences/Advanced, there is a program called "File types and programs" . If you click on that, a window will pop up to set the default programs to each file type.

Here under Documents/Published Materials/ you can set the default program to run when opening pdf files.

If you can't find the "File types and programs" on the menu, you can always run from a terminal by typing "gnome-file-types-properties" .

Good luck.

D
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Couple questions. kuplo Linux - Newbie 0 11-26-2005 10:48 AM
couple of questions?? Lucas10 Linux - Newbie 23 06-04-2005 05:45 PM
a Couple of questions! Nik0s Linux - Newbie 14 01-25-2004 11:01 AM
Just a couple of questions... LI-6Y LUCY Linux - Newbie 4 09-07-2003 09:33 AM
A couple questions aceman817 Linux - Networking 2 04-25-2001 06:02 PM


All times are GMT -5. The time now is 04:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration