LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-10-2004, 03:59 PM   #1
tedsung
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Rep: Reputation: 0
__ctype_b is undefined - what version did this start


Hi,

I've read some bugzilla entries about this but am still not clear.
At some point (I think in the RH 9 release), the libc internal function
__ctype_b() (and others) was removed. So if you had a static library
built from a previous version of glibc and tried to link to it with the later version of glibc, you'd get an undefined reference error.

My question is what version of RH did this start and with what version of glibc.

Thanks,

Ted
 
Old 08-10-2004, 04:16 PM   #2
ToniT
Senior Member
 
Registered: Oct 2003
Location: Zurich, Switzerland
Distribution: Debian/unstable
Posts: 1,357

Rep: Reputation: 47
Code:
toni@mario:~$ nm -D /lib/libc.so.6 | grep __ctype  
00128778 D __ctype_b
00023730 T __ctype_b_loc
00021d00 W __ctype_get_mb_cur_max
00128780 D __ctype_tolower
00023830 T __ctype_tolower_loc
00128784 D __ctype_toupper
000237b0 T __ctype_toupper_loc
0012877c D __ctype32_b
00128788 D __ctype32_tolower
0012878c D __ctype32_toupper
toni@mario:~$
It is still there in debian.
 
Old 08-10-2004, 04:34 PM   #3
tedsung
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
the bugzilla link regarding __ctype_b()

This was the link that lead me to believe that at some point one of the RH9 patches changed the behavior of things:

http://bugzilla.redhat.com/bugzilla/...g.cgi?id=86465
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem of undefined reference to `__ctype_b' nelnel Programming 3 08-01-2007 02:40 AM
Firefox wont start!!! undefined symbol: NS_NewUnionEnumerator nenyo Linux - Software 2 07-18-2005 04:31 PM
k3b won't start: "undefined symbol" error djzanni Mandriva 2 03-12-2005 11:49 AM
__ctype_b undefined - what glibc version did this start tedsung Linux - Software 0 08-11-2004 11:23 AM
Apache2 + opensll_0.9.7c undefined symbol X509_free when I try to start apache mdkelly069 Linux - Software 0 02-09-2004 12:09 PM


All times are GMT -5. The time now is 06:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration