LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-22-2003, 12:46 AM   #1
sparrot
LQ Newbie
 
Registered: Nov 2002
Posts: 27

Rep: Reputation: 15
5 small hitches.....


running mandrake 8.0 using X.....

1......
Cannot shutdown system from login area....resorting to powercut...OOCH!!

2........
Cannot configure soundcard....."modprobe: cannot locate module ISA-PNP"

3.......
.
Can connect to the net, but only thru mandrake cont. centre. It says conn. to net, then cannot connect, then connects, gives me disconn. option. Can i get an easy menu conn. option??

4........
Cannot seem to use filenames with spaces in text line....>(

5.......
Would appreciate some info on GTK...uses and .structure.

Know its a bit, any help thanked 4.
 
Old 03-22-2003, 03:49 AM   #2
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
Re: 5 small hitches.....

Quote:
Originally posted by sparrot
Cannot shutdown system from login area....resorting to powercut...OOCH!!
I take this to mean that you cannot select the graphical login screen button that let's one shutdown the system. There could be some sort of permissions problem. But even if there is... doesn't Ctrl-Alt-Del initiate a reboot? At least then you'd be going through a proper shutdown and you could power down just as the system was starting its reboot and before it'd had a chance to mount filesystems. Personally, I'd switch the run level to `3' from `5' if you cannot find a solution to this problem. You would need to login as root to shutdown the system but that's tons better than filesystem corruption.
Quote:
Cannot configure soundcard....."modprobe: cannot locate module ISA-PNP"
Have you looked in the /lib/modules subdirectories to see if a file with a similar name can be found? If you've rebuilt your kernel and removed some support, you may still have a /etc/modules.conf that contains lines that are for the support you've removed (and you'll see some goofy messages). BTW, what sound card are we talking about? An old ISA bus card?
Quote:
Cannot seem to use filenames with spaces in text line....>(
This is going to be a problem no matter what distribution you choose. Spaces are not part of traditional UNIX file names. You can deal with them, though, by escaping the spaces. I.e.,

mv Really\ Cool\ Song.mp3 Really_Cool_Song.mp3

Hope some of this helped (or at least made a little sense),

Rick
 
Old 03-23-2003, 12:07 AM   #3
sparrot
LQ Newbie
 
Registered: Nov 2002
Posts: 27

Original Poster
Rep: Reputation: 15
SHUTDOWN....no, there just is not a shutdown option ANYWHERE!
not under root, not in menu's, not at login.

SB 16 PNP soundcard. Not much in libs....how would i use them?

can now use most spaced files....exept those with command characters.....>(

Sometimes listed files wont be recognized when i try to use them........??
 
Old 03-23-2003, 12:13 AM   #4
crichards
Member
 
Registered: Feb 2003
Location: Arizona
Distribution: Gentoo!
Posts: 124

Rep: Reputation: 15
As for shutdown, hit GTRL+ALT+Fx, where x is a number between 1 and 6. Then login as root, and type the following command:

halt

You can also do this in an xterm or lookalike.

When you have a file:

-hello-world.mp3

use this

mv -- -hello-world.mp3 hello-world.mp3
 
Old 03-23-2003, 05:19 PM   #5
rnturn
Senior Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0, RHEL5,6), CentOS, SuSE (10.x, 11.x, 12.2, 13.2), Solaris (8-10), Tru64, MacOS, Raspian
Posts: 1,108

Rep: Reputation: 64
sparrot: ``no, there just is not a shutdown option ANYWHERE!
not under root, not in menu's, not at login''

That's really weird. I take it that this is true no matter the login GUI (gdm, kdm, etc.)?

crichards: ``As for shutdown, hit GTRL+ALT+Fx, where x is a number between 1 and 6.''

I've seen cases where that would log the user off. Quite a rude surprise when you have several windows open and work is then lost. Nice security feature, I suppose, but not too good when you're trying to help out a user and your attempt to get to a console wipes out that document they were working on.
 
Old 03-24-2003, 05:24 PM   #6
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Quote:
Originally posted by sparrot
running mandrake 8.0 using X.....

1......
Cannot shutdown system from login area....resorting to powercut...OOCH!!
What Window Manager/Desktop Environment are you using? When you select "logout" or "quit" in X, does it bring you back to a GUI login prompt? If there is no "shutdown" option, then you should be able to hit CTRL+ALT+Backspace to kill your X and get to a text command line. You might have to su to root before typing shutdown -h now. This will halt your system and tell you when it's safe to power off. If CTRL+ALT+Backspace doesn't work, try CTRL+ALT+F2 then su to root and do the command above. This should work and by this point, all your work should've been saved if you're trying to shutdown anyway.

Quote:
2........
Cannot configure soundcard....."modprobe: cannot locate module ISA-PNP"
You have the wrong module. The SoundBlaster 16 should have a module of sb. You can do as root:

modprobe sb

Also you can check your /etc/rc.d/rc.modules file and check to make sure that the line "/sbin/modprobe sb" is not commented out (no # at beginning of the line). You need to go to your /etc/modules.conf file and add the line:

alias sound-slot-0 sb
options sb io=0x220 irq=5 dma=1 dma16=5 mpu_io=0x330

You can set your ir1 to something that's free other than 5.

Quote:
[b]3.......
.
Can connect to the net, but only thru mandrake cont. centre. It says conn. to net, then cannot connect, then connects, gives me disconn. option. Can i get an easy menu conn. option??[b/]
Open a terminal, and as root type netconfig. Have your ISPs DNS and DHCP info handy.

Quote:
4........
Cannot seem to use filenames with spaces in text line....>(
Read what rnturn had to say on this.

Quote:
5.......
Would appreciate some info on GTK...uses and .structure.

Know its a bit, any help thanked 4.
I have no idea about GTK, but I'm sure someone here does. Good luck and I hope this helps you out some.
 
Old 03-25-2003, 12:31 AM   #7
sparrot
LQ Newbie
 
Registered: Nov 2002
Posts: 27

Original Poster
Rep: Reputation: 15
sound:
have rc0.d thru rc6.d......no rc.modules file, no mention of modprobe sb in S71sound file....
Changed modules.conf accordingly.....no effect. I now know vi! need to restart?? soon know..testing shutdown.......
 
Old 03-25-2003, 12:42 AM   #8
sparrot
LQ Newbie
 
Registered: Nov 2002
Posts: 27

Original Poster
Rep: Reputation: 15
shutdown works with halt....thx.
 
Old 03-26-2003, 03:02 AM   #9
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Can you post the output of ls /etc/rc.d for me? I'm curious to see what you have in there. Here's mine:
Code:
phyx@frankenstein:/$ ls /etc/rc.d
rc.0@  rc.S*            rc.gpm-sample*  rc.local*    rc.sendmail*  rc.yp*
rc.4*  rc.acpid*        rc.httpd*       rc.modules*  rc.serial*
rc.6*  rc.atalk*        rc.inet1*       rc.news@     rc.sshd*
rc.K*  rc.font.sample*  rc.inet1.OLD*   rc.nfsd*     rc.syslog*
rc.M*  rc.gpm*          rc.inet2*       rc.pcmcia*   rc.sysvinit*
I'm sure that distributions will vary with their file setups, but since you've got rc0.d through rc6.d I'm guessing that these are directories under /etc? Try to find rc.modules by typing:

locate rc.modules
or
whereis rc.modules
Code:
phyx@frankenstein:/$ whereis rc.modules
rc: /etc/rc.d
phyx@frankenstein:/$ locate rc.modules
/etc/rc.d/rc.modules
phyx@frankenstein:/$
You may very well not have this file but I'm not a Drake user anymore so I can't remember where the equivalent of it lies. We'll get your sound working yet.

Last edited by Texicle; 03-26-2003 at 03:04 AM.
 
Old 03-26-2003, 04:33 AM   #10
sparrot
LQ Newbie
 
Registered: Nov 2002
Posts: 27

Original Poster
Rep: Reputation: 15
ls etc/rc.d

init.d/ rc0.d/--rc6.d/
rc* rc.modules* rc.local* rc.sysinit*
rc.firewall

thats it.
 
Old 03-26-2003, 06:23 PM   #11
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
Great! So you've got rc.modules in /etc/rc.d. The full file name is:

/etc/rc.d/rc.modules

Now you need to edit the file to remove the # in front of the appropriate line. Since you now know vi, you need to edit it as root:

vi /etc/rc.d/rc.modules

Use your arrow keys to get to the line that says:

#/sbin/modprobe sb

Then, get rid of the # sign in front of it. Save the file. This should do it for you.

Are all the other issues still issues or have you solved them?
 
Old 03-27-2003, 05:08 AM   #12
sparrot
LQ Newbie
 
Registered: Nov 2002
Posts: 27

Original Poster
Rep: Reputation: 15
not there...as follows

#!/bin/sh
#.....descriptive...5lines....
[ -f /etc/modules ] || exit 0

# loop over every line in /etc/modules.
(cat /etc/modules; echo)
while read module args
do
case"$module" in
/#*|"") continue;;
esac
initlog -s "loading module: $module"
modprobe $module args >/dev/null 2>&1
done

must i add the line, or is it more than that??
 
Old 03-27-2003, 05:46 PM   #13
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
It seems as though your rc.modules file is calling on modules listed in /etc/modules. Is "modules" in /etc a file or a directory? If it's a file, check to see if you've got the module in there and if it's commented out or not. If it's commented out it will have a # at the beginning of the line. Try removing that. If it's a file, can you post the contents of it here? If it's a directory, see what is in it and let me know. Thanks.
 
Old 03-27-2003, 11:03 PM   #14
sparrot
LQ Newbie
 
Registered: Nov 2002
Posts: 27

Original Poster
Rep: Reputation: 15
etc/modules exists bu is nothing...cat=new prompt.
have also modules.conf+modules.conf~.....neither have that line...is there an easy way to cut+paste text from terminal(rxvt)?
 
Old 03-27-2003, 11:13 PM   #15
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
You can highlight the text you want to paste somewhere, then click use your middle mouse button to paste it where ever you want. If you have only 2 buttons, and your "emulate3buttons" option is enabled in XF86Config files, then you just highlight the text you want to paste, then put your pointer where you want to paste, then click both buttons at the same time. If you have a wheel mouse, use the wheel the same as the middle button.

BTW, I'm really hoping someone with your distribution will jump in on this conversation as I'm running out of ideas here.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A small help Gins Linux - General 4 05-31-2005 04:37 PM
Small Fonts... Too much small! cubax Debian 3 03-28-2005 12:31 PM
Mandrake 10 Software Hitches ant123 Linux - Software 2 10-25-2004 10:51 AM
Openldap with small directory very small iholdap Linux - Networking 5 10-04-2003 09:09 AM
3 small problems in 1 small post vzzt! Linux - Software 10 02-27-2003 08:40 PM


All times are GMT -5. The time now is 03:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration