LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-20-2009, 03:56 PM   #1
fixeyeson
LQ Newbie
 
Registered: Nov 2007
Posts: 5

Rep: Reputation: 0
4Gb limitation on my 1Tb external hard driver


Hi guys,
I got 1Tb external hard driver install in SUSE 11.0. Everything is fine just plug and play. The problem is when I want to copy a big file (i.e 7Gb, 10Gb) it stopped at 4Gb limitation. It said something like: "Could not write to file /media/MyBook .."
Anyone get an idea about this? I guest I should do something with security or permission but I don't know how.
Many thanks in advanced.

-FiX

Last edited by fixeyeson; 04-20-2009 at 04:00 PM.
 
Old 04-20-2009, 04:04 PM   #2
the trooper
Senior Member
 
Registered: Jun 2006
Location: England
Distribution: Debian Jessie Amd64
Posts: 1,477

Rep: Reputation: Disabled
I would suspect that the external hard drive is formatted with the 'fat' filesystem.
Because of this you are limited to a 4gb filesize.
The following link gives you some background:

http://en.wikipedia.org/wiki/File_Allocation_Table

You will need to change the filesystem type to get around this.
 
Old 04-20-2009, 04:38 PM   #3
fixeyeson
LQ Newbie
 
Registered: Nov 2007
Posts: 5

Original Poster
Rep: Reputation: 0
My file system is vfat.
What you suggest is format my external hdd to change it to ntfs system ?
could you tell me more detail about it ?
Thanks
 
Old 04-20-2009, 06:38 PM   #4
jmite
Member
 
Registered: Jun 2008
Distribution: Ubuntu
Posts: 266

Rep: Reputation: 36
Here's the question. Do you still have windows? Do you need to write to the drive, or just read from it?

If you still have windows, there's a way to convert FAT to NTFS, which wouldn't have a size limit, without wiping away all your files. Theres a risk of data loss, but it's not a sure thing.

I'm not sure how linux support for NTFS is. I know it can read it, but I'm not sure how write support is.

Alternately, if you are able to wipe out your external hard drive, format it to ext2, ext3, jfs, xfs, or another linux file system. WARNING: this will delete all data on the hard drive. don't do this if you still need those files.
 
Old 04-20-2009, 07:03 PM   #5
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 15,176

Rep: Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945Reputation: 1945
When Windoze is involved I use NTFS for (large) data movement I don't care if I lose(*) - the ntfs-3g support is fine. The problem with NTFS is that you must have access to a Windoze system if there are errors on the partition - being a proprietary format, you have to chkdsk it from Windoze. Obviously not an issue if you are concerned about moving stuff between Win and Linux.
Else just use any of the available filesystems. (I prefer no to use any of the IFSs to read Linux f/s from Windoze - bad experiences in the past).

(*): meaning I use them as transition only - I copy the data to the external, and (maybe) copy then to Linux. If the external gets trashed who cares, the original is still intact.

Last edited by syg00; 04-20-2009 at 07:06 PM.
 
Old 04-20-2009, 11:30 PM   #6
fixeyeson
LQ Newbie
 
Registered: Nov 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you guys for your advices. I use dual boot SUSE/Window but I use SUSE most of my time. My external HDD was used only for storing my data. I should say again my problem occur only when I transfer the file that is lager than 4Gb. If the all the file smaller it will be fine. I have already filled my 30Gb/1Tb of my external HDD.
So the solution is change from FAT to NTFS format. I found some more advices here
Any suggestion that how NTFS compatible with Linux SUSE 11.0 ? I check on the internet that you have to mount the HDD every time you restart the PC and it seems rather unstable ?
BTW, I will first contact my customer services because my HDD still new. Let see what is their suggestion.

Last edited by fixeyeson; 04-20-2009 at 11:34 PM.
 
Old 04-21-2009, 12:27 AM   #7
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
The support with NTFS as said earlier is fine. You just need ntfs-3g package to read and write ntfs partitions. It should be available in OpneSuSe by default.
You dont need to mount the partition every time after boot if you edit your /etc/fstab file to tell suse to mount it at boot.
 
Old 04-21-2009, 11:25 PM   #8
jmite
Member
 
Registered: Jun 2008
Distribution: Ubuntu
Posts: 266

Rep: Reputation: 36
hate to link to MS, but I have to reccomend this howto:

http://technet.microsoft.com/en-us/l.../bb456984.aspx

NTFS isn't open source, but to keep your data, it's best in this paricular instance...
 
Old 04-22-2009, 04:34 PM   #9
fixeyeson
LQ Newbie
 
Registered: Nov 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Thank you very much for your advices.
I have checked with WD customer services they have some guide to change the format here
So I think I will have no problem with change the to NTFS format.

Quote:
The support with NTFS as said earlier is fine. You just need ntfs-3g package to read and write ntfs partitions. It should be available in OpneSuSe by default.
You dont need to mount the partition every time after boot if you edit your /etc/fstab file to tell suse to mount it at boot.
@chaitanya: could you please tell me more detail about mounting problem.
I just practice with my 500Gb HDD. I can mount it with
Quote:
su -c 'mount -t ntfs-3g /dev/sdb1 /mnt/500Gb'
But I can't make it run every time I restart my computer. Sometime the path was changed when I plug my USB in. For example it will change to /dev/sdc1 or ...
Thanks.
-FIX
 
Old 04-22-2009, 06:05 PM   #10
jmite
Member
 
Registered: Jun 2008
Distribution: Ubuntu
Posts: 266

Rep: Reputation: 36
you could try using a UUID instead of a /dev reference.

You can see the UUID of devices with the command blkid
 
Old 04-22-2009, 06:22 PM   #11
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
Quote:
Originally Posted by linuxlover.chaitanya View Post
The support with NTFS as said earlier is fine. You just need ntfs-3g package to read and write ntfs partitions. It should be available in OpneSuSe by default.
You dont need to mount the partition every time after boot if you edit your /etc/fstab file to tell suse to mount it at boot.
For an external drive, if the automounting works, leave your fstab alone. If you add the drive to /etc/fstab, HAL will not automount it for you.

If not, use the UUID of the filesystem instead of the device node and use the "noauto" option. Also use the "user" or "users" option so you can mount it as a regular user. Using the UUID, the partition will be mounted even if the device node is different. If the drive is unplugged or turned off, automounting it at boot can cause boot up to fail. Hence the "noauto" is needed to prevent this.

I would recommend a native Linux filesystem. If you don't connect it to a windows machine, you can use samba to share it with your windows machine on the network. Using ntfs, you can't save files with Linux permissions or timestamps unless you archive it instead of saving files. You could partition it with a smaller ntfs partition if you want to hook it to a windows machine. Also, while Linux can save files on an NTFS filesystem, it can't fully repair one if something goes wrong. For that you need windows.

Last edited by jschiwal; 04-22-2009 at 06:26 PM.
 
Old 04-29-2009, 09:23 AM   #12
fixeyeson
LQ Newbie
 
Registered: Nov 2007
Posts: 5

Original Poster
Rep: Reputation: 0
Hi,
I am trying to use blkid and UUID but I could not get it work. I could not get blkid command run in SUSE 11.0. What I did is search in YAST and install all the related package.
Could anyone tell me detail how to use blkid and UUID to get my NTFS external HDD run automatically ? Sorry I am still newbie in Linux.
Thanks,
 
Old 04-30-2009, 12:30 AM   #13
linuxlover.chaitanya
Senior Member
 
Registered: Apr 2008
Location: Nagpur, India
Distribution: Cent OS 5/6, Ubuntu Server 10.04
Posts: 4,629

Rep: Reputation: Disabled
This is what your fstab entry should look like. You will need to change the UUID and mount points and other details that are specific to your needs.

Code:
UUID=0ac1c898-a214-438c-b603-791411e18b45 /               ext3    relatime,errors=remount-ro 0       1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Limitation of hpijs printer driver? vharishankar Linux - Hardware 0 09-30-2006 04:36 AM
What is the best distro for a 1GB Hard Disk? carbontwelve Linux - Distributions 4 06-17-2006 03:59 PM
linux installation on 1gb hard disk delmoras Linux - Newbie 5 02-22-2006 05:01 AM
RHEL4 sees only 1GB out of 4GB RAM saarb16 Linux - General 1 02-21-2006 10:36 AM
4GB hard disk is 2GB LinuxRam Linux - Newbie 7 08-25-2004 01:02 AM


All times are GMT -5. The time now is 01:00 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration